Welcome! Log In Create A New Profile

Advanced

NSA320: latest uboot, latest kernel - still no hwmon?

Posted by shivahoj 
NSA320: latest uboot, latest kernel - still no hwmon?
November 29, 2016 05:40AM
Hello,
i managed to update both of my NSA-320 to the latest U-Boot(2016.05) and kernel(4.8.3)
For the half bricked one, i succeeded in kwbooting and then installing u-Boot.
The other one i updated by the regular method ( boot a 4.2.x kernel from SATA hdd , and then following the appropriate steps for flashing nand / creating the files in /boot.
But now, as all is up and running, upon installing lm-sensors, i still have no hwmon module, and the sys/class/hwmon/directory ist still empty.
I did this upgrade to the latest Software partly because i thought all these old-days problems would be sorted out by now...
Is there anything else i have to do (apart from insmod nsa3xx_hwmon, maybe)?
Would log Output (like dmesg or fw_printenv) be of any help?

I run a munin node on the NSAs, which would be complete if it gave me fan RPMs and temperature(s).
This is of course not a must, but would be fancy...

2 Pieces NSA320 , u-boot 2016.05, debian with Kernel 4.8.3, Several Mac and Linux boxes connected.
More into soldering than programming. Location:Hildesheim, Germany
Re: NSA320: latest uboot, latest kernel - still no hwmon?
November 29, 2016 03:45PM
shivahoj,

Quote

Updated 10 Oct 2016:

Kernel linux-4.8.0-kirkwood-tld-1 package has been uploaded. The following features were added/updated:

- Marvell CESA driver improvement
- NSA320 hwmon: hardware monitoring module name is now named nsa320-hwmon. This module might work for other Zyxel NSA3xx also.

Try
modprobe nsa320-hwmon

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner
Re: NSA320: latest uboot, latest kernel - still no hwmon?
November 30, 2016 11:24PM
This did not work unfortunately:
root@publik:~# modprobe nsa320-hwmon
modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file '/lib/modules/4.8.3-kirkwood-tld-1/modules.dep.bin'
root@publik:~# depmod
depmod: ERROR: could not open directory /lib/modules/4.8.3-kirkwood-tld-1: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
root@publik:~# find / -name nsa320*
/media/div/software/OSX/nsa320-alarm.tar.gz
/sys/devices/platform/gpio-leds/leds/nsa320:green:usb
/sys/devices/platform/gpio-leds/leds/nsa320:green:hdd2
/sys/devices/platform/gpio-leds/leds/nsa320:orange:sys
/sys/devices/platform/gpio-leds/leds/nsa320:red:hdd1
/sys/devices/platform/gpio-leds/leds/nsa320:green:copy
/sys/devices/platform/gpio-leds/leds/nsa320:green:sys
/sys/devices/platform/gpio-leds/leds/nsa320:red:hdd2
/sys/devices/platform/gpio-leds/leds/nsa320:green:hdd1
/sys/devices/platform/gpio-leds/leds/nsa320:red:copy
/sys/class/leds/nsa320:green:usb
/sys/class/leds/nsa320:green:hdd2
/sys/class/leds/nsa320:orange:sys
/sys/class/leds/nsa320:red:hdd1
/sys/class/leds/nsa320:green:copy
/sys/class/leds/nsa320:green:sys
/sys/class/leds/nsa320:red:hdd2
/sys/class/leds/nsa320:green:hdd1
/sys/class/leds/nsa320:red:copy
root@publik:~# find / -name modules.dep.bin
/lib/modules/4.4.0-kirkwood-tld-1/modules.dep.bin
root@publik:~#



Edited 1 time(s). Last edit at 11/30/2016 11:44PM by shivahoj.
Re: NSA320: latest uboot, latest kernel - still no hwmon?
December 01, 2016 07:17AM
shivahoj Wrote:
-------------------------------------------------------
> This did not work unfortunately:
> root@publik:~# modprobe nsa320-hwmon
> modprobe: ERROR: ../libkmod/libkmod.c:557
> kmod_search_moddep() could not open moddep file
> '/lib/modules/4.8.3-kirkwood-tld-1/modules.dep.bin
> '
> root@publik:~# depmod
> depmod: ERROR: could not open directory
> /lib/modules/4.8.3-kirkwood-tld-1: No such file or
> directory
> depmod: FATAL: could not search modules: No such
> file or directory
> root@publik:~# find / -name nsa320*
> /media/div/software/OSX/nsa320-alarm.tar.gz
> /sys/devices/platform/gpio-leds/leds/nsa320:green:
> usb
> /sys/devices/platform/gpio-leds/leds/nsa320:green:
> hdd2
> /sys/devices/platform/gpio-leds/leds/nsa320:orange
> :sys
> /sys/devices/platform/gpio-leds/leds/nsa320:red:hd
> d1
> /sys/devices/platform/gpio-leds/leds/nsa320:green:
> copy
> /sys/devices/platform/gpio-leds/leds/nsa320:green:
> sys
> /sys/devices/platform/gpio-leds/leds/nsa320:red:hd
> d2
> /sys/devices/platform/gpio-leds/leds/nsa320:green:
> hdd1
> /sys/devices/platform/gpio-leds/leds/nsa320:red:co
> py
> /sys/class/leds/nsa320:green:usb
> /sys/class/leds/nsa320:green:hdd2
> /sys/class/leds/nsa320:orange:sys
> /sys/class/leds/nsa320:red:hdd1
> /sys/class/leds/nsa320:green:copy
> /sys/class/leds/nsa320:green:sys
> /sys/class/leds/nsa320:red:hdd2
> /sys/class/leds/nsa320:green:hdd1
> /sys/class/leds/nsa320:red:copy
> root@publik:~# find / -name modules.dep.bin
> /lib/modules/4.4.0-kirkwood-tld-1/modules.dep.bin
> root@publik:~#
>

Looks like your kernel installation was not successful. Pls get output of:
uname -a
ls -lart /boot
ls /lib/modules -lart
dpkg -l | grep -i linux-image | grep '4.8.3'

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner



Edited 1 time(s). Last edit at 12/01/2016 07:19AM by bodhi.
Re: NSA320: latest uboot, latest kernel - still no hwmon?
December 01, 2016 10:34AM
Hello, here is the info you requested:
root@publik:~# uname -a
Linux publik 4.8.3-kirkwood-tld-1 #1 PREEMPT Thu Oct 20 23:33:18 PDT 2016 armv5tel GNU/Linux
root@publik:~# ls -lart /boot
total 76184
-rw-r--r--  1 root root   140949 Jan 26  2016 config-4.4.0-kirkwood-tld-1
-rwxr-xr-x  1 root root  3154832 Jan 26  2016 zImage-4.4.0-kirkwood-tld-1
-rw-------  1 root root  3154832 Jan 26  2016 vmlinuz-4.4.0-kirkwood-tld-1
-rw-------  1 root root  2240040 Jan 26  2016 System.map-4.4.0-kirkwood-tld-1
-rw-r--r--  1 root root  7511582 Jan 26  2016 linux-headers-4.4.0-kirkwood-tld-1_1.0_armel.deb
drwxr-xr-x  2 root root     4096 Jan 26  2016 dts
-rw-r--r--  1 root root   146396 Oct 21 07:38 config-4.8.3-kirkwood-tld-1
-rwxr-xr-x  1 root root  3232304 Oct 21 08:34 zImage-4.8.3-kirkwood-tld-1
-rw-------  1 root root  3232304 Oct 21 11:30 vmlinuz-4.8.3-kirkwood-tld-1
-rw-------  1 root root  2361548 Oct 21 11:30 System.map-4.8.3-kirkwood-tld-1
-rw-r--r--  1 root root 17941540 Oct 21 11:36 linux-image-4.8.3-kirkwood-tld-1_1.0_armel.deb
-rw-r--r--  1 root root  8006718 Oct 21 11:51 linux-headers-4.8.3-kirkwood-tld-1_1.0_armel.deb
-rw-r--r--  1 root root  1249280 Oct 23 10:52 linux-dtb-4.8.3-kirkwood-tld-1.tar
-rw-r--r--  1 root root   144044 Oct 24 10:06 linux-4.8.3-kirkwood-tld-1.patch
-rw-r--r--  1 dirk dirk       85 Nov 11 03:25 uEnv.txt
-rw-r--r--  1 root root  7313648 Nov 26 18:40 initrd.img-4.8.3-kirkwood-tld-1
-rw-r--r--  1 root root  3232368 Nov 26 18:41 uImage
-rw-r--r--  1 root root  7313712 Nov 26 18:41 uInitrd
-rw-r--r--  1 root root  7448772 Nov 28 17:20 initrd.img-4.4.0-kirkwood-tld-1
drwxr-xr-x  3 root root     4096 Nov 28 17:20 .
drwxr-xr-x 24 root root     4096 Nov 28 19:24 ..
root@publik:~# ls /lib/modules -lart
total 12
drwxr-xr-x  3 root root 4096 Feb 19  2016 4.4.0-kirkwood-tld-1
drwxr-xr-x  3 root root 4096 Feb 19  2016 .
drwxr-xr-x 16 root root 4096 Nov 28 19:54 ..
root@publik:~# dpkg -l | grep -i linux-image | grep '4.8.3'
root@publik:~#
In the Meantime i also tried:
root@publik:~# dpkg -i  /boot/linux-headers-4.8.3-kirkwood-tld-1_1.0_armel.deb
Selecting previously unselected package linux-headers-4.8.3-kirkwood-tld-1.
(Reading database ... 21843 files and directories currently installed.)
Preparing to unpack .../linux-headers-4.8.3-kirkwood-tld-1_1.0_armel.deb ...
Unpacking linux-headers-4.8.3-kirkwood-tld-1 (1.0) ...
Setting up linux-headers-4.8.3-kirkwood-tld-1 (1.0) ...
Examining /etc/kernel/header_postinst.d.

root@publik:~# dpkg -i  /boot/linux-image-4.8.3-kirkwood-tld-1_1.0_armel.deb
Selecting previously unselected package linux-image-4.8.3-kirkwood-tld-1.
(Reading database ... 38449 files and directories currently installed.)
Preparing to unpack .../linux-image-4.8.3-kirkwood-tld-1_1.0_armel.deb ...
Examining /etc/kernel/preinst.d/
Done.
Unpacking linux-image-4.8.3-kirkwood-tld-1 (1.0) ...
Setting up linux-image-4.8.3-kirkwood-tld-1 (1.0) ...

 Hmm. There is a symbolic link /lib/modules/4.8.3-kirkwood-tld-1/build
 However, I can not read it: No such file or directory
 Therefore, I am deleting /lib/modules/4.8.3-kirkwood-tld-1/build


 Hmm. The package shipped with a symbolic link /lib/modules/4.8.3-kirkwood-tld-1/source
 However, I can not read the target: No such file or directory
 Therefore, I am deleting /lib/modules/4.8.3-kirkwood-tld-1/source

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.8.3-kirkwood-tld-1 /boot/vmlinuz-4.8.3-kirkwood-tld-1
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.8.3-kirkwood-tld-1 /boot/vmlinuz-4.8.3-kirkwood-tld-1
update-initramfs: Generating /boot/initrd.img-4.8.3-kirkwood-tld-1
run-parts: executing /etc/kernel/postinst.d/zz-flash-kernel 4.8.3-kirkwood-tld-1 /boot/vmlinuz-4.8.3-kirkwood-tld-1
root@publik:~#
now i can do modprobe nsa320-hwmon, but sensors-detect stil doesnt find anything
root@publik:~# ls -la /lib/modules
total 16
drwxr-xr-x  4 root root 4096 Dec  1 16:20 .
drwxr-xr-x 16 root root 4096 Nov 28 19:54 ..
drwxr-xr-x  3 root root 4096 Feb 19  2016 4.4.0-kirkwood-tld-1
drwxr-xr-x  3 root root 4096 Dec  1 16:21 4.8.3-kirkwood-tld-1
root@publik:~# mc

root@publik:~# depmod
root@publik:~# modprobe nsa320-hwmon
root@publik:~# lsmod
Module                  Size  Used by
nsa320_hwmon            2674  0
ext2                   56892  1
sg                     22105  0
sd_mod                 30181  7
uas                    12360  0
usb_storage            42905  2 uas
sata_mv                25034  3
libata                172604  1 sata_mv
fixed                   2665  0
scsi_mod              174030  5 sd_mod,usb_storage,libata,uas,sg
root@publik:~# sensors-detect
# sensors-detect revision 6209 (2014-01-14 22:51:58 +0100)
# DMI data unavailable, please consider installing dmidecode 2.7
# or later for better results.

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no):
modprobe: FATAL: Module cpuid not found.
Failed to load module cpuid.
Silicon Integrated Systems SIS5595...                       No
VIA VT82C686 Integrated Sensors...                          No
VIA VT8231 Integrated Sensors...                            No
AMD K8 thermal sensors...                                   No
AMD Family 10h thermal sensors...                           No
AMD Family 11h thermal sensors...                           No
AMD Family 12h and 14h thermal sensors...                   No
AMD Family 15h thermal sensors...                           No
AMD Family 15h power sensors...                             No
AMD Family 16h power sensors...                             No
Intel digital thermal sensor...                             No
Intel AMB FB-DIMM thermal sensor...                         No
VIA C7 thermal sensor...                                    No
VIA Nano thermal sensor...                                  No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): y
Sorry, no supported PCI bus adapters found.

Next adapter: mv64xxx_i2c adapter (i2c-0)
Do you want to scan it? (YES/no/selectively): y
Client found at address 0x50
Probing for `Analog Devices ADM1033'...                     No
Probing for `Analog Devices ADM1034'...                     No
Probing for `SPD EEPROM'...                                 No
Probing for `EDID EEPROM'...                                No
Client found at address 0x51
Handled by driver `rtc-pcf8563' (built-in), chip type `pcf8563'
    (note: this is probably NOT a sensor chip!)

Sorry, no sensors were detected.
Either your system has no sensors, or they are not supported, or
they are connected to an I2C or SMBus adapter that is not
supported. If you find out what chips are on your board, check
http://www.lm-sensors.org/wiki/Devices for driver status.
root@publik:~#
After a reboot lsmod looks different(no insmod was required), but sensors detect still fails:
root@publik:~# dpkg -l | grep -i linux-image
ii  linux-image-4.4.0-kirkwood-tld-1   1.0                           armel        Linux kernel binary image for version 4.4.0-kirkwood-tld-1
ii  linux-image-4.8.3-kirkwood-tld-1   1.0                           armel        Linux kernel binary image for version 4.8.3-kirkwood-tld-1
root@publik:~# lsmod
Module                  Size  Used by
ipv6                  329888  55
nsa3xx_hwmon            4052  0
fuse                   77715  0
evdev                  10965  0
marvell_cesa           25670  0
des_generic            16866  1 marvell_cesa
orion_wdt               6105  0
uio_pdrv_genirq         2914  0
nsa320_hwmon            2674  0
uio                     7199  1 uio_pdrv_genirq
gpio_keys               7762  0
ext2                   56892  1
sg                     22105  0
sd_mod                 30181  7
uas                    12360  0
usb_storage            42905  2 uas
sata_mv                25034  3
libata                172604  1 sata_mv
fixed                   2665  0
scsi_mod              174030  5 sd_mod,usb_storage,libata,uas,sg
root@publik:~#



Edited 3 time(s). Last edit at 12/01/2016 03:22PM by shivahoj.
Re: NSA320: latest uboot, latest kernel - still no hwmon?
December 01, 2016 06:25PM
Re: NSA320: latest uboot, latest kernel - still no hwmon?
December 01, 2016 06:31PM
Re: NSA320: latest uboot, latest kernel - still no hwmon?
December 02, 2016 03:35PM
this is my most recent dmesg output, there is no hwmon-related error AFAIK. Could the "local-mac-address is not set" thing in the beginning be related to my netcat not running?
root@publik:~# dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.8.3-kirkwood-tld-1 (root@tldDebian) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 PREEMPT Thu Oct 20 23:33:18 PDT 2016
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=0005397f
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] OF: fdt:Machine model: Zyxel NSA320
[    0.000000] Memory policy: Data cache writeback
[    0.000000] On node 0 totalpages: 131072
[    0.000000] free_area_init_node: node 0, pgdat c08b1e78, node_mem_map dfbf9000
[    0.000000]   Normal zone: 1024 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 131072 pages, LIFO batch:31
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130048
[    0.000000] Kernel command line: console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 mtdparts=mtdparts=orion_nand:1M(u-boot),512K(uboot_env),512K(key_store),512K(info),10M(etc),10M(kernel_1),48896K(rootfs1),10M(kernel_2),-(rootfs2)
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 503240K/524288K available (6149K kernel code, 614K rwdata, 1664K rodata, 308K init, 318K bss, 21048K reserved, 0K cma-reserved)
[    0.000000] Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
    vmalloc : 0xe0800000 - 0xff800000   ( 496 MB)
    lowmem  : 0xc0000000 - 0xe0000000   ( 512 MB)
    modules : 0xbf000000 - 0xc0000000   (  16 MB)
      .text : 0xc0008000 - 0xc0609718   (6150 kB)
      .init : 0xc07dd000 - 0xc082a000   ( 308 kB)
      .data : 0xc082a000 - 0xc08c391c   ( 615 kB)
       .bss : 0xc08c391c - 0xc0913170   ( 319 kB)
[    0.000000] Preemptible hierarchical RCU implementation.
[    0.000000] 	Build-time adjustment of leaf fanout to 32.
[    0.000000] NR_IRQS:16 nr_irqs:16 16
[    0.000000] clocksource: orion_clocksource: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 9556302233 ns
[    0.000010] sched_clock: 32 bits at 200MHz, resolution 5ns, wraps every 10737418237ns
[    0.000544] Console: colour dummy device 80x30
[    0.000579] Calibrating delay loop... 1196.85 BogoMIPS (lpj=5984256)
[    0.090102] pid_max: default: 32768 minimum: 301
[    0.090318] Security Framework initialized
[    0.090473] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.090496] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.091593] CPU: Testing write buffer coherency: ok
[    0.092012] Setting up static identity map for 0x8200 - 0x8258
[    0.092302] mvebu-soc-id: MVEBU SoC ID=0x6281, Rev=0x3
[    0.096373] devtmpfs: initialized
[    0.103253] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.103522] prandom: seed boundary self test passed
[    0.107262] prandom: 100 self tests passed
[    0.107275] pinctrl core: initialized pinctrl subsystem
[    0.108548] NET: Registered protocol family 16
[    0.109034] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.130112] cpuidle: using governor ladder
[    0.160110] cpuidle: using governor menu
[    0.160536] Feroceon L2: Enabling L2
[    0.160583] Feroceon L2: Cache support initialised.
[    0.160989] [Firmware Info]: /ocp@f1000000/ethernet-controller@72000/ethernet0-port@0: local-mac-address is not set
[    0.166858] No ATAGs?
[    0.201638] vgaarb: loaded
[    0.201965] usbcore: registered new interface driver usbfs
[    0.202046] usbcore: registered new interface driver hub
[    0.202131] usbcore: registered new device driver usb
[    0.203247] clocksource: Switched to clocksource orion_clocksource
[    0.249411] VFS: Disk quotas dquot_6.6.0
[    0.249500] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.261510] NET: Registered protocol family 2
[    0.262333] TCP established hash table entries: 4096 (order: 2, 16384 bytes)
[    0.262394] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[    0.262447] TCP: Hash tables configured (established 4096 bind 4096)
[    0.262509] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.262533] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.262715] NET: Registered protocol family 1
[    0.263301] RPC: Registered named UNIX socket transport module.
[    0.263314] RPC: Registered udp transport module.
[    0.263322] RPC: Registered tcp transport module.
[    0.263330] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.263342] PCI: CLS 0 bytes, default 32
[    0.263590] Unpacking initramfs...
[    0.915398] Freeing initrd memory: 7144K (cf906000 - d0000000)
[    0.915521] NetWinder Floating Point Emulator V0.97 (double precision)
[    0.916545] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.916593] audit: initializing netlink subsys (disabled)
[    0.916643] audit: type=2000 audit(0.910:1): initialized
[    0.916983] Initialise system trusted keyrings
[    0.917183] workingset: timestamp_bits=30 max_order=17 bucket_order=0
[    0.917280] zbud: loaded
[    0.918206] NFS: Registering the id_resolver key type
[    0.918233] Key type id_resolver registered
[    0.918243] Key type id_legacy registered
[    0.918261] nfs4filelayout_init: NFSv4 File Layout Driver Registering...
[    0.918271] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[    0.918546] jffs2: version 2.2. (NAND) (SUMMARY)  \xffffffc2\xffffffa9 2001-2006 Red Hat, Inc.
[    0.918831] orangefs_init: called with debug mask: :none: :0:
[    0.919238] orangefs: module version upstream loaded
[    0.919491] Key type big_key registered
[    2.553255] random: fast init done
[    5.010895] Key type asymmetric registered
[    5.010912] Asymmetric key parser 'x509' registered
[    5.010995] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 249)
[    5.011008] io scheduler noop registered
[    5.011016] io scheduler deadline registered
[    5.011049] io scheduler cfq registered (default)
[    5.012434] kirkwood-pinctrl f1010000.pin-controller: registered pinctrl driver
[    5.013562] irq: Cannot allocate irq_descs @ IRQ34, assuming pre-allocated
[    5.014229] irq: Cannot allocate irq_descs @ IRQ66, assuming pre-allocated
[    5.015047] mvebu-pcie mbus:pcie-controller: PCI host bridge to bus 0000:00
[    5.015068] pci_bus 0000:00: root bus resource [io  0x1000-0xfffff]
[    5.015082] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xefffffff]
[    5.015096] pci_bus 0000:00: root bus resource [bus 00-ff]
[    5.015109] pci_bus 0000:00: scanning bus
[    5.015150] pci 0000:00:01.0: [11ab:6281] type 01 class 0x060400
[    5.015197] pci 0000:00:01.0: calling pci_fixup_ide_bases+0x0/0x40
[    5.015455] pci_bus 0000:00: fixups for bus
[    5.015467] PCI: bus0: Fast back to back transfers disabled
[    5.015483] pci 0000:00:01.0: scanning [bus 00-00] behind bridge, pass 0
[    5.015491] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    5.015509] pci 0000:00:01.0: scanning [bus 00-00] behind bridge, pass 1
[    5.015675] pci_bus 0000:01: scanning bus
[    5.015686] pci_bus 0000:01: fixups for bus
[    5.015691] PCI: bus1: Fast back to back transfers enabled
[    5.015703] pci_bus 0000:01: bus scan returning with max=01
[    5.015714] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    5.015726] pci_bus 0000:00: bus scan returning with max=01
[    5.015738] pci 0000:00:01.0: fixup irq: got 0
[    5.015745] pci 0000:00:01.0: assigning IRQ 00
[    5.015766] pci 0000:00:01.0: PCI bridge to [bus 01]
[    5.015850] pcieport 0000:00:01.0: enabling bus mastering
[    5.016088] mv_xor f1060800.xor: Marvell shared XOR driver
[    5.073985] mv_xor f1060800.xor: Marvell XOR (Registers Mode): ( xor cpy intr )
[    5.074202] mv_xor f1060900.xor: Marvell shared XOR driver
[    5.133973] mv_xor f1060900.xor: Marvell XOR (Registers Mode): ( xor cpy intr )
[    5.134461] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    5.135915] console [ttyS0] disabled
[    5.135979] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 26, base_baud = 12500000) is a 16550A
[    5.783795] console [ttyS0] enabled
[    5.788484] nand: device found, Manufacturer ID: 0xec, Chip ID: 0xf1
[    5.794902] nand: Samsung NAND 128MiB 3,3V 8-bit
[    5.799542] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    5.807173] Scanning device for bad blocks
[    5.893386] Bad eraseblock 852 at 0x000006a80000
[    5.905878] Bad eraseblock 934 at 0x0000074c0000
[    5.919157] 9 ofpart partitions found on MTD device orion_nand
[    5.925042] Creating 9 MTD partitions on "orion_nand":
[    5.930205] 0x000000000000-0x000000100000 : "uboot"
[    5.936602] 0x000000100000-0x000000180000 : "uboot_env"
[    5.943207] 0x000000180000-0x000000200000 : "key_store"
[    5.949869] 0x000000200000-0x000000280000 : "info"
[    5.956180] 0x000000280000-0x000000c80000 : "etc"
[    5.962344] 0x000000c80000-0x000001680000 : "kernel_1"
[    5.968911] 0x000001680000-0x000004640000 : "rootfs1"
[    5.975647] 0x000004640000-0x000005040000 : "kernel_2"
[    5.982220] 0x000005040000-0x000008000000 : "rootfs2"
[    5.990492] libphy: Fixed MDIO Bus: probed
[    5.994814] libphy: mdio_driver_register: mv88e6085
[    6.000103] libphy: orion_mdio_bus: probed
[    6.009300] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
[    6.113727] mv643xx_eth: Set the PHY to fix link down
[    6.119448] mv643xx_eth_port mv643xx_eth_port.0 eth0: port 0 with MAC address b0:b2:dc:ee:d4:f2
[    6.128525] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    6.135128] ehci-pci: EHCI PCI platform driver
[    6.139661] ehci-orion: EHCI orion driver
[    6.143901] orion-ehci f1050000.ehci: EHCI Host Controller
[    6.149442] orion-ehci f1050000.ehci: new USB bus registered, assigned bus number 1
[    6.157318] orion-ehci f1050000.ehci: irq 30, io mem 0xf1050000
[    6.193282] orion-ehci f1050000.ehci: USB 2.0 started, EHCI 1.00
[    6.199559] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    6.206412] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    6.213683] usb usb1: Product: EHCI Host Controller
[    6.218582] usb usb1: Manufacturer: Linux 4.8.3-kirkwood-tld-1 ehci_hcd
[    6.225245] usb usb1: SerialNumber: f1050000.ehci
[    6.230771] hub 1-0:1.0: USB hub found
[    6.234628] hub 1-0:1.0: 1 port detected
[    6.239533] mousedev: PS/2 mouse device common for all mice
[    6.245845] rtc-mv f1010300.rtc: rtc core: registered f1010300.rtc as rtc0
[    6.252895] i2c /dev entries driver
[    6.259342] rtc-pcf8563 0-0051: low voltage detected, date/time is not reliable.
[    6.267055] rtc-pcf8563 0-0051: rtc core: registered rtc-pcf8563 as rtc1
[    6.276919] hidraw: raw HID events driver (C) Jiri Kosina
[    6.282799] drop_monitor: Initializing network drop monitor service
[    6.289366] NET: Registered protocol family 17
[    6.294066] Key type dns_resolver registered
[    6.299168] registered taskstats version 1
[    6.303320] Loading compiled-in X.509 certificates
[    6.308172] zswap: loaded using pool lzo/zbud
[    6.331568] Key type encrypted registered
[    6.336215] rtc-mv f1010300.rtc: setting system clock to 2016-12-01 20:36:16 UTC (1480624576)
[    6.346300] PM: Hibernation image not present or could not be loaded.
[    6.347864] Freeing unused kernel memory: 308K (c07dd000 - c082a000)
[    6.354331] This architecture does not have kernel memory protection.
[    6.434239] systemd-udevd[96]: starting version 215
[    6.593339] usb 1-1: new high-speed USB device number 2 using orion-ehci
[    6.658723] SCSI subsystem initialized
[    6.722474] libata version 3.00 loaded.
[    6.724647] sata_mv f1080000.sata: version 1.28
[    6.724940] sata_mv f1080000.sata: slots 32 ports 2
[    6.769416] scsi host0: sata_mv
[    6.784325] scsi host1: sata_mv
[    6.787926] ata1: SATA max UDMA/133 irq 33
[    6.792044] ata2: SATA max UDMA/133 irq 33
[    6.798093] usb 1-1: New USB device found, idVendor=05e3, idProduct=0608
[    6.798102] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    6.798108] usb 1-1: Product: USB2.0 Hub
[    6.799227] hub 1-1:1.0: USB hub found
[    6.799583] hub 1-1:1.0: 4 ports detected
[    7.113278] usb 1-1.3: new high-speed USB device number 3 using orion-ehci
[    7.275328] usb 1-1.3: New USB device found, idVendor=174c, idProduct=55aa
[    7.282253] usb 1-1.3: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[    7.289636] usb 1-1.3: Product: USB 3.0 Device
[    7.294114] usb 1-1.3: Manufacturer: Intenso
[    7.298406] usb 1-1.3: SerialNumber: 3160000000000000CA08
[    7.314161] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[    7.320756] usb-storage 1-1.3:1.0: Quirks match for vid 174c pid 55aa: 400000
[    7.328096] scsi host2: usb-storage 1-1.3:1.0
[    7.334337] usbcore: registered new interface driver usb-storage
[    7.343491] usbcore: registered new interface driver uas
[    7.383302] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[    7.413503] ata1.00: ATA-8: SAMSUNG HD204UI, 1AQ10001, max UDMA/133
[    7.419799] ata1.00: 3907029168 sectors, multi 0: LBA48 NCQ (depth 31/32)
[    7.453501] ata1.00: configured for UDMA/133
[    7.468412] scsi 0:0:0:0: Direct-Access     ATA      SAMSUNG HD204UI  0001 PQ: 0 ANSI: 5
[    8.033287] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[    8.093347] ata2.00: ATA-8: WDC WD20EARS-00MVWB0, 51.0AB51, max UDMA/133
[    8.100081] ata2.00: 3907029168 sectors, multi 0: LBA48 NCQ (depth 31/32)
[    8.135593] ata2.00: configured for UDMA/133
[    8.150446] scsi 1:0:0:0: Direct-Access     ATA      WDC WD20EARS-00M AB51 PQ: 0 ANSI: 5
[    8.227917] sd 0:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[    8.239391] sd 1:0:0:0: [sdb] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[    8.249020] sd 0:0:0:0: [sda] Write Protect is off
[    8.254216] sd 1:0:0:0: [sdb] Write Protect is off
[    8.259040] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[    8.259102] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    8.259223] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    8.268443] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    8.289486]  sda: sda1 sda2
[    8.294799] sd 0:0:0:0: [sda] Attached SCSI disk
[    8.299633]  sdb: sdb1 sdb2
[    8.304947] sd 1:0:0:0: [sdb] Attached SCSI disk
[    8.312737] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    8.320320] sd 1:0:0:0: Attached scsi generic sg1 type 0
[    8.404543] scsi 2:0:0:0: Direct-Access     Intenso  USB 3.0 Device   0    PQ: 0 ANSI: 6
[    8.419835] sd 2:0:0:0: Attached scsi generic sg2 type 0
[    8.425890] sd 2:0:0:0: [sdc] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[    8.441255] sd 2:0:0:0: [sdc] Write Protect is off
[    8.446221] sd 2:0:0:0: [sdc] Mode Sense: 43 00 00 00
[    8.446986] sd 2:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    8.497641]  sdc: sdc1
[    8.505969] sd 2:0:0:0: [sdc] Attached SCSI disk
[   20.734342] systemd-udevd[316]: starting version 215
[   21.120529] input: gpio_keys as /devices/platform/gpio_keys/input/input0
[   21.371184] orion_wdt: Initial timeout 21 sec
[   21.512014] marvell-cesa f1030000.crypto: CESA device successfully registered
[   21.990381] random: crng init done
[   24.085773] fuse init (API version 7.25)
[   24.494391] EXT4-fs (sda2): Mount option "noacl" will be removed by 3.5
Contact linux-ext4@vger.kernel.org if you think we should keep it.

[   24.510904] EXT4-fs (sda2): mounting ext3 file system using the ext4 subsystem
[   24.775383] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: noacl
[   24.784165] EXT4-fs (sdb2): Mount option "noacl" will be removed by 3.5
Contact linux-ext4@vger.kernel.org if you think we should keep it.

[   24.799631] EXT4-fs (sdb2): mounting ext3 file system using the ext4 subsystem
[   25.045406] EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: noacl
[   26.184055] EXT4-fs (sdc1): Mount option "noacl" will be removed by 3.5
Contact linux-ext4@vger.kernel.org if you think we should keep it.

[   26.199537] EXT4-fs (sdc1): mounting ext3 file system using the ext4 subsystem
[   26.394355] EXT4-fs (sdc1): warning: mounting unchecked fs, running e2fsck is recommended
[   26.516938] EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: noacl
[   27.860403] NET: Registered protocol family 10
[   28.105328] mv643xx_eth: Set the PHY back to auto-negotiation mode
[   28.111658] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   30.649363] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[   30.659293] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   93.080382] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
[   93.102534] NFSD: starting 90-second grace period (net c08a83d0)
root@publik:~#



Edited 1 time(s). Last edit at 12/02/2016 11:39PM by shivahoj.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: