Welcome! Log In Create A New Profile

Advanced

Can't install webmin in new 4.12.1 Kirkwood rootfs

Posted by Chris 
Hi
i want to install webmin in your new rootfs.
i need for webmin apt-show-version, but when I install I get some errors.

root@debian:~# apt-get -f install apt-show-versions
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  apt-show-versions
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/34.3 kB of archives.
After this operation, 162 kB of additional disk space will be used.
Selecting previously unselected package apt-show-versions.
(Reading database ... 15599 files and directories currently installed.)
Preparing to unpack .../apt-show-versions_0.22.7_all.deb ...
Unpacking apt-show-versions (0.22.7) ...
Setting up apt-show-versions (0.22.7) ...
** initializing cache. This may take a while **
Killed
dpkg: error processing package apt-show-versions (--configure):
 subprocess installed post-installation script returned error exit status 137
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 apt-show-versions



Edited 1 time(s). Last edit at 07/26/2017 05:09PM by bodhi.
Re: Can't install webmin in new 4.12.1 Kirkwood rootfs
July 26, 2017 05:26PM
Hi,

I startet today with a fresh new rootfs and I get the same error

root@debian:~# apt-get install apt-show-versions
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libssl1.0.0
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  libapt-pkg-perl libperl5.24 perl perl-modules-5.24
Suggested packages:
  perl-doc libterm-readline-gnu-perl | libterm-readline-perl-perl make
Recommended packages:
  rename
The following NEW packages will be installed:
  apt-show-versions libapt-pkg-perl libperl5.24 perl perl-modules-5.24
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 5863 kB of archives.
After this operation, 34.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.us.debian.org/debian stretch/main armel perl-modules-5.24 all 5.24.1-3+deb9u1 [2723 kB]
Get:2 http://ftp.us.debian.org/debian stretch/main armel libperl5.24 armel 5.24.1-3+deb9u1 [2822 kB]
Get:3 http://ftp.us.debian.org/debian stretch/main armel perl armel 5.24.1-3+deb9u1 [219 kB]
Get:4 http://ftp.us.debian.org/debian stretch/main armel libapt-pkg-perl armel 0.1.32 [64.7 kB]
Get:5 http://ftp.us.debian.org/debian stretch/main armel apt-show-versions all 0.22.7 [34.3 kB]
Fetched 5863 kB in 7s (784 kB/s)
Selecting previously unselected package perl-modules-5.24.
(Reading database ... 12561 files and directories currently installed.)
Preparing to unpack .../perl-modules-5.24_5.24.1-3+deb9u1_all.deb ...
Unpacking perl-modules-5.24 (5.24.1-3+deb9u1) ...
Selecting previously unselected package libperl5.24:armel.
Preparing to unpack .../libperl5.24_5.24.1-3+deb9u1_armel.deb ...
Unpacking libperl5.24:armel (5.24.1-3+deb9u1) ...
Selecting previously unselected package perl.
Preparing to unpack .../perl_5.24.1-3+deb9u1_armel.deb ...
Unpacking perl (5.24.1-3+deb9u1) ...
Selecting previously unselected package libapt-pkg-perl.
Preparing to unpack .../libapt-pkg-perl_0.1.32_armel.deb ...
Unpacking libapt-pkg-perl (0.1.32) ...
Selecting previously unselected package apt-show-versions.
Preparing to unpack .../apt-show-versions_0.22.7_all.deb ...
Unpacking apt-show-versions (0.22.7) ...
Setting up perl-modules-5.24 (5.24.1-3+deb9u1) ...
Setting up libperl5.24:armel (5.24.1-3+deb9u1) ...
Setting up libapt-pkg-perl (0.1.32) ...
Setting up perl (5.24.1-3+deb9u1) ...
update-alternatives: using /usr/bin/prename to provide /usr/bin/rename (rename) in auto mode
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up apt-show-versions (0.22.7) ...
** initializing cache. This may take a while **
Killed
dpkg: error processing package apt-show-versions (--configure):
 subprocess installed post-installation script returned error exit status 137
Errors were encountered while processing:
 apt-show-versions
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@debian:

----
Mod edit: please use code tags for readability



Edited 1 time(s). Last edit at 07/27/2017 04:35PM by bodhi.
Re: Can't install webmin in new 4.12.1 Kirkwood rootfs
July 27, 2017 04:40PM
Chris,

Were you root user while executing the tar command to extract it? If you like, post the log of the session when you create the rootfs here, perhaps I can spot something out of the ordinary.

By the way, for future reference you could also use dpkg to list packages

dpkg -l

But the problem you are seeing is abnormal, I think your rootf is not good to use.

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner
apt-get install -y nginx nginx-extras php-fpm php-cgi

installation is ok

     location /webdav {    
         autoindex on;
         alias /mnt/public/
         auth_basic "Restricted Access";
         auth_basic_user_file /mnt/.htpasswd;    
         client_body_temp_path /tmp/nginx/webdav;       
         dav_methods PUT DELETE MKCOL COPY MOVE;    
         dav_ext_methods PROPFIND OPTIONS;        
         create_full_put_path  on;
         dav_access user:rw group:rw  all:r;        
     }

but nginx fail to start with "dav_ext_methods PROPFIND OPTIONS; "

I can confirm that libnginx-mod-http-dav-ext is installed.

is it bug on debian9?
it was ajenti bug not debian9.


proftpd, samba and webdav setting by webmin

proftpd, samba and webdav works good
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: