Welcome! Log In Create A New Profile

Advanced

RTL8192cu WiFi disable power save on Mele & driver update

Posted by gnexus 
RTL8192cu WiFi disable power save on Mele & driver update
July 04, 2012 08:23AM
Most A10 devices use an internal USB RTL8192cu Wifi adapter board. A picture of it is at this page in the top picture. The wifi module is just below the battery to the left of the gold flex connector going to the LCD.

The wifi is designed for a battery powered portable tablet. Therefore the kernel driver module uses a power save mode to disable the wifi when not in use. That is all nice and wonderful in most cases. But currently I am using the wifi on my Mele in server mode. So I need the wifi always working.

I am interested in driver updates due to connection problems I have on occasion with my wireless N router when I am upstairs. Realtek just released new Linux drivers for the RTL8192cu on June 22. Since we are using an older kernel obviously those driver updates will not be incorporated into it. Therefore I am going to try to backport the new driver into the 3.0.36+ kernel and see if it help to minimize the connection issues. I don't know if the update will help anything. But usually when driver updates are released there is a very good reason.

Here is the d/l page:
http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#2312

Thanks to Andrew for the info below on disabling power save on the Mele to make the wifi more reliable. Fortunately my Mele is just above the router so there are no connection issues like with the tablet. But sometimes the wifi goes to sleep and you must either ping it multiple times or shake the mouse. The kernel parameters he posted will resolve that issue.



Edited 4 time(s). Last edit at 07/25/2012 03:30PM by gnexus.
Hi,
You can always try the command:
modinfo 8192cu

It will print a list of module parameters that can be passed to the module when loading with modprobe. For example:

parm: rtw_power_mgnt:int

You can then look up the meaning of and acceptable values for each parameter in the kernel source.
Hi,
Just to complement my previous post:
As root, create a file /etc/modprobe.d/8192cu.conf with the following contents:
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

This prevents the power down/up cycles of the 8192 wifi chip.
Depending on the build this line could be added to /etc/rc.local

iwconfig wlan0 power off

Domenic
Re: RTL8192cu WiFi disable power save on Mele & driver update
August 03, 2012 05:12AM
Is it possible to run the RTL8192cu as an access point with hostapd ?
No, not possible. Tries many times, on different architectures. Give it a break, buy more expensive stick that works in AP mode in Linux and not only in Windows <- pay attention to this.
To run it in AP mode, you have to download RTL8188CUS driver from realtek website and compile hostapd.
hostapd is included in the driver package, in wpa_supplicant_hostapd folder.

http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8188CUS

it works for me on Mele A1000.
Hello,
any news to:

"Therefore I am going to try to backport the new driver into the 3.0.36+ kernel and see if it help to minimize the connection issues."

I hope you can provide the module "8192cu.ko" already compiled without Power Saving. The makefile parameters should be:

CONFIG_POWER_SAVING
CONFIG_USB_AUTOSUSPEND

This becouse in my case using "options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 " in 8192cu.conf seems don't solve the problem. Output from /var/log/syslog:
...
Jan 1 03:02:45 linaro-alip kernel: [ 7355.560000] rtl8192c_dm_RF_Saving(): RF_Save
Jan 1 03:02:47 linaro-alip kernel: [ 7357.560000] rtl8192c_dm_RF_Saving(): RF_Normal
Jan 1 03:02:51 linaro-alip kernel: [ 7361.550000] rtl8192c_dm_RF_Saving(): RF_Save
Jan 1 03:02:53 linaro-alip kernel: [ 7363.550000] rtl8192c_dm_RF_Saving(): RF_Normal
Jan 1 03:03:01 linaro-alip kernel: [ 7371.550000] rtl8192c_dm_RF_Saving(): RF_Save


Thank you
Re: RTL8192cu WiFi disable power save on Mele & driver update
January 17, 2013 01:33PM
Quote

try to backport the new driver into the 3.0.36+ kernel

Current kernel version is 3.0.57. . .

Latest 8192cu linux driver is 3.4.4_4749. . .

I would try latest kernel first. If you want the latest Realtek code for your driver you would need to d/l it and compile it yourself. Others have said power-save works with existing driver. But 8192cu is still crap.
Re: RTL8192cu WiFi disable power save on Mele & driver update
December 16, 2013 12:27PM
Thanks Andrew for informing about the command.

Herbal Medicine
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: