Welcome! Log In Create A New Profile

Advanced

keyboard for other language

Posted by jeyrey 
keyboard for other language
May 08, 2020 10:39PM
I am currently using 5.6.5-kirkwood-tld-1 distribution. Some of the files I have to deal with are in other languages. What do I need to do/download/install to be able to type other language fonts or view through terminal?

$ locale
LANG=C
LANGUAGE=
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=


This is what happens when I view the file.
$ ls
''$'\340\270\243\340\270\261\340\270\201\340\270\225\340\270\264\340\270\224\340\271\204\340\270\213\340\271\200\340\270\243\340\270\231'' .mp3'

This is what happens when I ls and then press tab:
$ ls 
รักติดไซเรน.mp3
Re: keyboard for other language
May 08, 2020 11:54PM
jeyrey,

What you need to use is UTF-8. For example, American English is:

en_US.UTF-8 UTF-8


Find your language in /etc/locale.gen. Uncomment that. And run locale-gen.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: keyboard for other language
May 09, 2020 01:36AM
I don't have locale.gen in /etc/ or anywhere in the system. Is it normal?

When logged from another machine, I am seeing this with locale.

$ locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=C
LANGUAGE=
LC_CTYPE="C"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="C"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="C"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=



Edited 1 time(s). Last edit at 05/09/2020 01:39AM by jeyrey.
Re: keyboard for other language
May 09, 2020 01:52AM
> I don't have locale.gen in /etc/ or anywhere in
> the system. Is it normal?

apt-get install locales

and then edit locale.gen

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: keyboard for other language
May 09, 2020 02:05AM
Installed locales, update /etc/locale.gen but there is no locale.gen in the system.

# locale.gen
bash: locale.gen: command not found
Re: keyboard for other language
May 09, 2020 02:12AM
jeyrey Wrote:
-------------------------------------------------------
> Installed locales, update /etc/locale.gen but
> there is no locale.gen in the system.
>
>
> # locale.gen
> bash: locale.gen: command not found
>


The command is locale-gen (with a dash). The file that contains the setting is local.gen (with a dot).

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: keyboard for other language
May 09, 2020 02:45AM
Found it. For some reason, /usr/sbin is not included in the path. Now I need to get it to work with the new fonts. Thanks.



Edited 2 time(s). Last edit at 05/09/2020 03:36AM by jeyrey.
Re: keyboard for other language
May 09, 2020 06:27PM
jeyrey,

Very odd that /usr/sbin is not in the PATH.

You need at least:

PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: