Welcome! Log In Create A New Profile

Advanced

NAS326 network speed issue

Posted by kekeke 
kekeke
NAS326 network speed issue
July 16, 2020 11:51AM
Could someone get 1Gb to work reliably?
When I'm trying to use NAS326 through wall outlet, it eventually starts spamming errors like this

2017-10-24T21:25:38+02:00 err kernel[]: [496485.750253] mvneta f1034000.ethernet eth1: bad rx status 0f810000 (crc error), size=938

https://forum.turris.cz/t/mvneta-ethernet-eth1-bad-rx-status/5479

Then it can show "cable may be defective" error and degrades to 100mbps.

If I'm connecting it directly to the router -> no errors in dmesg. But the problem still appears - after some time it switches from 1Gb to 100mbps.

I tried different cables and different hardware. The problem only appears with NAS326.

P.S. I didn't check what happen on the stock OS (I'll try when I get physical access to nas).
kekeke
Re: NAS326 network speed issue
July 16, 2020 11:56AM
Relevant lines from dmesg:

[   24.675556] mvneta f1070000.ethernet eth0: PHY [f1072004.mdio-mii:01] driver [Marvell 88E1510] (irq=POLL)
[   24.694709] mvneta f1070000.ethernet eth0: configuring for phy/rgmii-id link mode
[   32.034004] mvneta f1070000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[   47.589891] mvneta f1070000.ethernet eth0: Link is Down
[   47.724742] mvneta f1070000.ethernet eth0: PHY [f1072004.mdio-mii:01] driver [Marvell 88E1510] (irq=POLL)
[   47.736325] mvneta f1070000.ethernet eth0: configuring for phy/rgmii-id link mode
[   54.998759] mvneta f1070000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx

Previously it booted with 1Gbps with the same cable.
Also, I tried different kernels. The problem persists for the 4.20.x, 5.6.x and the latest 5.7.6

Linux nas 5.7.6-mvebu-tld-1 #1.0 SMP PREEMPT Mon Jun 29 14:13:34 PDT 2020 armv7l GNU/Linux
Re: NAS326 network speed issue
July 16, 2020 02:38PM
kekeke,

Sounds like the problem is with the your box NIC, i.e. hardware. I have not seen it on my NAS326. But let me check again sometime later today.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: NAS326 network speed issue
July 17, 2020 03:39PM
kekeke,

See the bootlog by cyraxxx:

https://forum.doozan.com/read.php?2,104874,106264#msg-106264

So to see if it is not hardware, but something in your rootfs that cause this problem, post the serial boot log here.

-bodhi
===========================
Forum Wiki
bodhi's corner
kekeke
Re: NAS326 network speed issue
July 22, 2020 02:12AM
bodhi,
Thank you so much!
Will continue my experiments
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: