Welcome! Log In Create A New Profile

Advanced

Wifi not working

Posted by jeyrey 
Wifi not working
January 17, 2021 03:55AM
I have had this problem for years and after a lot of reading, I still can't find a solution.

I am current use Linux debian 5.5.1-kirkwood-tld-1 #1.0 PREEMPT Sat Feb 1 22:28:36 PST 2020 armv5tel GNU/Linux. I have both ethernet and usb wifi plugin. Here is my /etc/network/interfaces looks like:

auto lo eth0
iface lo inet loopback
iface eth0 inet static
        address 192.168.100.152
        netmask 255.255.255.0
        network 192.168.100.0
        broadcast 192.168.100.255
        gateway 192.168.100.1

allow-hotplug wlxxxxxxxxxxxxx
auto wlxxxxxxxxxxxxx
iface wlxxxxxxxxxxxxx inet static
	address 192.168.100.153
        netmask 255.255.255.0
        network 192.168.100.0
        broadcast 192.168.100.255
        gateway 192.168.100.1
	wpa-ssid myrouter
	wpa-psk xxxxxxxxx


After booting, both wired and wifi connections are pingable and work. However, if I disconnect ethernet, I will also lose wifi (not pingable all together). Wifi comes back if I re-plug ethernet. I have tried to reboot with just wifi pluged in and ehternet disconnected, but then I never got wifi to work or was able to login to see what is going on. My goal is to be able to use just wifi without ethernet pluged in. Anyone has any solution to this problem? Thanks.
Re: Wifi not working
January 17, 2021 03:54PM
jeyrey,

> After booting, both wired and wifi connections are
> pingable and work. However, if I disconnect
> ethernet, I will also lose wifi (not pingable all
> together). Wifi comes back if I re-plug ethernet.

This is a common problem when you first setup wifi on a box that has existing Ethernet. Somewhere in this forum we discussed this, and had a solution for this. Basically, you need to set up IP routes for this to work.

Look for it on threads that discuss the Pogoplug Pro.

In the Wiki thread:

http://forum.doozan.com/read.php?2,16044,21638#msg-21638
http://forum.doozan.com/read.php?2,34257,36119#msg-36119

I'll look into my old notes if you can't find it.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 01/17/2021 03:55PM by bodhi.
Re: Wifi not working
January 18, 2021 01:13AM
Thanks bodhi. I just spent the last few hours reading/searching your links but still no luck. Could you please check what the solution might be? Thanks.
Re: Wifi not working
January 18, 2021 04:47PM
jrey,

I could not find in my old notes. But here is the post that has the route added for wlan. In that thread we discussed the possible solutions.

https://forum.doozan.com/read.php?2,30533,30559#msg-30559


Also if you have serial console, you can do this during testing to force the link up link down for convenience (as GeekSmith suggested in the last post):

ifdown wlan0
ifup wlan0

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Wifi not working
January 21, 2021 09:06PM
So exactly, where can I put this so that it automatically fix during boot up?


>
> ifdown wlan0
> ifup wlan0
> 
Re: Wifi not working
January 21, 2021 09:59PM
Not sure what I have just done but the wifi now work without ethernet cable. Both wlan and eth0 are pingable so I think the default has been using the wireless one. Now I am trying to duplicate to another system. Thanks so much.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: