Welcome! Log In Create A New Profile


["SOLVED"]: Linux Kernel 6.4.11 On Zyxel NSA 326 cannot boot

Posted by raffe 
["SOLVED"]: Linux Kernel 6.4.11 On Zyxel NSA 326 cannot boot
September 23, 2023 02:40PM
I also got problems booting with 6.4.11-mvebu-tld-1.

It didn't boot up so I could reach it with SSH or ping it. Tried to wake with WOL, but it didn't help.

Not sure if I have Debian-5.13.6-kirkwood-tld-1-rootfs (28 Sept 2021) , but I think I installed Debian on it February 2022 so it should be that one.

I am not on site, so I have to check tomorrow what could be wrong.

@nsa_canis, did you get it working again? If yes, how?

EDIT: When I updated I followed this update process (but of course not the stuff after "shutdown -r now"):
Check versions here https://forum.doozan.com/read.php?2,32146

1. Find & replace /2023-09-23/ with the date today
2. Find & replace -6.4.11- with the new version (but first note the version here)
3. Find & replace -6.3.5- with the installed version (see note from step 2 above)
4. Find & replace 3OMPrPr with correct download link from forum.doozan.com
5. Save this file as "Upgrade rootfs and uImage ver [new ver].txt"
6. Run the commands below
7. If it works, edit "/root/run-apt-get-update.sh" with right version

su -
cd /boot
mkdir ./backup/2023-09-23/
cp -a uImage uInitrd ./backup/2023-09-23/
cp -a initrd.img-6.3.5-mvebu-tld-1 backup/2023-09-23/
cp -a System.map-6.3.5-mvebu-tld-1 backup/2023-09-23/
cp -a vmlinuz-6.3.5-mvebu-tld-1 backup/2023-09-23/
cp -a config-6.3.5-mvebu-tld-1 backup/2023-09-23/
cp -ra dts/ backup/2023-09-23/dts 
wget https://bit.ly/3OMPrPr
mv 3OMPrPr linux-6.4.11-mvebu-tld-1-bodhi.tar.bz2
tar -vxjf linux-6.4.11-mvebu-tld-1-bodhi.tar.bz2
tar -xf  linux-dtb-6.4.11-mvebu-tld-1.tar
apt-get remove flash-kernel 
dpkg -i linux-image-6.4.11-mvebu-tld-1_1_armhf.deb
cp -a zImage-6.4.11-mvebu-tld-1 zImage.fdt
cat dts/armada-380-zyxel-nas326.dtb >> zImage.fdt
mkimage -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -n Linux-6.4.11-mvebu-tld-1 -d zImage.fdt uImage
mkimage -A arm -O linux -T ramdisk -C gzip -a 0x00000000 -e 0x00000000 -n initramfs-6.4.11-mvebu-tld-1 -d initrd.img-6.4.11-mvebu-tld-1 uInitrd
mount /dev/sdc1 /mnt/bootusb/
mkdir /mnt/bootusb/boot/backup/2023-09-23/
cp -a /mnt/bootusb/boot/uI* /mnt/bootusb/boot/backup/2023-09-23/
cp -a uImage uInitrd /mnt/bootusb/boot/
umount /mnt/bootusb
shutdown -r now
su -
cd /boot
rm config-6.3.5-mvebu-tld-1
rm initrd.img-6.3.5-mvebu-tld-1
rm linux-6.3.5-mvebu-tld-1-bodhi.tar.bz2
rm linux-6.3.5-mvebu-tld-1.patch
rm linux-dtb-6.3.5-mvebu-tld-1.tar
rm linux-headers-6.3.5-mvebu-tld-1_1.0_armhf.deb
rm linux-image-6.3.5-mvebu-tld-1_1.0_armhf.deb
rm System.map-6.3.5-mvebu-tld-1
rm vmlinuz-6.3.5-mvebu-tld-1
rm zImage-6.3.5-mvebu-tld-1

I have one more Zyxel NAS 335 that I updated. But waited for the first to boot up before I restarted. When it did not, I tried reverse the update on this second one to the version I had before, with these commands. (I did not dare to reboot after downgrading as I am not on site, but wanted a working boot IF there is a power problem and the UPS shuts it down). But do this look right?:
su -
cd /boot
  485  cp -a zImage-6.3.5-mvebu-tld-1 zImage.fdt
  486  cat dts/armada-380-zyxel-nas326.dtb >> zImage.fdt
  487  mkimage -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -n Linux-6.3.5-mvebu-tld-1 -d zImage.fdt uImage
  488  mkimage -A arm -O linux -T ramdisk -C gzip -a 0x00000000 -e 0x00000000 -n initramfs-6.3.5-mvebu-tld-1 -d initrd.img-6.3.5-mvebu-tld-1 uInitrd
  489  sync
  490  sync
  491  mount /dev/sdc1 /mnt/bootusb/
  492  cp -a uImage uInitrd /mnt/bootusb/boot/
  493  sync
  494  sync
  495  umount /mnt/bootusb
  496  sync

Edited 1 time(s). Last edit at 09/24/2023 01:10PM by raffe.
Re: Linux Kernel 6.4.11 On Zyxel NSA 326 cannot boot
September 23, 2023 02:42PM
Re: Linux Kernel 6.4.11 On Zyxel NSA 326 cannot boot
September 23, 2023 02:46PM
bodhi Wrote:
> raffe,
> > Ah, you are right. I have a ZyXEL NAS326. So
> this
> > is wrong thread for me :-)
> Connect serial console, and power up, let it boot
> as far as it can. And post the entire serial
> console log (from u-boot banner.... everything)
> here in a new thread.
> There is no need to guess what the problem is.
> Serial console log will tell the whole story.

Thanks, will do! Maybe tomorrow when I am on site.
Re: Linux Kernel 6.4.11 On Zyxel NSA 326 cannot boot
September 24, 2023 01:10PM
Well, I got to the site and the two top LEDs had a steady light, but no response with any button.

But when I disconnected the power cable, waited 10 seconds, and reconnected the power it just booted up with 6.4.11 as nothing had ever been wrong. So probably just a random glitch or maybe a Gremling on site. Anyhow, now it seems to be happy and everything works :-)

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.