Welcome! Log In Create A New Profile

Advanced

Build your own Pro NAS – Seagate Goflex Net with Debian Linux, RAID1 and OpenMediaVault

Posted by DonCharisma 
I was bored one evening and wanted to see what is Open Media Vault. There is much easier way to install it on Wheezy. After playing for 10 minutes, I didn't find any good use for it except a nice GUI.

echo "deb http://packages.openmediavault.org/public kralizec main" > /etc/apt/sources.list.d/openmediavault.list 
apt-get update 
apt-get --yes --force-yes install openmediavault-keyring postfix 
apt-get update 
apt-get install openmediavault 
omv-initsystem 
shutdown -r now
That's it, your OpenMediaVault is installed. After restart you should be able to start OMV in your browser.
Warning: You won't be able to ssh into the system until you enable it via OMV.

Now If you want to add extra plugins from OMV-Extras.org just do the following.
Note: I didn't try that myself because I already deleted OMV
echo "deb http://packages.omv-extras.org/debian/ kralizec main" >> /etc/apt/sources.list.d/omv-extras-org-kralizec.list
apt-get update
apt-get --yes --force-yes install openmediavault-omvextrasorg
apt-get update



Edited 1 time(s). Last edit at 11/08/2014 07:04PM by Almaz.
Hi, I've used this tutorial to install ovm on the goflexnet.
Everything worked almost without errors, the network was not working with dhcp so I switched to static ip.
I've also installed OMV and it is working.

The problem is that the sata ports are not working at all, the disk don't even spin up, regardeless of the used port.

I'm connected to the serial console. I've noticed that if I stop the booting process and do:
"ide reset" the drive spins up but nothing changes at the end.

Any help is greatly appreciated.
Thanks

GoFlexNet> ide reset

Reset IDE: Bus 0: not available  Bus 1: OK
  Device 1: Model: Hitachi HTS543225L9SA00  Firm: FBEOC40C Ser#: 080819FB0D20LJG19L9D
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 238475.1 MB = 232.8 GB (488397168 x 512)
GoFlexNet>


GoFlexNet> printenv
arcNumber=2097
baudrate=115200
bootcmd=usb start; run force_rescue_bootcmd; run ubifs_bootcmd; run usb_bootcmd; usb stop; run rescue_bootcmd; run pogo_bootcmd; reset
bootdelay=3
console=ttyS0,115200
ethact=egiga0
ethaddr=00:10:75:26:0F:29
force_rescue=0
force_rescue_bootcmd=if test $force_rescue -eq 1 || ext2load usb 0:1 0x1700000 /rescueme 1 || fatload usb 0:1 0x1700000 /rescueme.txt 1; then run rescue_bootcmd; fi
led_error=orange blinking
led_exit=green off
led_init=green blinking
mainlineLinux=yes
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:1M(u-boot),4M(uImage),32M(rootfs),-(data)
partition=nand0,2
pogo_bootcmd=if fsload uboot-original-mtd0.kwb; then go 0x800200; fi
rescue_bootcmd=if test $rescue_installed -eq 1; then run rescue_set_bootargs; nand read.e 0x800000 0x100000 0x400000; bootm 0x800000; else run pogo_bootcmd; fi
rescue_installed=0
rescue_set_bootargs=setenv bootargs console=$console ubi.mtd=2 root=ubi0:rootfs ro rootfstype=ubifs $mtdparts $rescue_custom_params
stderr=serial
stdin=serial
stdout=serial
ubifs_bootcmd=run ubifs_set_bootargs; if ubi part data && ubifsmount rootfs && ubifsload 0x800000 /boot/uImage && ubifsload 0x1100000 /boot/uInitrd; then bootm 0x800000 0x1100000; fi
ubifs_mtd=3
ubifs_set_bootargs=setenv bootargs console=$console ubi.mtd=$ubifs_mtd root=ubi0:rootfs rootfstype=ubifs $mtdparts $ubifs_custom_params
usb_boot=mw 0x800000 0 1; ext2load usb $usb_device 0x800000 /boot/uImage; if ext2load usb $usb_device 0x1100000 /boot/uInitrd; then bootm 0x800000 0x1100000; else bootm 0x800000; fi
usb_bootcmd=run usb_init; setenv usb_root LABEL=rootfs; run usb_set_bootargs; run usb_boot
usb_device=0:1
usb_init=run usb_scan
usb_root=/dev/sda1
usb_rootdelay=10
usb_rootfstype=ext2
usb_scan=usb_scan_done=0;for scan in $usb_scan_list; do run usb_scan_$scan; if test $usb_scan_done -eq 0 && ext2load usb $usb 0x800000 /boot/uImage 1; then usb_scan_done=1; echo "Found bootable drive on usb $usb"; setenv usb_device $usb; setenv usb_root /dev/$dev; fi; done
usb_scan_1=usb=0:1 dev=sda1
usb_scan_2=usb=1:1 dev=sdb1
usb_scan_3=usb=2:1 dev=sdc1
usb_scan_4=usb=3:1 dev=sdd1
usb_scan_list=1 2 3 4
usb_set_bootargs=setenv bootargs console=$console root=$usb_root rootdelay=$usb_rootdelay rootfstype=$usb_rootfstype $mtdparts $usb_custom_params

Environment size: 2372/131068 bytes


root@flexnet:~# dmesg
[    0.000000] Booting Linux on physical CPU 0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.3.2-kirkwood-dg (davygravy@bitbaker64) (gcc version 4.6.1 (Sourcery CodeBench Lite 2011.09-70) ) #1 Mon Apr 23 17:09:27 CDT 2012
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=00053977
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] Machine: Marvell SheevaPlug Reference Board
[    0.000000] Memory policy: ECC disabled, Data cache writeback
[    0.000000] On node 0 totalpages: 32768
[    0.000000] free_area_init_node: node 0, pgdat c043cd24, node_mem_map c04a4000
[    0.000000]   Normal zone: 256 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32512 pages, LIFO batch:7
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 rootfstype=ext2 mtdparts=orion_nand:1M(u-boot),4M(uImage),32M(rootfs),-(data)
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] allocated 262144 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.000000] Memory: 128MB = 128MB total
[    0.000000] Memory: 118056k/118056k available, 13016k reserved, 0K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     vmalloc : 0xc8800000 - 0xff000000   ( 872 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xc8000000   ( 128 MB)
[    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
[    0.000000]       .text : 0xc0008000 - 0xc03e07fc   (3938 kB)
[    0.000000]       .init : 0xc03e1000 - 0xc0404000   ( 140 kB)
[    0.000000]       .data : 0xc0404000 - 0xc043f1a0   ( 237 kB)
[    0.000000]        .bss : 0xc043f1c4 - 0xc04a3228   ( 401 kB)
[    0.000000] NR_IRQS:114
[    0.000000] gpiochip_add: registered GPIOs 0 to 31 on device: orion_gpio0
[    0.000000] gpiochip_add: registered GPIOs 32 to 49 on device: orion_gpio1
[    0.000000] sched_clock: 32 bits at 200MHz, resolution 5ns, wraps every 21474ms
[    0.000000] Console: colour dummy device 80x30
[   13.405517] Calibrating delay loop... 1191.11 BogoMIPS (lpj=5955584)
[   13.495401] pid_max: default: 32768 minimum: 301
[   13.495528] Security Framework initialized
[   13.495606] Mount-cache hash table entries: 512
[   13.495954] Initializing cgroup subsys cpuacct
[   13.495970] Initializing cgroup subsys memory
[   13.496007] Initializing cgroup subsys devices
[   13.496020] Initializing cgroup subsys freezer
[   13.496029] Initializing cgroup subsys net_cls
[   13.496038] Initializing cgroup subsys blkio
[   13.496064] Initializing cgroup subsys perf_event
[   13.496154] CPU: Testing write buffer coherency: ok
[   13.496433] Setting up static identity map for 0x2c9590 - 0x2c95cc
[   13.497554] devtmpfs: initialized
[   13.499344] print_constraints: dummy:
[   13.499597] NET: Registered protocol family 16
[   13.500261] Kirkwood: MV88F6281-A0, TCLK=200000000.
[   13.500276] Feroceon L2: Enabling L2
[   13.500313] Feroceon L2: Cache support initialised.
[   13.500841] initial MPP regs: 01111111 11113322 00001111 00100000 00000000 00000000 00000000
[   13.500864]   final MPP regs: 01111111 11113322 00001111 00000000 00000000 00000000 00000000
[   13.502901] bio: create slab <bio-0> at 0
[   13.503264] vgaarb: loaded
[   13.503759] Switching to clocksource orion_clocksource
[   13.517803] NET: Registered protocol family 2
[   13.518037] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[   13.518715] TCP established hash table entries: 4096 (order: 3, 32768 bytes)
[   13.518815] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[   13.518874] TCP: Hash tables configured (established 4096 bind 4096)
[   13.518883] TCP reno registered
[   13.518893] UDP hash table entries: 256 (order: 0, 4096 bytes)
[   13.518916] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[   13.519133] NET: Registered protocol family 1
[   13.519166] PCI: CLS 0 bytes, default 32
[   13.519325] Unpacking initramfs...
[   14.085142] Freeing initrd memory: 6840K
[   14.085155] NetWinder Floating Point Emulator V0.97 (double precision)
[   14.085840] audit: initializing netlink socket (disabled)
[   14.085881] type=2000 audit(0.670:1): initialized
[   14.087296] VFS: Disk quotas dquot_6.5.2
[   14.087394] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[   14.087499] JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
[   14.087841] msgmni has been set to 243
[   14.089397] alg: No test for stdrng (krng)
[   14.089501] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[   14.089515] io scheduler noop registered
[   14.089522] io scheduler deadline registered
[   14.089571] io scheduler cfq registered (default)
[   14.089658] mv_xor_shared mv_xor_shared.0: Marvell shared XOR driver
[   14.089692] mv_xor_shared mv_xor_shared.1: Marvell shared XOR driver
[   14.123830] mv_xor mv_xor.0: Marvell XOR: ( xor cpy )
[   14.163827] mv_xor mv_xor.1: Marvell XOR: ( xor fill cpy )
[   14.203826] mv_xor mv_xor.2: Marvell XOR: ( xor cpy )
[   14.243825] mv_xor mv_xor.3: Marvell XOR: ( xor fill cpy )
[   14.244180] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[   14.264678] serial8250.0: ttyS0 at MMIO 0xf1012000 (irq = 33) is a 16550A
[   14.730686] console [ttyS0] enabled
[   14.735051] ONFI flash detected
[   14.738291] ONFI param page 0 valid
[   14.741802] NAND device: Manufacturer ID: 0x2c, Chip ID: 0xda (Micron MT29F2G08AAD)
[   14.749512] Scanning device for bad blocks
[   14.905757] 4 cmdlinepart partitions found on MTD device orion_nand
[   14.912055] Creating 4 MTD partitions on "orion_nand":
[   14.917232] 0x000000000000-0x000000100000 : "u-boot"
[   14.923019] 0x000000100000-0x000000500000 : "uImage"
[   14.928783] 0x000000500000-0x000002500000 : "rootfs"
[   14.934587] 0x000002500000-0x000010000000 : "data"
[   14.941009] mousedev: PS/2 mouse device common for all mice
[   15.953809] rtc-mv rtc-mv: internal RTC not ticking
[   15.958789] i2c /dev entries driver
[   15.962414] cpuidle: using governor ladder
[   15.966670] cpuidle: using governor menu
[   15.970750] Registered led device: plug:red:misc
[   15.970845] Registered led device: plug:green:health
[   15.971732] TCP cubic registered
[   15.974993] NET: Registered protocol family 17
[   15.979467] Registering the dns_resolver key type
[   15.984248] Gating clock of unused units
[   15.984257] before: 0x00dfc3fd
[   15.984265]  after: 0x00c701d9
[   15.984691] registered taskstats version 1
[   15.989244] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[   15.995602] Initializing network drop monitor service
[   16.001264] Freeing init memory: 140K
[   16.054174] udev[47]: starting version 164
[   16.110787] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
[   16.180727] usbcore: registered new interface driver usbfs
[   16.249447] mv643xx_eth smi: probed
[   16.254209] mmc0: mvsdio driver initialized, lacking card detect (fall back to polling)
[   16.293911] usbcore: registered new interface driver hub
[   16.314017] mv643xx_eth_port mv643xx_eth_port.0: eth0: port 0 with MAC address 00:10:75:26:0f:29
[   16.329600] usbcore: registered new device driver usb
[   16.337848] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   16.350535] orion-ehci orion-ehci.0: Marvell Orion EHCI
[   16.355894] orion-ehci orion-ehci.0: new USB bus registered, assigned bus number 1
[   16.383847] orion-ehci orion-ehci.0: irq 19, io mem 0xf1050000
[   16.403814] orion-ehci orion-ehci.0: USB 2.0 started, EHCI 1.00
[   16.409846] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[   16.416692] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   16.423959] usb usb1: Product: Marvell Orion EHCI
[   16.428682] usb usb1: Manufacturer: Linux 3.3.2-kirkwood-dg ehci_hcd
[   16.435076] usb usb1: SerialNumber: orion-ehci.0
[   16.442046] hub 1-0:1.0: USB hub found
[   16.445858] hub 1-0:1.0: 1 port detected
[   16.763807] usb 1-1: new high-speed USB device number 2 using orion-ehci
[   16.914622] usb 1-1: New USB device found, idVendor=0781, idProduct=5567
[   16.921355] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   16.928534] usb 1-1: Product: Cruzer Blade
[   16.932645] usb 1-1: Manufacturer: SanDisk
[   16.936776] usb 1-1: SerialNumber: 4C532000060411115413
[   16.963997] SCSI subsystem initialized
[   16.970414] usbcore: registered new interface driver uas
[   16.980319] Initializing USB Mass Storage driver...
[   16.985535] scsi0 : usb-storage 1-1:1.0
[   16.990732] usbcore: registered new interface driver usb-storage
[   16.996796] USB Mass Storage support registered.
[   17.985091] scsi 0:0:0:0: Direct-Access     SanDisk  Cruzer Blade     1.26 PQ: 0 ANSI: 5
[   18.007299] sd 0:0:0:0: [sda] 31266816 512-byte logical blocks: (16.0 GB/14.9 GiB)
[   18.016770] sd 0:0:0:0: [sda] Write Protect is off
[   18.021584] sd 0:0:0:0: [sda] Mode Sense: 43 00 00 00
[   18.022269] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[   18.040027]  sda: sda1 sda2
[   18.046520] sd 0:0:0:0: [sda] Attached SCSI removable disk
[   27.162901] udev[146]: starting version 164
[   28.014494] mdadm: sending ioctl 1261 to a partition!
[   28.019570] mdadm: sending ioctl 1261 to a partition!
[   28.025596] mdadm: sending ioctl 1261 to a partition!
[   28.030670] mdadm: sending ioctl 1261 to a partition!
[   28.036304] mdadm: sending ioctl 1261 to a partition!
[   28.041378] mdadm: sending ioctl 1261 to a partition!
[   28.047548] mdadm: sending ioctl 1261 to a partition!
[   28.052627] mdadm: sending ioctl 1261 to a partition!
[   28.058580] mdadm: sending ioctl 800c0910 to a partition!
[   28.064026] mdadm: sending ioctl 800c0910 to a partition!
[   28.354182] device-mapper: uevent: version 1.0.3
[   28.374479] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[   31.402555] Software Watchdog Timer: 0.07 initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout= 0)
[   31.502958] wd_keepalive (700): /proc/700/oom_adj is deprecated, please use /proc/700/oom_score_adj instead.
[   33.228026] mv643xx_eth_port mv643xx_eth_port.0: eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[   33.926363] NET: Registered protocol family 10
[   44.063819] eth0: no IPv6 routers present


root@flexnet:~# fdisk -l

Disk /dev/mtdblock0: 1 MB, 1048576 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mtdblock0 doesn't contain a valid partition table

Disk /dev/mtdblock1: 4 MB, 4194304 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xee020f10

Disk /dev/mtdblock1 doesn't contain a valid partition table

Disk /dev/mtdblock2: 33 MB, 33554432 bytes
255 heads, 63 sectors/track, 4 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mtdblock2 doesn't contain a valid partition table

Disk /dev/mtdblock3: 229 MB, 229638144 bytes
255 heads, 63 sectors/track, 27 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mtdblock3 doesn't contain a valid partition table

Disk /dev/sda: 16.0 GB, 16008609792 bytes
64 heads, 32 sectors/track, 15267 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0031ea30

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               2        4097     4194304   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2            4098        4353      262144   82  Linux swap / Solaris
Partition 2 does not end on cylinder boundary.
@Almaz, I'm running Wheezy now too :) thanks for confirming the install on Wheezy ...

@leo you need to change the arcNumber to 3089 ...

The reason the SATA isn't working I think is that 2097 is probably a Pogoplug that doesn't have a SATA port ! 3089 is the arcNumber for GoFlexNet (can be looked up on kernel.org I think)

Cheers

D

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com
Thanks for the reply,
Today I've made a new usbkey but with the latest rootfs from this forum, (Debian-3.17.0-kirkwood-tld-1-rootfs-bodhi.tar.bz2 ) using the method in that same post and than I've installed open media vault kralizec.
A couple of errors during the installation but now it's seem it is working.
I've manually installed the latest xmlstarlet (don't know if this was really necessary) and also removed collectd and reinstalled the latest version after doing this openmediavoult installed correctly.
@leo - thanks for the update ... and good to know OpenMediaVault working on latest kernel and latest OMV distribution ... I don't know if xmlstarlet needed or not !

Cheers

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com
Very nice article !

I have managed it to do the same.
Runs absolutely stable.
With 2x 3,5 inch harddrives as Raid1. (With extra Wires for supplying the Disks with 12 Volt too)
I have approx. 35 MB/s Read and 35 MB/s Write performance.

The only problem is, when i want to reboot this thing.

If i am doing it via "reboot" -> The system hangs
"shutdown -r 0" -> Sometimes works, but sometimes hangs too. (50% ?!?)

Is there a newer Image for the USB Stick, i can try ?
(Propably one, that can be upgraded "in Place")

Br,
@hollari - I've (personally) migrated off of using OMV in favour of setting stuff up manually with command line. So no there isn't a "newer image" :)

One thing I forgot to do when I set mine up was to add in the swap partitions. With mdadm, at boot, an fsck on a RAID array can fail due to not having enough memory. So it's *essential* to create the swap if you're using RAID, and these do need adding to /etc/fstab ... This was my solution to a similar issue I was having.

If you're booting off a flash device it's possible there's an issue with the flash drive your using. So might be worth trying a different flash device. Or even SATA booting.

And lastly, (or maybe firstly actually !) have a dig around in the logs, setup the netconsole or even better serial cable - that way you might find out actually what the problem is. Simply saying "it doesn't boot" isn't enough information to provide accurate solutions ...

PS always do a "sync" before your do a reboot ... or indeed unmount or eject a flash drive ... that way you're sure data has been written to the device.

Cheers

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com
@hollari - PS, I found RAID10,f2 to have better performance than RAID1 ... but I think that has to be setup on command line, I don't think it's in OMV ...

Cheers

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com



Edited 1 time(s). Last edit at 03/04/2015 09:51PM by DonCharisma.
I've got OMV running on my Pogoplug Pro / V3 with bodhi's 3.18.5. rootfs. I posted a brief demo on Youtube here: https://www.youtube.com/watch?v=v4VHeI43yGI . It works surprisingly well IMO.



Edited 2 time(s). Last edit at 04/24/2015 06:08PM by LeggoMyEggo.
LeggoMyEggo Wrote:
-------------------------------------------------------
> I've got OMV running on my Pogoplug Pro / V3 with
> bodhi's 3.18.5. rootfs. I posted a brief demo on
> Youtube here:
> https://www.youtube.com/watch?v=v4VHeI43yGI . It
> works surprisingly well IMO.

Wow THANKS for that.

=========
-=Cloud 9=-
* almost back, hold on.
@DonCharisma hi there, i just bought the goflex to transform in a nas, after reading your guide, i wanto to share the guide in a forum in my language (translating it). Can i have your permission? :)
@Saverio - sure why not ... just be sure to link back to the original post -

http://doncharisma.org/2013/09/22/build-your-own-pro-nas-seagate-goflex-net-with-debian-linux-raid1-and-openmediavault/

cheers

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com
Quote
rmleonard
Do you have an updated openmediavault install posting?

(Your original spoke of version 0.4 and iirc 2.xx is the current)

The current version seems to be in the apt sources...
(But will that work correctly?)

I've been gifted a goflex net (not sure if it works)...
So I need to find out why it doesn't have a web page, and then.. omv seems to be where i'd like its destiny to lie...(or maybe Amahi, or Tonido, or the like)

In the past 2 years, any new thoughts on the workings of the little pogoplug?

@rmleonard PM'ed me this, and I felt the answers where relevant publicly, so have answered so ...

1. "Do you have an updated openmediavault install posting? "

No, it was never my intention to maintain this, nor do I have the resources. I'd of course welcome anyone who wanted to take it over into a github, etc ... offers ?

2. "The current version seems to be in the apt sources"

If it's in apt-sources, then great, Debian repo is often very well maintained, so that may work better than trying to do it yourself ...

3. "In the past 2 years, any new thoughts on the workings of the little pogoplug?"

I think "little" is the operative word. 128MB memory is pretty small ... however the GoFlexNet/Pogoplug do run for years without crashing, and all drawing virtually no power, running virtually on fresh air ! So for the right application(s), which is still a large area, GoFlexNet and Pogoplug etc, still great fun and totally useable.

Since learning more about Linux, and Debian, I've tended to do more of my stuff on command line, so OMV I'm not using anymore. Not because it's "not great", but just that my personal usage evolved, to where I don't need a NAS type interface. I can build RAID arrays on command line or create NFS shares, etc ...

I bought a couple of Odroid devices, which has been my progression in ARM. They have faster CPUs, more cores and more memory, and the hardware is more accessible. They do also have their drawbacks, I've had some major issues getting enough power to peripherals, which I seem to have resolved now.

Overall, anything I've done on ARM/embedded takes more time, and is more challenging than anything on Intel/PC platform. The advantage of ARM is cost, low power consumption and arguably long term stability as CPUs often run without coolers ...

Another recent purchase was two Asrock mini-itx motherboards with Intel CPUs, which I find a lot easier to get software working on than ARM based devices. Also Intel now have the compute stick, and some small form factor PCs, which are more expensive than ARM gear, but probably save a lot of time ...

Lastly, I think the main "value" in doing anything with any of these devices in not in what you achieve, but in what you learn along the way.

Cheers

Don Charisma

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com
Hi, thanks for this INCREDIBLE tutorial! Now it's even more convenient, as the last GoFlex Net around are shipping for less than 20$ (I supposed due to stock clearings). Just a curiosity, before starting this quite complicated journey into hacking it: how long does it need to boot up and be up and running?
Hi Don,

I made a new system and got a Error by openmediavault.

root@debian:~# apt-get install openmediavault
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openmediavault : Depends: php5-fpm but it is not installable
                  Depends: php5-cgi but it is not installable
                  Depends: php5-cli but it is not installable
                  Depends: php5-pam but it is not going to be installed
                  Depends: openssh-blacklist-extra but it is not installable
                  Depends: php5-proctitle but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

can you help me
Re: Build your own Pro NAS – Seagate Goflex Net with Debian Linux, RAID1 and OpenMediaVault
October 08, 2017 02:19PM
lexa,

OMV works well only in wheezy, not even jessie, IIRC.

Are you running the stretch rootfs Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2 ? you might want to try older rootfs:

jessie:
Debian-4.4.0-kirkwood-tld-1-rootfs-bodhi.tar.bz2

wheezy:
Debian-3.18.5-kirkwood-tld-1-rootfs-bodhi.tar.bz2


The errors you saw could be that some OMV packages are not in stretch yet.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 10/08/2017 02:21PM by bodhi.
Yes i run Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2, next step i will try Debian-3.18.5-kirkwood-tld-1-rootfs-bodhi.tar.bz2 and give some Feedback
I search for wheezy, i online found 3.17 the 3.18.5 is already jessie.
Re: Build your own Pro NAS – Seagate Goflex Net with Debian Linux, RAID1 and OpenMediaVault
October 11, 2017 03:16PM
lexa Wrote:
-------------------------------------------------------
> I search for wheezy, i online found 3.17 the
> 3.18.5 is already jessie.

Right! I remember incorrectly.

-bodhi
===========================
Forum Wiki
bodhi's corner
after running wheezy 3.17 this message come

The following packages have unmet dependencies:
openmediavault : Depends: php5-pam but it is not going to be installed
Depends: scponly but it is not installable
E: Unable to correct problems, you have held broken packages.
i search every packages as deb armel and installed it with dpkg - now i' m able to login
Re: Build your own Pro NAS – Seagate Goflex Net with Debian Linux, RAID1 and OpenMediaVault
October 15, 2017 02:44PM
Hi lexa,

> i search every packages as deb armel and installed
> it with dpkg - now i' m able to login

When you have the error above, you should reconfigure dpkg, clean, and do apt-get update. And install.

Basically, forcing install packages like you did will work, but it is not the right way.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, solve the mathematical question and enter the answer in the input field below. This is for blocking bots that try to post this form automatically.
Question: how much is 6 plus 9?
Message: