Welcome! Log In Create A New Profile


[SOLVED] Pogoplug E02 won't boot into Debian anymore - help with rootfs needed

Posted by debi 
[SOLVED] Pogoplug E02 won't boot into Debian anymore - help with rootfs needed
October 09, 2013 08:07AM
After my Pogoplug E02 suddenly refused to boot into Debian - it used to cold and warm boot from an Intenso Rainbow Line 4GB USB drive without issues for a couple of months - I wanted to start from scratch and do a clean Debian Squeeze install following the installation instructions on http://projects.doozan.com/debian/ once again.

I repartioned my USB drive using fdisk and reran the Debian Squeeze installation script, but although there were no errors reported during the installation my Pogo still wouldn't boot into Debian. I tried another three USB drives - among them a Sandisk Cruzer Fit 8GB drive which was reported to be working by other forum users - but had no luck.

I browsed through the forum hoping to find a solution and came across this thread (http://forum.doozan.com/read.php?2,12096) explaining how to quickly get into Debian using rootfs. Since I'm a Linux novice I had some difficulties interpreting the installation steps but would like to give it a shot anyway. Maybe someone can help.

The brief guide says, "Note: if your uBoot env for usb_rootfstype is ext2, then use an ext2 USB drive", but I don't know where to find/check my "uBoot env for usb_rootfstype". Besides, it is advised to "format a new ext3 USB drive", which probably means to create an ext3 partition on the drive, but there's no mention of a swap partition. Does it mean it will work without swap?

One last question: Can the rootfs be used to build upon or is it simply made for debugging and testing purposes? I would appreciate if I could continue to use the rootfs because that would spare me another installation.

Please excuse my noob questions, I'm still trying to figure out how this Linux thing works :)

Many thanks in advance!

Edited 1 time(s). Last edit at 10/10/2013 03:28PM by debi.
Re: Pogoplug E02 won't boot into Debian anymore - help with rootfs needed
October 09, 2013 02:49PM

The ext2 vs ext3 type USB drive is to make sure uBoot usb_rootfstype variable is consistent with the USB file system type. If you can't log in to the stock Popgo OS, then don't worry about it. You've installed using the official script from Jeff, so your USB drive should be formatted as Ext2. But you can also format it as Ext3, it should work fine.
But not the other way around, i.e. if uBoot thinks you have Ext3 rootfs then you must have Ext3 to get it to work.

There is no swap setup on the roofts (no need to). Later you can set up a swap file or swap partition as you wish.

So all you need to do now is to use another Linux box (or Live CD) to format the USB stick as Ext2 or Ext3. And copy the rootfs to it per instruction. And boot with it. This rootfs is a basic starting point. But it is fully functional so you can install whichever package you need, setup swap, ...etc. It were like you have successfully run Jeff's installation script to the end, and installed a few packages. I've created this rootfs for users who have installed uBoot, but need a roofts to work with their plugs.

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: Pogoplug E02 won't boot into Debian anymore - help with rootfs needed
October 10, 2013 03:26PM
Hi bodhi,

Many thanks for your help. Installation to a new ext3 USB drive went smoothly and I could boot into Debian without any issues. Very happy to have a working Debian Pogo again!

Keep up the great work, it's very much appreciated!


Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.