Welcome! Log In Create A New Profile


Strange "double boot" behavior

Posted by hanker 
Strange "double boot" behavior
October 06, 2010 12:41PM
There was a short a power outage today (grrr). I came back home, and the Dockstar's LED was off, indicating (as I understand it) that the linux kernel had control. I tried to ssh in to it, and got no reply. So I unplugged and re-plugged the Dockstar's power supply. The LED started flashing (which means that the bootloader is running as I understand it), and then it stopped flashing and the LED turned off, indicating that the kernel had taken control again.

I waited a minute or two and then tried to ssh in again. No reply. So I'm thinking "oh crap..."

But then the LED started flashing again, and then eventually stopped again. So I waited another minute or so and tried to ssh in again. And it worked fine. I was able to start rtorrent and mount the Dockstar's nfs share on another machine on the LAN.

I don't have a serial terminal link, so I can't monitor the machine during these plug-and-pray sessions, but does anyone know what is happening here with this bootloader-kernel-bootloader-kernel sequence? Is this normal?

Thank you!

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.