Welcome! Log In Create A New Profile

Advanced

XFCE desktop on Pogoplug Debian

Posted by bodhi 
XFCE desktop on Pogoplug Debian
May 07, 2015 11:19PM
XFCE desktop on Debian Installation Instruction

Note that Peter (PeterGunn ?) had posted about setup and using Fluxbox desktop with VNC. This instruction will show how to install and run XFCE desktop with either RDC or VNC client.

1. Install all needed packages:

apt-get upgrade
apt-get install tightvncserver xrdp xfce4 xfce4-goodies  xfonts-base x11-xserver-utils


2. Setup xfce:

Create or edit the xstartup script

cd /root
nano /root/.vnc/xstartup

This is the content of xstartup:
#!/bin/sh
xrdb $HOME/.Xresources
startxfce4 &
xsetroot -solid grey
/etc/X11/Xsession
and then make it executable
chmod +x .vnc/xstartup


3. Setup X required files:

cd /root
touch .Xdefaults .Xresources .Xauthority

4. Setup vnc password (it is not need for connecting with Remote Desktop Connection client, but required for connecting with VNC):

vncpasswd

5. Setup tightvnc server:

Choose a display resolution and name for the session window
tightvncserver -geometry 1440x900 -depth 8 -name Debian

- Done.


Running RDC from Windows/Mac

- Start RDC using the Pogoplug IP address or its network name
- Choose sessman-xvnc in RDC
- Log in using the Pogoplug root and root password. If you have a different user setup, then that user/password should be used to connect.

A VNC client can also connect to the Pogoplug in a similar way.


Swap space

XFCE desktop is very lightweight, and it should run with the typical Pogolug which has 128MB RAM without problem. With xfce desktop, you can add system CPU meter, memory meter, and swap meter on the xfce panel to monitor the usage.

Do the following to make the GUI experience better:

- Have a swap file size at least 512 MB on a hardisk (USB flash is OK too if zswap is used).
- Use zswap (see the latest Kirkwood or Oxnas kernel threads in my signature for installing these zswap-supported kernels). This will help a great deal whether the swap file resides on USB flash or HDD drive.
- Set swappiness to 10 or less.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 2 time(s). Last edit at 05/08/2015 02:36AM by bodhi.
works perfect
May 10, 2015 12:19AM
Wow great job, thanks a lot bodhi. On PogoPro it seems real good; still fine tuning it.

=========
-= Cloud 9 =-



Edited 1 time(s). Last edit at 05/10/2015 10:53AM by JoeyPogoPlugE02.
Re: works perfect
May 10, 2015 07:10AM
Cool!

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
May 23, 2015 01:18PM
I have installed this as well, and it is working. Only issue was in step 2 when I went to save the xstartup file there was no .vnc folder to save it to so I had to create that.

I am interested in your zswap point above though. I have looked through the Kirkwood and Oxnas threads and each only mentions Zswap once and really gives no instructions. Do I need the 3.12.something or other kirkwood kernel to have zswap? I have 3.18.5 jessie version installed now. If this version does have zswap what do I need to do to set swappiness? I run Debian from a hard drive on my GoFlex Home if that information ishelpful at all.

Thanks
Re: XFCE desktop on Pogoplug Debian
May 23, 2015 04:26PM
optim,

> I am interested in your zswap point above though.
> I have looked through the Kirkwood and Oxnas
> threads and each only mentions Zswap once and
> really gives no instructions.

To activate zswap, you need to pass a parameter into the kernel command line. For example, if your bootargs look like below, add it to the end of the bootargs string:

usb_set_bootargs=setenv bootargs console=$console root=$usb_root rootdelay=$usb_rootdelay rootfstype=$usb_rootfstype $mtdparts $usb_custom_params
usb_custom_params=zswap.enabled=1

If you've installed the latest u-boot, you can put the definition in the uEnv.txt so it will be loaded automatically, without changing u-boot envs permanently. See section D in my instruction for the latest u-boot release.
D. How to use the uEnv.txt script

> Do I need the
> 3.12.something or other kirkwood kernel to have
> zswap? I have 3.18.5 jessie version installed
> now. If this version does have zswap what do I
> need to do to set swappiness?

Yes, it's in 3.18.5

To set swappiness, set the vm.swappiness to a number of your liking and reboot. For example, this is the sysctl parameters for one of my NASs.

# cat /etc/sysctl.d/local.conf
vm.min_free_kbytes = 8192
vm.swappiness = 60
net.netfilter.nf_conntrack_acct=0

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 05/23/2015 04:32PM by bodhi.
Re: XFCE desktop on Pogoplug Debian
May 28, 2015 08:50PM
Thanks!

I have made the changes, how am I sure it is working? I checked htop and did not see it in the process list, I did see 'kswapd0' though.

Should it be there or would I have to peruse the log to see if it started?
Re: XFCE desktop on Pogoplug Debian
May 28, 2015 09:25PM
optim,

Swappiness is just a characteristic of swap. You will not see it. As long as you have set up swap, it will be in effect (how often the kernell performs swapping when it determines some process memory is needed to be swapped to disk).

To see zswap running, look in dmesg. It should show that zswap started and allocated pool.

To see the effectiveness of zswap, run without it in the kernel bootargs, and do something memory intensive, such as launch xfce, and observe the amount of memory swapped in/out by running the command:
vmstat -5

Next, turn on zswap, reboot, and launch xfce again, and observe the vmstat output. It should show substantial improvement in the amount of memory be swapped out. What we are really interested in seeing is less memory pages being swapped out than before.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
July 02, 2015 05:45PM
@bodhi - nice going, I didn't even realise this was possible in that small memory :)

I'll have to look into zswap, it's a new one on me ...

Cheers

Don Charisma ... because anything is possible with Charisma

My blog - http://DonCharisma.org
Our commercial site - http://DonCharisma.com
E02 too
August 19, 2015 12:02AM
Imagine the wide open spaces of 256 MB RAM on the E02. This works perfect here and I can't imagine a Pogoplug without that option from now on. Absolutely brilliant how you've got it so the processes of the GUI are mostly not on until demand from RDP.

The reason I was inspired to try this on the E02 is because of the problem solving earlier today (Pogoplug Pro) with permissions for Transmission - sometimes a GUI can help me remember what's needed.

Thanks yet again Bodhi :-)


Oh give me RAM lots of RAM, and starry skies above... don't fence me in - Bing Crosby (not)

=========
-= Cloud 9 =-



Edited 1 time(s). Last edit at 08/19/2015 12:15AM by JoeyPogoPlugE02.
Re: E02 too
August 20, 2015 05:47AM
> Imagine the wide open spaces of 256 MB RAM on the
> E02.

The irony of this cracked me up :))

But seriously, IMO more RAM is almost always a better trade with small embedded Linux.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
August 20, 2015 12:47PM
brought out my inner comic :-D

There's only one thing this lacks on the E02, either a browser that supports Ghostery or a standalone file downloader that's break resistant. The company I beta test has files for me at app.box - a dropbox-style uploader that's probably real secure (and supposedly resumable but only one Windows app works and i can't afford it).

Any ideas?

=========
-= Cloud 9 =-
Re: XFCE desktop on Pogoplug Debian
August 20, 2015 06:31PM
JoeyPogoPlugE02 Wrote:
-------------------------------------------------------
> brought out my inner comic :-D
>
> There's only one thing this lacks on the E02,
> either a browser that supports Ghostery or a
> standalone file downloader that's break resistant.
> The company I beta test has files for me at
> app.box - a dropbox-style uploader that's probably
> real secure (and supposedly resumable but only one
> Windows app works and i can't afford it).
>
> Any ideas?

I don't use browser on these plugs, so can't tell you how good the add-ons are. But I do recall reading somewhere that iceweasel (Firefox) supports them.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
August 21, 2015 12:14AM
Well, just to say Iceweasel doesn't run after install, but lots of people everywhere have that problem - I've seen some real small versions of Firefox too in my Thin clients on Linux but they're way earlier versions. But my policy is usually:

1. not to run Flash on any machine I care about,
2. use Ghostery with bubble alert turned off and every possible thing blocked except two Facebooks (to view comments at news-type websites only)
3. paranoid settings in general
And usually browsers like that fly - if only Midori ran ghostery I'd be set, but Firefox and Iceweasel usually can, and in addition run nice download manager addons too, a big plus.

And the name Iceweasel, it's a cool name. Not known to be particularly stable, but we don't need a browser much anyway. Still, to obsess, great GUI and I'm more enthusiastic with a pink pogoplug than I am with a newly-upgraded quadcore with 8G RAM...

5 WATTS! omg

=========
-= Cloud 9 =-
Re: XFCE desktop on Pogoplug Debian
June 04, 2016 06:46AM
Anyone out there, I'm trying to do this:

2. Setup xfce:

Create or edit the xstartup script

cd /root
nano /root/.vnc/xstartup


This is the content of xstartup:

#!/bin/sh
xrdb $HOME/.Xresources
startxfce4 &
xsetroot -solid grey
/etc/X11/Xsession

And I get this:

"[ Error writing /root/.vnc/xstartup: No such file or directory ]"

Even after I rebooted the pogo.

Ideas, please?

I used the exact commands, copy and paste, as above.
Re: XFCE desktop on Pogoplug Debian
June 04, 2016 06:51AM
notoneofmyseeds,

If the /root/.vnc folder does not exist, then
mkdir /root/.vnc

and then edit /root/.vnc/xstartup

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
June 04, 2016 07:21AM
You bohdi! you're awesome!

Thanks this is great.

I'd edit your post to include

mkdir .vnc

and then onto to 2.

A word of advice if you're here, if you have not created an account on your rootfs, be careful using this as you'd be using root. And with a click, click, click, it's easier to mess things up.

Bohdi, I don't see my other ext4 partition, however.

Thanks a lot.
Re: XFCE desktop on Pogoplug Debian
June 04, 2016 04:19PM
notoneofmyseeds,

Remember that this rootfs is a basic rootfs. I've intentionally made it that way to keep it small and lean for an initial installation. To have all disks/partitions mounted during boot and presented to the users/application, you will need to install more packages. Automount can be set up with a few different ways in Linux. Look again in the Wiki - Debian on ARM Topics and Tutorials, you will find this topic.

The xfce desktop relies on the base Debian system to show the partitions and disks.

In your Debian command line:
mount
and see if you can see all partitions and disks.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
April 29, 2017 07:04PM
The code above works for Beelink X2 running Armbian's Ubuntu/Xenial and Debian, for me not so much VNC but RDP is great :-)

=========
-= Cloud 9 =-
Re: XFCE desktop on Pogoplug Debian
April 30, 2017 12:09AM
JoeyPogoPlugE02 Wrote:
-------------------------------------------------------
> The code above works for Beelink X2 running Armbia
> n's Ubuntu/Xenial and Debian, for me not so much V
> NC but RDP is great :-)

Cool :)

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
May 01, 2017 01:44AM
bodhi Wrote:
-------------------------------------------------------

> Cool :)

Heck yeah, and I went straight for RDP and don't know if VNC works perfectly fine, and I assume it does.

Bodhi, probably the only thing I'd edit is to add creation of : /.vnc/xstartup early in step 2.

=========
-= Cloud 9 =-
Re: XFCE desktop on Pogoplug Debian
May 01, 2017 02:34AM
Joey,

It is in step 2

nano /root/.vnc/xstartup

Did the above work in Armbian rootfs ?

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 05/01/2017 02:37AM by bodhi.
Re: XFCE desktop on Pogoplug Debian
May 17, 2017 01:07AM
bodhi I get this at that step, and maybe it's my inability to use Nano so well, but I think last time I went in with WinSCP and cheated:

[ Error writing /root/.vnc/xstartup: No such file or directory ]

Update: yes that's what I did, went in with WinSCP and it shows that's a hidden directory and file, but pasting in that way works, and then set executable with command line.

For a change I left out VNC altogether and it works fine with RDP. Later on I can try VNC from a higher quality mindset.

Pretty fun stuff, and in this instance I'm A/B testing one micro SD card with Reads and Writes of 80/80 MB/sec (Sandisk Ultra Plus) with another that's 80/20 MB/sec (Samsung EVO) and the Sandisk is really nicer.

=========
-= Cloud 9 =-



Edited 1 time(s). Last edit at 05/17/2017 01:25AM by JoeyPogoPlugE02.
Re: XFCE desktop on Pogoplug Debian
December 28, 2018 09:12AM
Hello, so I followed this guide and now I can rdc into pogoplug but I can't seem to login. What is the ip box under sessman-xvnc for? Thanks
Re: XFCE desktop on Pogoplug Debian
December 28, 2018 05:31PM
brickman7713@gmail.com Wrote:
-------------------------------------------------------
> Hello, so I followed this guide and now I can rdc
> into pogoplug but I can't seem to login. What is
> the ip box under sessman-xvnc for? Thanks

The same credential used for the rootfs. So if you can log in with SSH, then use that.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
December 30, 2018 09:16AM
I can ssh into the box, and connect via rdc but when I go to login in under rdc the login box goes away and eventually a box pops up in the top left with an error
Re: XFCE desktop on Pogoplug Debian
December 30, 2018 12:28PM
brickman7713,

> I can ssh into the box, and connect via rdc but
> when I go to login in under rdc the login box goes
> away and eventually a box pops up in the top left
> with an error

Ah, I recalled there was an error starting rdp in the recent kernels, but have not have time to look for cause (nobody has tried to install rdp latetly). If this is indeed related to the problem, I will not be able to investigate this for a few weeks.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
December 30, 2018 11:17PM
brickman7713,

Boot up the box with serial console, log into Debian, and

ps -deaf | grep rdp
ps -deaf | grep vnc

and post the entire serial console log here.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: XFCE desktop on Pogoplug Debian
January 05, 2019 09:47PM
Have you tried creating a file /etc/X11/Xwrapper.config containing

allowed_users = anybody
Re: XFCE desktop on Pogoplug Debian
February 10, 2019 12:11PM
Hi Bodhi and everyone with any insight into this problem,

I Installed XFCE as instructed here on the wiki ( https://forum.doozan.com/read.php?2,21784 ).

I am using RDC on windows 10 machine to connect to GoFlexHome box running Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2 with uboot.2017.07-tld-1.goflexhome.bodhi.tar

Problem:

After I RDC to goflex box a black screen apperas with a notch on top showing thumbpin logo and ip address. few seconds later a xrdp connection log box on teal/blue background appears stating:

------------------------------------------------------------
connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
login failed for display 0
--------------------------------------------------------------

Then I press ok button to close the box

now all I see is teal/blue background and xrdp login window that has following options:

Session: Xorg, Xvnc, Console, vnc-any, sesman-any, rdp-any, neutrinordp-any.

I have tried all but nothing works.

Out of the above, "Xvnc" connection gives following in Connection Log Box:
------------------------------------------------------
connection to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
login successful for display 10
VNC started connection
VNC connecting to 127.0.0.1 5910
VNC error - problem connection
some problem
--------------------------------

I have tried all the solutions that I found on ( https://askubuntu.com/questions/797973/error-problem-connecting-windows-10-rdp-into-xrdp ) as follows:

(i) I removed and then reinstalled tightvncserver and xrdp.

(ii) I created a file /etc/X11/Xwrapper.config containing "allowed_users = anybody"

(iii) I edited /etc/xrdp/sesman.ini and changed "AllowRootLogin=1"

But nothing worked.

I think this problem is the same problem as posted by brickman7713 in this message above ( https://forum.doozan.com/read.php?2,21784,75864#msg-75864 )

What am I missing? Should I have implemented some prerequisites before installing xfce?

any and all help will be appreciated.

Regards,

Navi

P.S. Bodhi, You had asked Brickman7713 to share the serial console log of ps -deaf | grep rdp
ps -deaf | grep vnc with you, did he ever do that? ) can this log be generated on my box through Netconsole?

P.S.2: Upgraded the kernel to latest 4.20.6 Kirkwood package, xfce and rdp problem still persists.

P.S.3. UPDATE: Got VNC to work from windows on my Goflex home box.

First I removed everything I had installed previously to remotely access the goflex home box

# apt-get remove tightvncserver xrdp xfce4 xfce4-goodies xfonts-base x11-xserver-utils

then I installed following packages only:

# apt-get install xfce4 xfonts-base
# apt install tightvcserver

then changed /.vnc/xstartup

nano /.vnc/xstartup

removed:
xsetroot -solid grey
/etc/X11/Xsession

now the files looks like:

#!/bin/sh
xrdb $HOME/.Xresources
startxfce4 &


restarted vncserver and then connected from windows 10 system using vnc viewer from real vnc and ssh tunnel in putty.

and it worked!!! I am attaching the screen shot.



Edited 5 time(s). Last edit at 02/17/2019 11:33AM by Navi.
Attachments:
open | download - Screenshot (42).png (58.5 KB)
open | download - Screenshot (41).png (8.1 KB)
open | download - Screenshot (45).png (581.8 KB)
Re: XFCE desktop on Pogoplug Debian
March 24, 2019 08:41PM
This is the output of those two commands, and I tried what Navi did but still got the same results (after installing xrdp)

root@debian:~# ps -deaf | grep rdp
root      1919     1  0 19:01 ?        00:00:00 /usr/sbin/xrdp-sesman
xrdp      1925     1  0 19:01 ?        00:00:00 /usr/sbin/xrdp
root      2312  2020  1 19:19 pts/0    00:00:00 grep rdp

root@debian:~# ps -deaf | grep vnc
root      2037     1  0 19:02 pts/0    00:00:00 Xtightvnc :1 -desktop Debian -auth /root/.Xauthority -geometry 1440x900 -depth 8 -rfbwait 120000 -rfbauth /root/.vnc/passwd -rfbport 5901 -fp /usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/ -co /etc/X11/rgb
root      2175     1  1 19:18 pts/0    00:00:00 Xtightvnc :2 -desktop Debian -auth /root/.Xauthority -geometry 1440x900 -depth 8 -rfbwait 120000 -rfbauth /root/.vnc/passwd -rfbport 5902 -fp /usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/ -co /etc/X11/rgb
root      2179     1  0 19:18 pts/0    00:00:00 /bin/sh /root/.vnc/xstartup
root      2318  2020  0 19:19 pts/0    00:00:00 grep vnc
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: