Welcome! Log In Create A New Profile


dockstar installed twice but still boots to pogo

Posted by vds 
dockstar installed twice but still boots to pogo
November 10, 2010 12:33AM
Just received my Dockstars today and ran Jeff's procedure to install Debian on one of them. Tried two times, both 'seemingly' successful, first to a 8GB Imation USB key, then to a 40GB laptop drive. On the "you can now reboot your device into Debian" prompt I tried that a couple times, then yanked the power and reconnected. In both cases the Dockstar boots to the Pogoplug os as a failsafe (whew).

FWIW, I do not have a serial cable and would really prefer to not hack the hardware.

What do I need to do to get it to actually boot to the external Debian ?

I 'do' have some SheevaPlug experience using the original plug so I have messed around in U-boot in the past. In years past there were some reports that the Sheeva took a while to find its USB subsystem which was thought to block some external devices from booting without tweaking timeouts etc. I was wondering about the "bootdelay=3" and "usb_rootdelay=10" items maybe needing more time perhaps (?)

Any ideas appreciated...thanks...

fw_printenv returns the following:
led_init=green blinking
led_exit=green off
led_error=orange blinking
rescue_set_bootargs=setenv bootargs console=$console ubi.mtd=2 root=ubi0:rootfs ro rootfstype=ubifs $mtdparts $rescue_custom_params
rescue_bootcmd=if test $rescue_installed -eq 1; then run rescue_set_bootargs; nand read.e 0x800000 0x100000 0x400000; bootm 0x800000; else run pogo_bootcmd; fi
pogo_bootcmd=if fsload uboot-original-mtd0.kwb; then go 0x800200; fi
force_rescue_bootcmd=if test $force_rescue -eq 1 || ext2load usb 0:1 0x1700000 /rescueme 1 || fatload usb 0:1 0x1700000 /rescueme.txt 1; then run rescue_bootcmd; fi
ubifs_set_bootargs=setenv bootargs console=$console ubi.mtd=$ubifs_mtd root=ubi0:rootfs rootfstype=ubifs $mtdparts $ubifs_custom_params
ubifs_bootcmd=run ubifs_set_bootargs; if ubi part data && ubifsmount rootfs && ubifsload 0x800000 /boot/uImage && ubifsload 0x1100000 /boot/uInitrd; then bootm 0x800000 0x1100000; fi
usb_scan=usb_scan_done=0;for scan in $usb_scan_list; do run usb_scan_$scan; if test $usb_scan_done -eq 0 && ext2load usb $usb 0x800000 /boot/uImage 1; then usb_scan_done=1; echo "Found bootable drive on usb $usb"; setenv usb_device $usb; setenv usb_root /dev/$dev; fi; done
usb_scan_list=1 2 3 4
usb_scan_1=usb=0:1 dev=sda1
usb_scan_2=usb=1:1 dev=sdb1
usb_scan_3=usb=2:1 dev=sdc1
usb_scan_4=usb=3:1 dev=sdd1
usb_init=run usb_scan
usb_set_bootargs=setenv bootargs console=$console root=$usb_root rootdelay=$usb_rootdelay rootfstype=$usb_rootfstype $mtdparts $usb_custom_params
usb_bootcmd=run usb_init; run usb_set_bootargs; run usb_boot
usb_boot=mw 0x800000 0 1; ext2load usb $usb_device 0x800000 /boot/uImage; if ext2load usb $usb_device 0x1100000 /boot/uInitrd; then bootm 0x800000 0x1100000; else bootm 0x800000; fi
bootcmd=usb start; run force_rescue_bootcmd; run ubifs_bootcmd; run usb_bootcmd; usb stop; run rescue_bootcmd; run pogo_bootcmd; reset
Re: dockstar installed twice but still boots to pogo
November 10, 2010 10:04PM
update - got the Imation 8GB key to boot while plugged into the back right slot (as facing the front of the unit) by doing the following:
  • setting the arcNumber value to 2998 (dockstar)
  • making the first partition on the flash disk bootable within fdisk
  • changing the bootcmd in fw_setenv to add a leading 'usb start ; usb stop; ' to the existing stanza, per a post elsewhere in the forums here

I can't quite explain why it's booting now, as booting off a 40GB laptop drive isn't working yet, but I'll look into that down the road. At least now I can start building up my Debian install to more than the minimum and document what I did.

(step 1 - "apt-get install iptables")

Edited 1 time(s). Last edit at 11/10/2010 10:05PM by vds.
Re: dockstar installed twice but still boots to pogo
November 15, 2010 11:26AM
I am having a similar problem. I installed Debian on my new Dockstar last week. I even installed the kernel ( http://forum.doozan.com/read.php?2,582 ) to get the LEDs to work.

When cold booted, it will just boot to NAND, and I have to log in as root and reboot it. Then it will run Debian.

I tried adding 'usb stop; usb start;' to usb_init, but that didn't help. I also added it to bootcmd (which seems to effectively do the same), and that didn't help either.

Finally, I tried setting arcNumber to 2998. Debian would not boot after that. It would boot NAND, but after I logged in and issued a reboot, then it would just hang. I booted back to NAND and set arcNumber back to 2097.

What other things can I try to allow the proper cold boot?

Is it good for me to be using the kernel from gorgone?

Edited 2 time(s). Last edit at 11/17/2010 10:57AM by Flavor.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.