Welcome! Log In Create A New Profile

Advanced

debootstrap error on pogoplug E02

Posted by Steve 
Steve
debootstrap error on pogoplug E02
December 01, 2015 10:22PM
I'm trying to get debian running on my pogoplug without much success.

I've seen a few posts with the same problem I'm having, but I can't get their solutions to work.

I I have my usb drive set up and I run

cd /tmp 
wget http://projects.doozan.com/debian/dockstar.debian-squeeze.sh 
chmod +x dockstar.debian-squeeze.sh 
export PATH=$PATH:/usr/sbin:/sbin
./dockstar.debian-squeeze.sh

It gets stuck at:
# Starting debootstrap installation
E: unrecognized or invalid option --no-check-gpg
debootstrap failed.
See /tmp/debian/debootstrap/debootstrap.log for more information.
That error log does not exist.

So I remount / with rw, remove the debootstrap files in /usr/sbin and /usr/share, then run it again. Same error. Reboot, try again, same error.

Running ./debootstrap --version gives me this:
debootstrap 1.0.26+squeeze1

What else can I try? I had Arch installed at one point, but I'm much more familiar with Debian, so I'd love to get that running if at all possible.

Thanks!
Re: debootstrap error on pogoplug E02
December 02, 2015 12:56AM
Steve,

Download the 3.16 rootfs as recommended here, it should run with stock or older u-boot:
http://forum.doozan.com/read.php?4,23425,23427#msg-23427

Later, you can install new u-boot:
http://forum.doozan.com/read.php?3,12381

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: