Welcome! Log In Create A New Profile



Posted by ron 
March 28, 2017 03:52AM
Hi everyone!

Based on what yongki has written
> U-Boot 1.1.4 (Feb 24 2012 - 15:06:45)NC1

the internal LG codename for the N2Bx series are NC1. (Just like NT1 is the codename for the N1T1/N1A1/...). I downloaded the sources from LG and compared the nt1-setup.c and nc1-setup.c BSP files (my DTS was based on the nt1-setup file).

Apart from the different CPUs there are other things that have to be considered:
- The NC1 has an RTC attached to the I2C bus, probably a Ricoh R2025SD.
- It also has a NAND flash, which is at least 16MB large (I couldn't find the MTDPART_SIZ_FULL definition so the size of the last partition is unknown). It shouldn't affect booting from USB but if you want to re-flash the original OS then some adjustments have to be made.
- This also means that there is no SPI flash that is defined in the NT1 DTS.
- There is no USB device support, eg. the NAS can't be attached to a PC as a mass storage device. (IMHO you don't lose anything special)
- USB VBUS and VBUS EN pin definitions seem to be missing, USB power is probably enabled all the time (or U-Boot enables it).
- The HDD power pins are defined, however the function that sets the power state is empty.
- There are some unknown GPIO pin definitions (MPP20, MPP22, MPP32, MPP33) that are probably LEDs or buttons and are controlled from the LG NAS daemon (there are scripts in the original rootfs with pin number definitions, so you can look it up).

The bottom line is that the NT1 DTS cannot be used for the NC1/N2B1. Maybe you'll have success by modifying some kernel arguments (like removing the mtdparts=spi... part) but it won't be a 100% stable/functional unit.
My advice is to either create a DTS based on the NT1 DTS and the nc1-setup.c, nt1-setup.c file. Or point me to a site where I can buy an N2B1 in the EU for less than 50-60EUR and I'll be happy to port the kernel for the N2B1 :)
Mattias Magnusson
May 29, 2017 03:43PM
Hi, i see this is a seriously old tread and that ny question is not related to the active discussion, but this is my last hope. As you probably understand I also have a N1T1DD1 device that recently broke down, so I bought a new disc and replaced it, now i don't have a recovery disc for my device since it's very old ^^ it sure have served me well after all these years and I still want to kick some life in to this butiful machine.

Does anyone have a original recovery disc of this device or could some one guide me through how to install any os on this device since I don't have anything installed. I have tried to do the power + backup button start but it seams useless without the recovery disc. I would love if you could share your recovery disc in a ISO format or any other image that I could burn my self, i have been in contact with LG about this disc but they say they don't have one or that they can't send me a copy of it in any way. So you're my last hope here guys.

Thanks in advance.
Great regards Mattias Magnusson.
May 30, 2017 06:45AM
Hi Mattias,

I looked at the box of my N1T1TD1 but the CD originally included is not a Recovery CD. In the manual they write explicitly:
"Initialization CD is not provided. Please download LG Network Storage Installer ...."
But there is an old zipped recovery iso on LG's Dutch support page. At the bottom of this page you will find a "NT1 initialization program" as the next to last entry. (Thanks to Tantalus for the hint to the Dutch LG-page, see FAQ "Mein Update ist fehlgeschlagen, was kann ich tun?".) Please note that using the recovery disk will destroy the data on your NAS Box.
On Tantalus' page you will also find alternative custom firmwares for N1T1.

If instead you follow the instructions of this thread here you will get an up-to-date operating system - a bare linux with an up-to-date kernel and the option to install debian software packages. But this solution is near to hardware, e.g. soldering a serial cable. Furthermore you should gain an understanding of the boot loader (uboot).

I refer to the following postings:

Best regards
Mattias Magnusson
May 30, 2017 12:54PM
Awesome! thanks for sharing this with me, i actually got it booted now, firmware upgrading everything right now, and i had lost everything anyway since my HDD died, luckily i got weekly backups on another ext hdd that i keep for safety. So after all firmware upgrades i will most likely just put everything back there again using pydio sync on my desktop :) thanks again!
Mattias Magnusson
May 31, 2017 09:05AM
So after a couple of firmware upgrades i installed the firmware 111223 just like any regular bin firmware upgrade, i did a backup and it was working fine, the first boot. After i restarted the N1T1 i found out that i don't have access to / on this server, so i figured something went wrong durring the upgrade, and i tried to reset it once more just to be sure that something was wrong. Yes it's not allowing me to access / on this server probably some apache issues regarding the interface on port 8000. well i inserted my disc that i had just burnt and figured i had to restart and NOT install firmware 111223. now im stuck, it happens absolutely nothing at all. the HDD led i blinking like christmas and it's been like this for that last 18 hours no web interface, no sounds at boot, no nothing.

Any idea whats wrong?

What happens in upgrade 111223 except the new interface?
June 01, 2017 06:46AM
Hi Mattias,

I never did this upgrade myself so I can only look at what others write about it.

According to LG's download page the update 111223 is an update of the uboot firmware (see "Uboot file (new_ui_uboot_update_111223.bin) for New User Interface update -N1T1" on the download page).
"uboot" is the device's boot loader and it is stored on your N1T1's mainboard, not on the harddisk.

Did you check your uboot version on the "[Log] -> [Self-diagnosis] page" after your upgrade as it is recommended in LG's readme N1T1(ew)_uboot.txt?

Anyhow, in case you have still a working uboot, you could get control of it by soldering a serial interface to your mainboard as described in this forum. Over this serial interface you can watch the boot process, look where it fails and even get a command line of uboot in order to get control of the boot process.
In case your uboot is broken, maybe you could flash it on a hardware level soldering even some other connections (JT...) to the mainboard, but this is beyond my knowledge.
July 31, 2017 06:07PM
I dont mind giving you root access to my N2R1D which is based on the NC1 system
I have been looking at updating my nas and maybe get something else running like an up to date debian or Alpine Linux due to the lower requirements.
September 25, 2017 01:57PM
Is there any possibility that this could be installed directly to the hard drive? The reason I ask is that I can't seem to get the NAS to initialize, even with the disk. I don't have a serial cable, and it would take me a few weeks to get one, but I do have a hard drive dock. Is it possible that I could write directly to the hard drive to bypass the need for a console cable?

Thanks in advance!
September 30, 2017 09:28AM

the interface and the numbers of the boot and root partitions are configured in uboot (see step 6 and 10 in Ron's mini howto). This configuration must match with the interface and partitioning of your hard drive where you want to boot from. Maybe you can make your hard drive match the existing configuration of your uboot loader by looking at your original harddrive, but in order to get actually control of the configuration and the bootloader, you should get the serial adapter. I got mine from Amazon in a few days.
September 30, 2017 12:03PM
Alright, thanks bernd. I live outside of the US, so it takes a bit longer to get things in the mail (deliveries usually happen once a week), but I'll look into getting one. Thanks again.
Clark Leach
October 12, 2017 01:14PM
I created a CD from the "NT1 Initialization Program" mentioned above, inserted it, and rebooted the device while holding the BACK-UP button. The thing has been blinking the HDD and Network lights for hours now. I'm fairly confident in saying that this is a bad sign. I was given this N1T1DD1 and it seems like just the sort of device I need for sharing files on my network. It seemed to work fine - I could find it on my network and get the web interface up on my browser - but I was unable to login. This seemed like the fast way to reset it to factory settings and put it to use. Any suggestions as to what my next move might be? I'm no Linux wizard but also not incompetent...
Clark Leach
October 13, 2017 02:05PM
Trying the NT1 Initialization apparently did nothing; the thing still boots and seems to run. The web interface is accessible but I can't log on.

So, I connected my FTDI TTL-232R-3V3 as directed (I think) but I'm seeing nothing on my terminal when I restart the N1T1 (except one unprintable character, most likely garbage created on power-up). The four pins on the N1T1 main board are connected, starting at the end nearest the power jack, as follows: N/C, RXD (YLW), TXD (ORG), GND (BLK).

Any thoughts on troubleshooting this?
October 13, 2017 05:07PM
Try swapping RxD and TxD.
October 14, 2017 10:09AM
@Clark Leach

If you use the latest u-boot version from LG then the old Initialization Program won't work. For the latest u-boot version you have to use N1T1_eng.zip instead.

The procedure to factory reset the N1T1DD1 with the latest u-boot is:

1. Press the backup button and power button at the same time. This will boot to recovery mode.
2. Open the the program in the zip folder and proceed with factory reset. NOTE: the zip file includes an old firmware, you can replace it with a newer firmware if you want. But dont forget to edit the textfile with the name of the firmware.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.