Welcome! Log In Create A New Profile

Advanced

Debian on Medion NAS MD 86xxx (MitraStar STG-212)

Posted by pengu 
I managed to install the new uboot but somehow my kernel isnt starting.
My partitions are like this:
  1. rootfs with /boot(kernel and u-boot.img)
  2. data (empty)
  3. swap
i used debian rootfs (Debian-4.4.54-oxnas-tld-1-rootfs-bodhi.tar.bz2 (02 Aug 2017) ).

bootlog:

U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2015.10-tld-2 (Oct 21 2017 - 22:00:02 -0700)
OXNAS OX820

DRAM:  128 MiB
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   dwmac.40400000
Hit any key to stop autoboot:  0 

Reset IDE: Bus 0: OK 
  Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#:  WD-WCAZAL357097
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (3907029168 x 512)
4621824 bytes read in 1609 ms (2.7 MiB/s)
4594376 bytes read in 1565 ms (2.8 MiB/s)
7067 bytes read in 15 ms (460 KiB/s)
## Booting kernel from Legacy Image at 60500000 ...
   Image Name:   Linux-4.4.54-oxnas-tld-1
   Created:      2017-08-01   4:45:36 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4621760 Bytes = 4.4 MiB
   Load Address: 60008000
   Entry Point:  60008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 60e00000 ...
   Image Name:   initramfs-4.4.54-oxnas-tld-1
   Created:      2017-08-01   7:51:04 UTC
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    4594312 Bytes = 4.4 MiB
   Load Address: 60000000
   Entry Point:  60000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 62c00000
   Booting using the fdt blob at 0x62c00000
   Loading Kernel Image ... OK
   Loading Ramdisk to 679c4000, end 67e25a88 ... OK
   Loading Device Tree to 679bf000, end 679c3b9a ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.


printenv(most variables unused):
autoload=no
baudrate=115200
bootargs=console=ttyS0,115200n8
bootcmd=run dt_bootcmd_ide
bootcmd_uenv=run uenv_load; if test $uenv_loaded -eq 1; then run uenv_import; fi
bootdelay=10
console=console=ttyS0,115200n8
devices=usb ide
dt_bootcmd_ide=ide reset; run dt_ide_bootcmd; reset
dt_bootcmd_usb=usb start; run dt_usb_bootcmd; usb stop; reset
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
dt_ide_boot=run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_ide_bootcmd=run ide_set_bootargs; run dt_ide_boot
dt_load_dtb=ext2load ide 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_load_id=ide 0:1 0x60e00000 /boot/uInitrd\
setenv dt_load_u ext2load ide 0:1 0x60500000 /boot/uImage\
setenv dt_ide_borun dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_load_initrd=ext2load ide 0:1 $uinitrd_addr /boot/uInitrd
dt_load_uimage=ext2load ide 0:1 $uimage_addr /boot/uImage
dt_usb_boot=run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_usb_bootcmd=run usb_set_bootargs; run dt_usb_boot
dtb_addr=0x62c00000
ethact=dwmac.40400000
ethaddr=5e:2b:15:71:ec:b6
ide_set_bootargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10
ide_set_btargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10
if_netconsole=ping $serverip
ipaddr=192.168.0.222
mtdids=nand0=41000000.nand
mtdparts=mtdparts=41000000.nand:14m(boot),-(data)
preboot_nc=run if_netconsole start_netconsole
serverip=192.168.0.220
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version
stderr=serial
stdin=serial
stdout=serial
uenv_import=echo importing envs ...; env import -t 0x60500000
uenv_init_devices=setenv init_usb "usb start";  setenv init_ide "ide reset";  setenv init_mmc "mmc rescan"; for devtype in $devices; do run init_$devtype; done;
uenv_load=run uenv_init_devices; setenv uenv_loaded 0; for devtype in $devices;  do for disknum in 0; do run uenv_read_disk; done; done;
uenv_read=echo loading envs from $devtype $disknum ...; if load $devtype $disknum:1 0x60500000 /boot/uEnv.txt; then setenv uenv_loaded 1; fi
uenv_read_disk=if test $devtype -eq mmc; then if $devtype part; then run uenv_read;  fi; else if $devtype part $disknum; then run uenv_read; fi;  fi
uimage_addr=0x60500000
uinitrd_addr=0x60e00000
usb_device=0:1
usb_set_bootargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10

to set up the env i used this from here:
setenv uinitrd_addr '0x60e00000'
setenv uimage_addr '0x60500000'
setenv dtb_addr '0x62c00000'
setenv ide_set_bootargs 'setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10'
setenv dt_bootm 'bootm $uimage_addr $uinitrd_addr $dtb_addr'
setenv dt_load_dtb 'ext2load ide 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb'
setenv dt_load_initrd 'ext2load ide 0:1 $uinitrd_addr /boot/uInitrd'
setenv dt_load_uimage 'ext2load ide 0:1 $uimage_addr /boot/uImage'
setenv dt_ide_boot 'run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm'
setenv dt_ide_bootcmd 'run ide_set_bootargs; run dt_ide_boot'
setenv dt_bootcmd_ide 'ide reset; run dt_ide_bootcmd; reset'
setenv bootcmd 'run dt_bootcmd_ide'

Now my question is, is it beacuse the kernel,u-boot.img and rootfs are in one partition or because the kernel isnt working.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 13, 2019 05:53PM
steven,

Looks like you've missed these steps while installing u-boot. You did not flash the envs image.

9. Erase 1 block starting 0x00100000 
/usr/sbin/flash_erase /dev/mtd0 0x00100000 1
Expected output 
Erasing 128 Kibyte @ 100000 -- 100 % complete

10. Flash uboot environment to 0x00100000 
/usr/sbin/nandwrite -s 1048576 /dev/mtd0 uboot.2015.10-tld-2.ox820.environment.img

You should only the u-boot instruction to flash and then set up your envs. Don't use any other instruction.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 05/13/2019 05:54PM by bodhi.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 18, 2019 05:45PM
steven,

With the Debian-4.4.54-oxnas-tld-1-rootfs-bodhi.tar.bz2 on USB.

Power up, interrupt serial console, and

printenv

Please post the serial console log up until this point. I will post the flashing commands in u-boot to flash the envs image after seeing the log.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 19, 2019 06:47AM
I prepared the hdd like described in this post (without changing the env variables and without putting the debian rootfs on the hdd i just load the boot directory from ox820-sata-uboot.tar.gz on the first partition of the hdd.)

and put debian rootfs on an usb with ext3 format.

this is the printenv
U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM:  128 MiB
IDE:   Bus 0: OK 
  Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#:  WD-WCAZAL357097
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   
Led:	GREEN
mii0
Main Loop
Hit any key to stop autoboot:  0 
OX820 # printenv
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
autoload=no
baudrate=115200
bootargs=console=ttyS0,115200n8
bootcmd=run dt_bootcmd_ide
bootdelay=3
console=console=ttyS0,115200n8
dt_bootcmd_ide=ide start; run dt_ide_bootcmd; ide stop; reset
dt_bootcmd_usb=usb start; run dt_usb_bootcmd; usb stop; reset
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
dt_ide_boot=run dt_ide_load_uimage; run dt_ide_load_initrd; run dt_ide_load_dtb; run dt_bootm
dt_ide_bootcmd=run ide_set_bootargs; run dt_sata_boot
dt_ide_load_dtb=ext2load ide 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_ide_load_initrd=ext2load ide 0:1 $uinitrd_addr /boot/uInitrd
dt_ide_load_uimage=ext2load ide 0:1 $uimage_addr /boot/uImage
dt_load_dtb=ext2load usb 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_load_initrd=ext2load usb 0:1 $uinitrd_addr /boot/uInitrd
dt_load_uimage=ext2load usb 0:1 $uimage_addr /boot/uImage
dt_sata_boot=ext2load ide 0:1 $uimage_addr /boot/uImage_2.6.31.14_OX820_1.2_shv.Pro; bootm $uimage_addr
dt_usb_boot=run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_usb_bootcmd=run usb_set_bootargs; run dt_usb_boot
dtb_addr=0x62c00000
ethact=mii0
ethaddr=00:25:31:01:C6:76
ide_set_bootargs=setenv bootargs root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
if_netconsole=ping $serverip
ipaddr=192.168.0.100
mtdids=nand0=41000000.nand
mtdparts=mtdparts=41000000.nand:14m(boot),-(data)
preboot_nc=run if_netconsole start_netconsole
sata_bootcmd=run usb_set_bootargs; run sata_boot
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version
stderr=serial
stdin=serial
stdout=serial
uimage_addr=0x60500000
uinitrd_addr=0x60e00000
usb_device=0:1
usb_set_bootargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10

this is the bootlog with usb attached and no interruption

U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM:  128 MiB
IDE:   Bus 0: OK 
  Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#:  WD-WCAZAL357097
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   
Led:	GREEN
mii0
Main Loop
Hit any key to stop autoboot:  0 
ide - IDE sub-system

Usage:
ide reset - reset IDE controller
ide info  - show available IDE devices
ide device [dev] - show or set current device
ide part [dev] - print partition table of one or all IDE devices
ide read  addr blk# cnt
ide write addr blk# cnt - read/write `cnt' blocks starting at block `blk#'
    to/from memory address `addr'
2212156 bytes read in 605 ms (3.5 MiB/s)
## Booting kernel from Legacy Image at 60500000 ...
   Image Name:   Linux-2.6.31.14_OX820_1.2_shv
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2212092 Bytes = 2.1 MiB
   Load Address: 60008000
   Entry Point:  60008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Led:	GREEN

Starting kernel ...

Uncompressing Linux....................................................................................................................................... done, booting the kernel.
[    0.000000] Linux version 2.6.31.14_OX820_1.2_shv (root@plug2) (gcc version 4.4.5 (Debian 4.4.5-8) ) #1 SMP Fri Oct 4 11:38:10 CEST 2013
[    0.000000] CPU: ARMv6-compatible processor [410fb025] revision 5 (ARMv7), cr=00c5387f
[    0.000000] CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[    0.000000] Machine: Oxsemi NAS
[    0.000000] 1 memory region
[    0.000000] Ignoring unrecognised tag 0x00000000
[    0.000000] Memory policy: ECC disabled, Data cache writealloc
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
[    0.000000] PID hash table entries: 512 (order: 9, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Memory: 128MB = 128MB total
[    0.000000] Memory: 125368KB available (3816K code, 304K data, 132K init, 0K highmem)
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS:96
[    0.000000] OX820_RPS_init_irq: interrupts 64 to 96
[    0.010000] Console: colour dummy device 80x30
[    0.010000] console [ttyS0] enabled
[    0.020000] Calibrating delay loop... 339.14 BogoMIPS (lpj=1695744)
[    0.230000] Security Framework initialized
[    0.230000] Mount-cache hash table entries: 512
[    0.240000] CPU: Testing write buffer coherency: ok
[    0.240000] Calibrating local timer... 425.50MHz.
[    0.310000] CPU1: Booted secondary processor
[    0.410000] Calibrating delay loop... 339.14 BogoMIPS (lpj=1695744)
[    0.620000] Brought up 2 CPUs
[    0.630000] SMP: Total of 2 processors activated (678.29 BogoMIPS).
[    0.640000] NET: Registered protocol family 16
[    0.640000] Number of DMA channels = 4, version = 4
[    0.650000] Reserving a DMA channel for DirectRAID
[    0.650000] Allocating 389 SRAM generic DMA descriptors
aferwards i tried to run it manually with this command (run dt_bootcmd_usb)
OX820 # run dt_bootcmd_usb
(Re)start USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 2 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
** File not found /boot/uImage **
** File not found /boot/uInitrd **
** File not found /boot/ox820-stg212.dtb **
Wrong Image Format for bootm command

Led:	ORANGE (Failed)
ERROR: can't get kernel image!
stopping USB..
resetting ...
My best guess is that the usb is not formatted correctly



Edited 2 time(s). Last edit at 05/19/2019 10:09AM by steveyyyy.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 19, 2019 05:41PM
steven,

Since this OXNAS SoC will boot with SATA first if you have a special format hex string (aka WarheadsSE's magic dust) in raw sector on the HDD attached. Basically, u-boot stored in your HDD takes precedent, u-boot in NAND is second in line.

- Remove the HDD.
- With USB rootfs attached.

Power up and interrupt serial console,

printenv
And post the serial log here.

I'd like to make sure that the NAND u-boot and SPL look OK.

And then we can populate the correct envs.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 19, 2019 11:52PM
The output without hdd but usb attached is nothing. It doesnt even boot so i guess nand is bricked/broken.

I used WarheadsSE's magic dust without uImage and uboot i changed the script that it would use u-boot-spl.bin from ox820-sata-uboot.tar.gz as stage1 and but the uboot.env and the other images like the description here.

And btw i have a working tftp server if i need it to restore nand.



Edited 3 time(s). Last edit at 05/20/2019 12:16AM by steveyyyy.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 20, 2019 12:15AM
steven,


> The output without hdd but usb attached is
> nothing. It doesnt even boot so i guess nand is
> bricked/broken.

Then it means you have not flashed the new u-boot and SPL to NAND (and currently you don't have a valid u-boot on NAND).

My impression was that you have flashed u-boot to NAND when you posted:

U-Boot 2015.10-tld-2 (Oct 21 2017 - 22:00:02 -0700)
OXNAS OX820

DRAM:  128 MiB
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   dwmac.40400000
Hit any key to stop autoboot:  0 

Reset IDE: Bus 0: OK 
  Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#:  WD-WCAZAL357097
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (3907029168 x 512)
4621824 bytes read in 1609 ms (2.7 MiB/s)
4594376 bytes read in 1565 ms (2.8 MiB/s)

Now, it means you are booting with SPL and u-boot from HDD. But the envs are not correct so you cannot boot to the rootfs on HDD or USB.

====

To recap, with USB roots and the envs as posted below. I will write a few envs to get you boot to USB rootfs. And then you can flash SPL and u-boot to NAND.



Quote

and put debian rootfs on an usb with ext3 format.

this is the printenv
U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
Boot device: SATA
Attempting to set PLLA to 850 MHz ...
plla_ctrl0 : 0000020a
plla_ctrl1 : 00330000
plla_ctrl2 : 0065008b
plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK
Device 0:
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM: 128 MiB
IDE: Bus 0: OK
Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#: WD-WCAZAL357097
Type: Hard Disk
Supports 48-bit addressing
Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
NAND: 128 MiB
In: serial
Out: serial
Err: serial
Net:
Led: GREEN
mii0
Main Loop
Hit any key to stop autoboot: 0
OX820 # printenv
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
autoload=no
baudrate=115200
bootargs=console=ttyS0,115200n8
bootcmd=run dt_bootcmd_ide
bootdelay=3
console=console=ttyS0,115200n8
dt_bootcmd_ide=ide start; run dt_ide_bootcmd; ide stop; reset
dt_bootcmd_usb=usb start; run dt_usb_bootcmd; usb stop; reset
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
dt_ide_boot=run dt_ide_load_uimage; run dt_ide_load_initrd; run dt_ide_load_dtb; run dt_bootm
dt_ide_bootcmd=run ide_set_bootargs; run dt_sata_boot
dt_ide_load_dtb=ext2load ide 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_ide_load_initrd=ext2load ide 0:1 $uinitrd_addr /boot/uInitrd
dt_ide_load_uimage=ext2load ide 0:1 $uimage_addr /boot/uImage
dt_load_dtb=ext2load usb 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_load_initrd=ext2load usb 0:1 $uinitrd_addr /boot/uInitrd
dt_load_uimage=ext2load usb 0:1 $uimage_addr /boot/uImage
dt_sata_boot=ext2load ide 0:1 $uimage_addr /boot/uImage_2.6.31.14_OX820_1.2_shv.Pro; bootm $uimage_addr
dt_usb_boot=run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_usb_bootcmd=run usb_set_bootargs; run dt_usb_boot
dtb_addr=0x62c00000
ethact=mii0
ethaddr=00:25:31:01:C6:76
ide_set_bootargs=setenv bootargs root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
if_netconsole=ping $serverip
ipaddr=192.168.0.100
mtdids=nand0=41000000.nand
mtdparts=mtdparts=41000000.nand:14m(boot),-(data)
preboot_nc=run if_netconsole start_netconsole
sata_bootcmd=run usb_set_bootargs; run sata_boot
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version
stderr=serial
stdin=serial
stdout=serial
uimage_addr=0x60500000
uinitrd_addr=0x60e00000
usb_device=0:1
usb_set_bootargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 20, 2019 12:20AM
I used WarheadsSE's magic dust without uImage and uboot i changed the script that it would use u-boot-spl.bin from ox820-sata-uboot.tar.gz as stage1 and but the uboot.env and the other images like the description here.

And I dont know how to put it on nand.

And btw i have a working tftp server if it is needed to restore nand.



Edited 1 time(s). Last edit at 05/20/2019 12:28AM by steveyyyy.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 20, 2019 12:32AM
steven,

With the USB rootfs attached. Power up, interrupt serial console and

setenv usb_set_bootargs 'setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 earlyprintk=serial'
setenv dt_load_dtb 'ext2load usb 0:1 $dtb_addr /boot/dts/ox820-stg212.dtb'
setenv bootcmd 'run dt_bootcmd_usb'
boot

After you have booted into the USB Debian rootfs. You can then flash SPL and u-boot to NAND following the instruction in the release thread:
https://forum.doozan.com/read.php?3,16017

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 05/20/2019 12:38AM by bodhi.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 20, 2019 12:24PM
I did it, the kernel booted but i run into a kernel panic.

U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM:  128 MiB
IDE:   Bus 0: OK 
  Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#:  WD-WCAZAL357097
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   
Led:	GREEN
mii0
Main Loop
Hit any key to stop autoboot:  0 
OX820 # setenv usb_set_bootargs 'setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 earlyprintk=serial'
OX820 # setenv dt_load_dtb 'ext2load usb 0:1 $dtb_addr /boot/dts/ox820-stg212.dtb'
OX820 # setenv bootcmd 'run dt_bootcmd_usb'
OX820 # boot
(Re)start USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 2 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
4629048 bytes read in 427 ms (10.3 MiB/s)
4594376 bytes read in 445 ms (9.8 MiB/s)
7224 bytes read in 193 ms (36.1 KiB/s)
## Booting kernel from Legacy Image at 60500000 ...
   Image Name:   Linux-4.4.54-oxnas-tld-1
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4628984 Bytes = 4.4 MiB
   Load Address: 60008000
   Entry Point:  60008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 60e00000 ...
   Image Name:   initramfs-4.4.54-oxnas-tld-1
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    4594312 Bytes = 4.4 MiB
   Load Address: 60000000
   Entry Point:  60000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 62c00000
   Booting using the fdt blob at 0x62c00000
   Loading Kernel Image ... OK
   Loading Ramdisk to 679c6000, end 67e27a88 ... OK
   Loading Device Tree to 679c1000, end 679c5c37 ... OK

Led:	GREEN

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.4.54-oxnas-tld-1 (root@tldDebian) (gcc version 4.9.2 (Debian 4.9.2-10) ) #2 SMP PREEMPT Sat Mar 18 23:09:58 PDT 2017
[    0.000000] CPU: ARMv6-compatible processor [410fb025] revision 5 (ARMv7), cr=00c5787d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] Machine model: MitraStar Technology Corp. STG-212
[    0.000000] bootconsole [earlycon0] enabled
[    0.000000] Memory policy: Data cache writealloc
[    0.000000] Kernel panic - not syncing: ERROR: Failed to allocate 0x2000 bytes below 0x0.
[    0.000000] 
[    0.000000] CPU: 0 PID: 0 Comm: swapper Not tainted 4.4.54-oxnas-tld-1 #2
[    0.000000] Hardware name: PLXTECH NAS782X SoC (Flattened Device Tree)
[    0.000000] [<c0010c6c>] (unwind_backtrace) from [<c000cf8c>] (show_stack+0x10/0x14)
[    0.000000] [<c000cf8c>] (show_stack) from [<c02cf840>] (dump_stack+0x84/0xa0)
[    0.000000] [<c02cf840>] (dump_stack) from [<c0091c78>] (panic+0x8c/0x1ec)
[    0.000000] [<c0091c78>] (panic) from [<c0835b7c>] (memblock_alloc_base+0x34/0x40)
[    0.000000] [<c0835b7c>] (memblock_alloc_base) from [<c082cf44>] (early_alloc_aligned+0xc/0x2c)
[    0.000000] [<c082cf44>] (early_alloc_aligned) from [<c082dfe0>] (paging_init+0x764/0xa1c)
[    0.000000] [<c082dfe0>] (paging_init) from [<c082ae54>] (setup_arch+0x508/0x8f8)
[    0.000000] [<c082ae54>] (setup_arch) from [<c0828940>] (start_kernel+0x80/0x3ac)
[    0.000000] [<c0828940>] (start_kernel) from [<60008074>] (0x60008074)
[    0.000000] ---[ end Kernel panic - not syncing: ERROR: Failed to allocate 0x2000 bytes below 0x0.
[    0.000000]

Here you wrote that it is because the bootargs.bin is missing, how can i generate one or where do i get one.

The other person of the forum just used "Schnee"s file-system package but i couldn't find it.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 20, 2019 10:24PM
steven,

OK. I think it is not ready for you to boot USB rootfs. Let's go back to the beginning, starting fresh.

Plug in the HDD, no USB. Power up, Interrupt serial console and

printenv
boot

And post the entire serial console here (meaning every thing you see on the screen from the moment you power up).

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 21, 2019 11:52AM
Here is the Bootlog without USB attached, the env is untouched.
U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM:  128 MiB
IDE:   Bus 0: OK 
  Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#:  WD-WCAZAL357097
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   
Led:	GREEN
mii0
Main Loop
Hit any key to stop autoboot:  0 
OX820 # printenv
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
autoload=no
baudrate=115200
bootargs=console=ttyS0,115200n8
bootcmd=run dt_bootcmd_ide
bootdelay=3
console=console=ttyS0,115200n8
dt_bootcmd_ide=ide start; run dt_ide_bootcmd; ide stop; reset
dt_bootcmd_usb=usb start; run dt_usb_bootcmd; usb stop; reset
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
dt_ide_boot=run dt_ide_load_uimage; run dt_ide_load_initrd; run dt_ide_load_dtb; run dt_bootm
dt_ide_bootcmd=run ide_set_bootargs; run dt_sata_boot
dt_ide_load_dtb=ext2load ide 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_ide_load_initrd=ext2load ide 0:1 $uinitrd_addr /boot/uInitrd
dt_ide_load_uimage=ext2load ide 0:1 $uimage_addr /boot/uImage
dt_load_dtb=ext2load usb 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_load_initrd=ext2load usb 0:1 $uinitrd_addr /boot/uInitrd
dt_load_uimage=ext2load usb 0:1 $uimage_addr /boot/uImage
dt_sata_boot=ext2load ide 0:1 $uimage_addr /boot/uImage_2.6.31.14_OX820_1.2_shv.Pro; bootm $uimage_addr
dt_usb_boot=run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_usb_bootcmd=run usb_set_bootargs; run dt_usb_boot
dtb_addr=0x62c00000
ethact=mii0
ethaddr=00:25:31:01:C6:76
ide_set_bootargs=setenv bootargs root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
if_netconsole=ping $serverip
ipaddr=192.168.0.100
mtdids=nand0=41000000.nand
mtdparts=mtdparts=41000000.nand:14m(boot),-(data)
preboot_nc=run if_netconsole start_netconsole
sata_bootcmd=run usb_set_bootargs; run sata_boot
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version
stderr=serial
stdin=serial
stdout=serial
uimage_addr=0x60500000
uinitrd_addr=0x60e00000
usb_device=0:1
usb_set_bootargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10

Environment size: 1898/16380 bytes
OX820 # boot
ide - IDE sub-system

Usage:
ide reset - reset IDE controller
ide info  - show available IDE devices
ide device [dev] - show or set current device
ide part [dev] - print partition table of one or all IDE devices
ide read  addr blk# cnt
ide write addr blk# cnt - read/write `cnt' blocks starting at block `blk#'
    to/from memory address `addr'
2212156 bytes read in 1025 ms (2.1 MiB/s)
## Booting kernel from Legacy Image at 60500000 ...
   Image Name:   Linux-2.6.31.14_OX820_1.2_shv
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2212092 Bytes = 2.1 MiB
   Load Address: 60008000
   Entry Point:  60008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Led:	GREEN

Starting kernel ...

Uncompressing Linux....................................................................................................................................... done, booting the kernel.
[    0.000000] Linux version 2.6.31.14_OX820_1.2_shv (root@plug2) (gcc version 4.4.5 (Debian 4.4.5-8) ) #1 SMP Fri Oct 4 11:38:10 CEST 2013
[    0.000000] CPU: ARMv6-compatible processor [410fb025] revision 5 (ARMv7), cr=00c5387f
[    0.000000] CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[    0.000000] Machine: Oxsemi NAS
[    0.000000] 1 memory region
[    0.000000] Ignoring unrecognised tag 0x00000000
[    0.000000] Memory policy: ECC disabled, Data cache writealloc
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
[    0.000000] PID hash table entries: 512 (order: 9, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Memory: 128MB = 128MB total
[    0.000000] Memory: 125368KB available (3816K code, 304K data, 132K init, 0K highmem)
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS:96
[    0.000000] OX820_RPS_init_irq: interrupts 64 to 96
[    0.010000] Console: colour dummy device 80x30
[    0.010000] console [ttyS0] enabled
[    0.020000] Calibrating delay loop... 339.14 BogoMIPS (lpj=1695744)
[    0.230000] Security Framework initialized
[    0.230000] Mount-cache hash table entries: 512
[    0.240000] CPU: Testing write buffer coherency: ok
[    0.240000] Calibrating local timer... 425.50MHz.
[    0.310000] CPU1: Booted secondary processor
[    0.410000] Calibrating delay loop... 339.14 BogoMIPS (lpj=1695744)
[    0.620000] Brought up 2 CPUs
[    0.630000] SMP: Total of 2 processors activated (678.29 BogoMIPS).
[    0.640000] NET: Registered protocol family 16
[    0.640000] Number of DMA channels = 4, version = 4
[    0.650000] Reserving a DMA channel for DirectRAID
[    0.650000] Allocating 389 SRAM generic DMA descriptors



Edited 2 time(s). Last edit at 05/21/2019 12:15PM by steveyyyy.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 22, 2019 02:25PM
steven,

I'm confused!

The 1st post:

U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2015.10-tld-2 (Oct 21 2017 - 22:00:02 -0700)
OXNAS OX820

DRAM:  128 MiB
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   dwmac.40400000
Hit any key to stop autoboot:  0

The last post:

U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
  Boot device: SATA
Attempting to set PLLA to 850 MHz ...
  plla_ctrl0 : 0000020a
  plla_ctrl1 : 00330000
  plla_ctrl2 : 0065008b
  plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK 
  Device 0: 
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM:  128 MiB
IDE:   Bus 0: OK

In both cases, you are booting with the specially formatted HDD, with u-boot and SPL are on it.

Which is correct?

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 22, 2019 04:05PM
Yes, then without the hdd it doesnt boot anything. The hdd doesnt even boot ub totally it just stucks at
[    0.650000] Allocating 389 SRAM generic DMA descriptors

and with thw usb i got
Kernel panic - not syncing: ERROR: Failed to allocate 0x2000 bytes below 0x0.

booting only with usb doesnt work, becaus ethe nand is corrupted/broken. So first things first i need to run a system to it and then repair uboot by flashing it like this.
The problem is i cant figure out why it doesnt boot.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 23, 2019 12:41AM
steven,


So is this the current system? (I should ignore the first post).


Quote

U-Boot SPL 2013.10-g3a0f380-dirty (Jul 26 2014 - 14:31:34)
Boot device: SATA
Attempting to set PLLA to 850 MHz ...
plla_ctrl0 : 0000020a
plla_ctrl1 : 00330000
plla_ctrl2 : 0065008b
plla_ctrl3 : 000000f1

PLLA Set
Bus 0: OK
Device 0:
** File not found /boot/bootargs.bin **


U-Boot 2013.10-g3a0f380-dirty (Jul 26 2014 - 10:18:57) for OXNAS

DRAM: 128 MiB
IDE: Bus 0: OK
Device 0: Model: WDC WD20EARX-00PASB0 Firm: 51.0AB51 Ser#: WD-WCAZAL357097
Type: Hard Disk
Supports 48-bit addressing
Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
NAND: 128 MiB
In: serial
Out: serial
Err: serial
Net:
Led: GREEN
mii0
Main Loop
Hit any key to stop autoboot: 0
OX820 # printenv
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
autoload=no
baudrate=115200
bootargs=console=ttyS0,115200n8
bootcmd=run dt_bootcmd_ide
bootdelay=3
console=console=ttyS0,115200n8
dt_bootcmd_ide=ide start; run dt_ide_bootcmd; ide stop; reset
dt_bootcmd_usb=usb start; run dt_usb_bootcmd; usb stop; reset
dt_bootm=bootm $uimage_addr $uinitrd_addr $dtb_addr
dt_ide_boot=run dt_ide_load_uimage; run dt_ide_load_initrd; run dt_ide_load_dtb; run dt_bootm
dt_ide_bootcmd=run ide_set_bootargs; run dt_sata_boot
dt_ide_load_dtb=ext2load ide 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_ide_load_initrd=ext2load ide 0:1 $uinitrd_addr /boot/uInitrd
dt_ide_load_uimage=ext2load ide 0:1 $uimage_addr /boot/uImage
dt_load_dtb=ext2load usb 0:1 $dtb_addr /boot/dts/ox820-pogoplug-pro.dtb
dt_load_initrd=ext2load usb 0:1 $uinitrd_addr /boot/uInitrd
dt_load_uimage=ext2load usb 0:1 $uimage_addr /boot/uImage
dt_sata_boot=ext2load ide 0:1 $uimage_addr /boot/uImage_2.6.31.14_OX820_1.2_shv.Pro; bootm $uimage_addr
dt_usb_boot=run dt_load_uimage; run dt_load_initrd; run dt_load_dtb; run dt_bootm
dt_usb_bootcmd=run usb_set_bootargs; run dt_usb_boot
dtb_addr=0x62c00000
ethact=mii0
ethaddr=00:25:31:01:C6:76
ide_set_bootargs=setenv bootargs root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
if_netconsole=ping $serverip
ipaddr=192.168.0.100
mtdids=nand0=41000000.nand
mtdparts=mtdparts=41000000.nand:14m(boot),-(data)
preboot_nc=run if_netconsole start_netconsole
sata_bootcmd=run usb_set_bootargs; run sata_boot
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version
stderr=serial
stdin=serial
stdout=serial
uimage_addr=0x60500000
uinitrd_addr=0x60e00000
usb_device=0:1
usb_set_bootargs=setenv bootargs console=ttyS0,115200 root=/dev/sda1 rootdelay=10

Environment size: 1898/16380 bytes
OX820 # boot
ide - IDE sub-system

Usage:
ide reset - reset IDE controller
ide info - show available IDE devices
ide device [dev] - show or set current device
ide part [dev] - print partition table of one or all IDE devices
ide read addr blk# cnt
ide write addr blk# cnt - read/write `cnt' blocks starting at block `blk#'
to/from memory address `addr'
2212156 bytes read in 1025 ms (2.1 MiB/s)
## Booting kernel from Legacy Image at 60500000 ...
Image Name: Linux-2.6.31.14_OX820_1.2_shv
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2212092 Bytes = 2.1 MiB
Load Address: 60008000
Entry Point: 60008000
Verifying Checksum ... OK
Loading Kernel Image ... OK

Led: GREEN

Starting kernel ...

Uncompressing Linux....................................................................................................................................... done, booting the kernel.
[ 0.000000] Linux version 2.6.31.14_OX820_1.2_shv (root@plug2) (gcc version 4.4.5 (Debian 4.4.5-8) ) #1 SMP Fri Oct 4 11:38:10 CEST 2013
[ 0.000000] CPU: ARMv6-compatible processor [410fb025] revision 5 (ARMv7), cr=00c5387f
[ 0.000000] CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[ 0.000000] Machine: Oxsemi NAS
[ 0.000000] 1 memory region
[ 0.000000] Ignoring unrecognised tag 0x00000000
[ 0.000000] Memory policy: ECC disabled, Data cache writealloc
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512
[ 0.000000] Kernel command line: root=/dev/sda2 rootfstype=ext3 console=ttyS0,115200 mem=128M
[ 0.000000] PID hash table entries: 512 (order: 9, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Memory: 128MB = 128MB total
[ 0.000000] Memory: 125368KB available (3816K code, 304K data, 132K init, 0K highmem)
[ 0.000000] Hierarchical RCU implementation.
[ 0.000000] NR_IRQS:96
[ 0.000000] OX820_RPS_init_irq: interrupts 64 to 96
[ 0.010000] Console: colour dummy device 80x30
[ 0.010000] console [ttyS0] enabled
[ 0.020000] Calibrating delay loop... 339.14 BogoMIPS (lpj=1695744)
[ 0.230000] Security Framework initialized
[ 0.230000] Mount-cache hash table entries: 512
[ 0.240000] CPU: Testing write buffer coherency: ok
[ 0.240000] Calibrating local timer... 425.50MHz.
[ 0.310000] CPU1: Booted secondary processor
[ 0.410000] Calibrating delay loop... 339.14 BogoMIPS (lpj=1695744)
[ 0.620000] Brought up 2 CPUs
[ 0.630000] SMP: Total of 2 processors activated (678.29 BogoMIPS).
[ 0.640000] NET: Registered protocol family 16
[ 0.640000] Number of DMA channels = 4, version = 4
[ 0.650000] Reserving a DMA channel for DirectRAID
[ 0.650000] Allocating 389 SRAM generic DMA descriptors


If yes, then I can help you boot into the USB rootfs. Add then you will install u-boot and SPL to NAND.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 23, 2019 03:30AM
Yes correct, you can ignore the first bootlog.

And like i said the booting from USB doesnt work. Since it runs into problems aka kernel panic.
Re: Debian on Medion NAS MD 86xxx (MitraStar STG-212)
May 24, 2019 12:00AM
Steven,

rootfs with /boot(kernel and u-boot.img)
data (empty)
swap

Since you have 3 paritions, try extracting the rootfs Debian-4.4.54-oxnas-tld-1-rootfs-bodhi.tar.bz2 to the data partition.

If your rootfs is labeled rootfs, temporary relabel if as rootfs_orig or something like that.

On another Linux box, as root, format the data partition as Ext3 and and relabel it rootfs , and then extract the tarball.

And then

fdisk -l

Note the partition number of this new rootfs partition.

And post the log of how you did this.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: