Welcome! Log In Create A New Profile


RESOLVED - webmin upgrade - gone bad & a question

Posted by sandbasser 
RESOLVED - webmin upgrade - gone bad & a question
December 09, 2010 11:51AM
Hi -

Last night I tried to upgrade webmin on my debian/dockstar via a link on the web interface... it rendered my usb-stick unbootable...

I checked both the debian forum and webmin forums and couldn't find any other folks reporting problems.

I suspect it's somehow due to my flawed installation of webmin - it never 'automatically' started after aboot although it looks to me like all the required pieces are in place.

So, fair warning - if you use webmin and try to upgrade it, keep your fingers crossed. At least.

(I haven't investigated any further yet...but, I'll have a look via serial port later today or tonight and post the details if I see anything interesting.)

- Ray

Edited 4 time(s). Last edit at 12/14/2010 02:00PM by sandbasser.
Re: webmin upgrade - goes badly
December 11, 2010 02:25PM
No problems here upgrading webmin to 1.530.

Re: webmin upgrade - goes badly
December 11, 2010 08:47PM
Heinz -

A question for you...does your webmin start automatically after reboot or do you have to manually start it???

Mine (obviously, on a separate stick) doesn't start after reboot - I have to manually start it. It's pretty annoying.


- Ray
Re: webmin upgrade - goes badly
December 12, 2010 04:27PM
I initially downloaded webmin_1.520_all.deb from the webmin website; /etc/init.d/webmin was created and started automatically as part of the standard installation as far as I recall.

You could try
cd /etc/init.d
update-rc.d webmin defaults
(or "Webmin / System / Bootup and Shutdown" of course) to have it started on boot up.

If this does not work, your runlevel links may be trashed; try
cd /etc/init.d
rm ../rc?.d/???webmin
update-rc.d webmin defaults
to clean it up.

Re: webmin upgrade - gone bad
December 14, 2010 01:58PM
Heinz -

I tried the 'update-rc.d webmin defaults' command that you recommended... I did get some warning messages; but it resolved the problem with webmin not starting after reboot.

Many thanks!!!

- Ray
Re: webmin upgrade - gone bad
July 30, 2011 09:32PM
I had similar problems:

boot@server:/tmp# update-rc.d webmin defaults
update-rc.d: using dependency based boot sequencing
update-rc.d: warning: webmin start runlevel arguments
(2 3 4 5) do not match LSB Default
-Start values (2 3 5)
insserv: warning: current stop runlevel(s) (empty) of
script `webmin' overwrites default
s (0 1 6).

This resulted after your suggestion to run this:

apt-get install perl libnet-ssleay-perl openssl
libauthen-pam-perl libpam-runtime libio-pty-perl apt-
show-versions python

I'm trying this next, but.....

cd /etc/init.d
rm ../rc?.d/???webmin
update-rc.d webmin defaults
Re: RESOLVED - webmin upgrade - gone bad & a question
July 31, 2011 02:58PM
Squeeze uses a dependency based boot system. update-rc is sort of deprecated. inssrv is the new version. but the start up script in /etc/init.d needs to be formatted properly. just copy the starting bit from /etc/init.d/ssh into top of /etc/init.d/webmin.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.