Welcome! Log In Create A New Profile

Advanced

USB not working after kernel upgrade (NSA320)

Posted by davidgf 
Re: USB not working after kernel upgrade (NSA320)
March 18, 2021 06:39PM
bandicoot,

> > But if you insist on staying with stock u-boot,
> > then a similar command as "mw.l f1010100
> 0020c000"
> > needed to be figured out (not hard at all).

Meaning I can help you to do this.

> I have been googling to find this for the NSA320,
> but there is about zero else then this command,
> which I read almost anywhere is for the NSA325. It
> may not be hard to figure it out, but to me it is,
> I have no clue to how to approach this.

> Is there a way to do something like 'md.l
> f1010100' from a booted Debian?

Not in Debian. This command is u-boot command. Let me find the post (if I had saved it), else we'll do it from scratch.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: USB not working after kernel upgrade (NSA320)
March 18, 2021 06:51PM
Here is an example for the Armada boxes.

https://forum.doozan.com/read.php?2,76314,112684#msg-112684

For Kirkwood boxes like this NSA320 the GPIO addresses are different. And the USB power GPIO must be used. So I'll write a new set of commands.

============

But first, I like to see if you can activate the USB drive at u-boot console.

WIth a USB rootfs attached. Power up, interrupt serial console and,
usb reset
ext2ls usb 0:1 /
ext2ls usb 0:1 /boot

And see if how it behaves, whether you can read the USB content with the commands above.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: USB not working after kernel upgrade (NSA320)
March 18, 2021 09:03PM
bodhi Wrote:
-------------------------------------------------------
> Here is an example for the Armada boxes.
>
> https://forum.doozan.com/read.php?2,76314,112684#msg-112684
>
> For Kirkwood boxes like this NSA320 the GPIO
> addresses are different. And the USB power GPIO
> must be used. So I'll write a new set of
> commands.
>
> ============
>
> But first, I like to see if you can activate the
> USB drive at u-boot console.
>
> WIth a USB rootfs attached. Power up, interrupt
> serial console and,
>
> usb reset
> ext2ls usb 0:1 /
> ext2ls usb 0:1 /boot
>
>
I am getting this:
USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0, egiga1 [PRIME]
Hit any key to stop autoboot:  0

NSA320>> usb reset
(Re)start USB...
USB:   scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 0 Storage Device(s) found

NSA320>> ext2ls usb 0:1 /
** Bad partition - usb 0:1 **

> And see if how it behaves, whether you can read
> the USB content with the commands above.



Edited 1 time(s). Last edit at 03/18/2021 09:04PM by bandicoot.
Re: USB not working after kernel upgrade (NSA320)
March 18, 2021 09:31PM
bandicoot,


> NSA320>> usb reset
> (Re)start USB...
> USB: scanning bus for devices... 2 USB Device(s)
> found
> scanning bus for storage devices... 0
> Storage Device(s) found

Looks like stock u-boot did not detect the USB drive.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 03/18/2021 09:32PM by bodhi.
Re: USB not working after kernel upgrade (NSA320)
March 18, 2021 09:41PM
See this new post:

https://forum.doozan.com/read.php?2,118064

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: