Welcome! Log In Create A New Profile

Advanced

[SOLVED} Pogoplug V4 upgrade problem

Posted by sudos 
[SOLVED} Pogoplug V4 upgrade problem
January 19, 2018 01:11AM
Hi there! it's Pogoplug update time again with the V4!

I did a full dist-upgrade from Wheezy-lts to Stretch and ended up having to upgrade Uboot and my kernel in the mix, and it's been a long, long while. before this, the box was up for two years, if you can believe it.

anyways, when it tries to boot the latest kernel after following the instructions for making a uImage with the embedded dtb, it sits there after loading both uImage and uInitrd and says "OK, booting the kernel." and just hangs. This is booting off a hard drive.
I popped a flash drive in containing the rootfs/kernel for a 3.18.5 Jessie install and since the hard drive is always sda1, it loaded the kernel from the flash drive and continued booting from the hard drive. I currently have some sort of frankenstein system of Stretch booting on a 3.18.5 Jessie kernel built by you, but no matter what I do, after embedding the pogoplug dtb in the zImage.fdt file, it seems the kernel doesn't like that and hangs.


EDIT: I fixed it. something wasn't right with stuff and I ended up getting it working by magic, after hours of serial console shennanigans with a RasPi with minicom. we're all good here. False alarm. I now have a stretch box running the 4.14.1 kernel and it is amazing.



Edited 2 time(s). Last edit at 01/19/2018 02:54AM by bodhi.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: