Welcome! Log In Create A New Profile


rt73usb problem ?

Posted by davygravy 
rt73usb problem ?
October 13, 2011 06:28PM
I'm more or less (less on a bad day) using an ASUS WL-167G v2 USB adapter on my PogoWeather Station (running Squeeze) ...

Bus 001 Device 006: ID 0b05:1723 ASUSTek Computer, Inc. WL-167G v2 802.11g Adapter [Ralink RT73]

I'm experiencing daily dropouts of connectivity.

I've not gone for more that 36 hours w/o needing to reboot the Pogo. Right now I have a script set up to ping several servers every few minutes and either restart networking services (this seems to fix it sometimes), and when that doesn't do it, I have it reboot (this almost always works,s but not always).

When connectivity fails, I sometimes see this in the logs:

rt2x00usb: Vendor Request 0x07 failed

repeated over & over...

Has anyone else seen this?

If so, how did you fix it?

I've seen a hint to try a newer kernel (I'm running 2.6.32.x - the original kernel in the Squeeze setup).

Has anyone tried

iwconfig wlan0 power off

as a fix?

Maybe using nohwcrypt option for rt73usb?

Edited 1 time(s). Last edit at 10/13/2011 06:46PM by davygravy.
Re: rt73usb problem ?
October 15, 2011 12:58PM
OK, after doing quite a bit of sifting and googling, I think I found it...

The power management feature for the rt73usb seems like it indeed does have something to do w/ dropouts in connectivity, at least w/ the ready-made/supplied/default kernel that is used w/ the debootstrap script used at this site (2.6.32-5-kirkwood). When I turn it off, I have no problems whatsoever w/ dropouts - two days up and not a single hiccup.

from the command line:
iwconfig wlan0 power off

from within /etc/network/interfaces ... [see last line in the code below]
root@pogodebian:~# cat /etc/network/interfaces
auto lo eth0
iface lo inet loopback
iface eth0 inet dhcp
auto wlan0
iface wlan0 inet static
	address xxx.xxx.xxx.xxx
	gateway xxx.xxx.xxx.xxx
	wpa-ssid xxxxxxx
	wpa-psk xxxxxxxxxxxx
        wireless-power off

This seems to fix it perfectly. If it doesn't, I'll post back.

Update: No more dropped connections, no more loss of connectivity, ZERO problems since turning power management off. Problem solved.

Edited 1 time(s). Last edit at 11/06/2011 07:38AM by davygravy.
Re: rt73usb problem ?
May 01, 2014 04:18AM
I know this thread is a bit old, but it is exactly what i was looking for...
I have an old Dlink Usb dongle that i use for my the Raspberry Pi - it uses the same chipset though -
And sometimes the SSh dies... I read somewhere that it was power management... and i couldnt figure out how to turn it off... I hope it works...
If it does.. THANK YOU!!!
else... oh well ill just have to keep looking!

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.