Welcome! Log In Create A New Profile

Advanced

network reset and sata error on oxnas

Posted by jmandawg 
network reset and sata error on oxnas
June 26, 2018 08:52PM
So i have a oxnas pogo pro, when i transfer a large number of large files to the pogo my open vpn times out and my network connection dies. I also see this in the serial console (my rootfs drive is connected to the sata port):

[  362.200133] sata_oxnas: resetting SATA core
[  362.560099] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[  362.567132] ata1.00: failed command: WRITE DMA EXT
[  362.571973] ata1.00: cmd 35/00:28:80:0c:44/00:00:5a:00:00/e0 tag 13 dma 20480 out
                        res 51/00:28:80:0c:44/00:00:5a:00:00/e0 Emask 0x1 (device error)
[  362.587489] ata1.00: status: { DRDY ERR }
[  362.591557] ata1: hard resetting link
[  363.100213] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[  363.151790] ata1.00: configured for UDMA/100
[  363.156131] ata1: EH complete

Once i start transferring my files i see this in the VPN log:

Tue Jun 26 19:26:09 2018 Initialization Sequence Completed
Tue Jun 26 19:37:23 2018 [Windscribe Node Server 4096] Inactivity timeout (--pin
g-restart), restarting
Tue Jun 26 19:37:23 2018 Closing TUN/TAP interface

I'm guess transferring that large files is making it so the openvpn cannot use the network at all.

Any ideas? I'm on 4.4.124-oxnas-tld-1 with a wired connection.

Thanks.
Re: network reset and sata error on oxnas
June 26, 2018 09:18PM
jmandawg,

> [ 362.200133] sata_oxnas: resetting SATA core
> [ 362.560099] ata1.00: exception Emask 0x0 SAct
> 0x0 SErr 0x0 action 0x6 frozen
> [ 362.567132] ata1.00: failed command: WRITE DMA
> EXT

I have not seen this on the Popgo OXNAS V3. But have seen similar error on a Kirkwood box. I can't say it is the same.

But usually when you see this, check your SATA cable and also power supply first, it might not be the disk itself. Ie, is the cable OK? is there enough voltage? it was no fun tracking down this problem :) but the SMART report on my disk back then said it is OK.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: network reset and sata error on oxnas
June 27, 2018 08:50PM
Thanks Bodhi,

Your right, after giving the drive more power via plugging both ends of the "Y" usb cable in, it hasn't happened again. I also tuned the network and samba config as recommended in this article and seems like it's running smoothly now (no more network crash).

https://linuxengineering.wordpress.com/2014/08/03/performance-tuning-with-pogoplug-v4/

Thanks!



Edited 1 time(s). Last edit at 06/27/2018 08:51PM by jmandawg.
Re: network reset and sata error on oxnas
June 27, 2018 11:22PM
jmandawg Wrote:
-------------------------------------------------------
> Thanks Bodhi,
>
> Your right, after giving the drive more power via
> plugging both ends of the "Y" usb cable in, it
> hasn't happened again. I also tuned the network
> and samba config as recommended in this article
> and seems like it's running smoothly now (no more
> network crash).
>
> https://linuxengineering.wordpress.com/2014/08/03/performance-tuning-with-pogoplug-v4/
>
> Thanks!

Cool!

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: