Welcome! Log In Create A New Profile


No access to goflex net

Posted by joho 
No access to goflex net
February 02, 2012 11:04PM

I did the Debian installation like it is described in the tutorial. Everything worked fine. But during the installation I got a lot of errors like "corrupt file system" after a reboot I have no access because I can not find any IP address for the device on the DHCP server. When I switch on the device I get some green blinking LED after some secounds it is a yellow blinking LED (with or without the stick) I also reseted the device but it makes no diffence.

I have a goflex net and did the installation on a usb stick.

I am very new in this forum, what can I do to get again access to my goflex net. Do I have to use his serial connection? What does this mean?


Re: No access to goflex net
March 14, 2012 12:10PM

I have the same problem like you.
I tried to install debian on a USB Stick using Jeffs script, not with the updated Version from shyd because i found this later after the problem appears.
At the Installation process there are some downloading failures and i canceled the script.
What i was thinking is that my network connection was lost and i restartet my goflex net.
A other point was that i was thinking that the goflex will boot the pogoplug (original os) from the nand.

But now my box will only blinking amber. What can i do??

Please guys help us!
Re: No access to goflex net
March 14, 2012 05:03PM
Did you capture the log of what was showing on the screen? It would be very helpful to know at which point the error occurred, and when you cancelled the script.
Re: No access to goflex net
March 15, 2012 06:56AM
here is my installation log.
open | download - install-log.txt (29.7 KB)
Re: No access to goflex net
March 15, 2012 09:23AM
To me it looks like the bootloader installed fine but the script failed when setting up rootfs. Which means that the device is not bricked. You just need to put a working rootfs with uImage and uInitrd on your thumb drive and GoFlex Net should boot.
Re: No access to goflex net
March 17, 2012 09:23AM
Ok that sounds great that it is not bricked.
But iam very new on all these stuff. Can you post a link or the steps that i have to do to put a rootfs with uImage and uinitrd on a usb with linux.
An where i get the file to do this.

Re: No access to goflex net
March 17, 2012 11:11AM

ich have tried to get more informations using a usb-to-serial connection.
But i can only see strange character.
I tried this on a mac and windows but i get the same result.
open | download - usb-out.txt (2.2 KB)
Re: No access to goflex net
March 19, 2012 02:37AM
Hi Guys,

i have solved my proplem doing the following steps.
  1. downloading the archlinux ArchLinuxARM-armv5te-latest.tar.gz from http://archlinuxarm.org/platforms/armv5/seagate-goflex-net on a linux pc
  2. format a usb-stick with one ext2 partition and mountet the partition to /mnt
      $: mount /dev/sdd1 /mnt  
  3. extract the tar ball to /mnt
      $: tar xzf ArchLinuxARM-armv5te-latest.tar.gz /mnt  
  4. unmount the drive
      umount /mnt  
  5. plug the arch usb-stick into the USB-port on the goflex net and poweron the system

    The system in now booting and i will be able to connect using ssh
    After that i putted a usb-hub between the goflex an the usb-stick that i can connect a second usb-drive on which i will be able to install debian.
  6. ssh root@ #password: root
  7. download the installation script
      $: cd /tmp && wget http://dev.shyd.de/dockstar/dockstar.debian-squeeze.sh && chmod +x dockstar.debian-squeeze.sh  
  8. connect the target usb drive to the usb hub and looking for his devicename
      $: dmesg  
  9. replace the SWAP_DEV and ROOT_DEV in the script with my target devicename /dev/sdb1 -> ROOT_DEV and /dev/sdb2 -> SWAP_DEV
  10. run the installation script and follow the instruction
      $: ./dockstar.debian-squeeze.sh  
  11. after installation shutdown the system an disconnected the Archlinux-usb-stick and usb-hub and plug the debian usbstick directly to the goflex
  12. my system is now booting debian in a charm way

Thank to all helping me to understand whats happening to my box.

Edited 1 time(s). Last edit at 03/19/2012 02:39AM by newgordan.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.