Welcome! Log In Create A New Profile

Advanced

NAS326 installation problem

Posted by edda_ 
edda_
NAS326 installation problem
December 21, 2018 09:08AM
I tried 3 Pendrives to find the one working. GPT didn't work, only MBR partitions



Edited 1 time(s). Last edit at 12/21/2018 03:29PM by bodhi.
Michael Käppler
NAS326 installation problem (without serial console)
December 21, 2018 08:02AM
Hi all,
I tried the described steps for my NAS326 box, firmware
V5.21(AAZF.2) without serial console, but ended up booting the old kernel.
How can I debug this? Do these steps work with recent firmware or do I have to downgrade?

Thanks,
Michael



Edited 1 time(s). Last edit at 12/21/2018 03:27PM by bodhi.
Re: NAS326 installation problem
December 21, 2018 03:33PM
All,

I've moved your posts to this thread. Sorry the merge function does not work well so it is out of order.

Please, remember to create a new thread for installation problem like these. The release thread is not a good place to post specific problems.


@Michael,

Quote

I tried the described steps for my NAS326 box, firmware
V5.21(AAZF.2) without serial console, but ended up booting the old kernel.
How can I debug this? Do these steps work with recent firmware or do I have to downgrade?

In stock OS, get these information

dmesg
cat /proc/mtd
fw_printenv

-bodhi
===========================
Forum Wiki
bodhi's corner
Michael Käppler
Re: NAS326 installation problem
December 22, 2018 12:50PM
Hi bodhi,
thanks for your answer.
Console output for the mentioned commands is here:

- Michael
Re: NAS326 installation problem
December 22, 2018 12:58PM
Sorry, link did not work, now logs attached...
Attachments:
open | download - dmesg_output.txt (29.3 KB)
Re: NAS326 installation problem
December 22, 2018 05:06PM
Michael,

Everything looks normal for stock. Without serial console, it is hard to figure out any mistake you did during installation.

So go ahead and repeat the installation. And post everything you've done during installation. Including how you created the rootfs on USB (if that is what you want), and how you execute the procedure to install u-boot.

And then attempt reboot with new u-boot and USB rootfs. Observe the LED behavior and post it here, too.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: NAS326 installation problem
December 23, 2018 03:39PM
Hi bodhi,
thanks for all your effort you put in here!
I repeated all steps today, in addition to the last try I did a raw format with my flash drive before
partitioning it. Same situation as before.
Attached are the console log of the usb flashdrive preparation steps (usbprep.log) and
the ssh console logs while changing uboot settings.
Video of the front leds during booting is here: https://drive.google.com/file/d/1BYH1MdfBT8FD3EERrNbXJmvnVsFfUD_8/view?usp=sharing

Two another observations: Even with the flashdrive removed from the usb port, the nas326
looses its configuration on every startup (login settings admin/1234) This occurs since I changed
the uboot settings. Additionately, the web interface url shows a different revision (?):
(r50984 instead of the former r51161)

Happy christmas,
Michael
Attachments:
open | download - usbprep.log (3.2 KB)
open | download - putty-192.168.178.32-20182312_171802.log (3.5 KB)
Re: NAS326 installation problem
December 23, 2018 09:04PM
Michael,

Quote

Two another observations: Even with the flashdrive removed from the usb port, the nas326
looses its configuration on every startup (login settings admin/1234) This occurs since I changed
the uboot settings. Additionately, the web interface url shows a different revision (?):
(r50984 instead of the former r51161)

This is because there 2 kernels on NAND. One is the backup kernel, in case the current kernel could not boot. The kernel is switched during boot if we have this env set
fw_setenv change_boot_part 1

The logs look OK. So one possibilty why it kep falling back to stock kernel is because the current kernel is kernel 2. So try the same procedure, but replace the kernel address as:

fw_setenv kernel_addr_1 0x00E00000
fw_setenv kernel_addr_2 '0x00000000; run bootcmd_custom; '

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: NAS326 installation problem
January 01, 2019 02:25PM
Hi bodhi,
thanks for your help! Using a different flash drive now worked for me.

With best wishes,
Michael
Re: NAS326 installation problem
January 01, 2019 09:50PM
Michael,

Cool! glad you've figured out the problem.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: