Welcome! Log In Create A New Profile

Advanced

Kernel 5.1.0 on ix-dl no sensors, Need recompile ?

Posted by olderzeus 
Kernel 5.1.0 on ix-dl no sensors, Need recompile ?
June 02, 2019 08:20PM
I Used Kernel 5.1.0 on my ix-dl, Here no sensors:

Kernel 4.20.6:
<root@IX2-DL>~/:uname -a
Linux IX2-DL 4.20.6-kirkwood-tld-1 #1 PREEMPT Thu Jan 31 21:41:45 PST 2019 armv5tel GNU/Linux
<root@IX2-DL>~/:sensors
adt7473-i2c-0-2e
Adapter: mv64xxx_i2c adapter
in1:          +1.10 V  (min =  +0.00 V, max =  +2.99 V)
+3.3V:        +3.35 V  (min =  +2.96 V, max =  +3.61 V)
fan1:         834 RPM  (min =    0 RPM)
fan2:           0 RPM  (min =    0 RPM)
fan3:           0 RPM  (min =    0 RPM)
fan4:           0 RPM  (min =    0 RPM)
temp1:        +53.2°C  (low  = -63.0°C, high = +191.0°C)
                       (crit = +100.0°C, hyst = +96.0°C)
Board Temp:   +50.2°C  (low  = -63.0°C, high = +191.0°C)
                       (crit = +100.0°C, hyst = +96.0°C)
temp3:        +47.5°C  (low  = -63.0°C, high = +191.0°C)
                       (crit = +100.0°C, hyst = +96.0°C)
Kernel 5.1.0:
<root@IX2-DL>~/:uname -a
Linux IX2-DL 5.1.0-kirkwood-tld-1 #1 PREEMPT Tue May 7 00:16:02 PDT 2019 armv5tel GNU/Linux
<root@IX2-DL>~/:sensors
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.

Error log in kernel 5.1.0 start:
[   16.887766] orion_wdt: Initial timeout 21 sec
[   16.929788] adt7475 0-002e: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[   17.039903] sd 0:0:0:0: Attached scsi generic sg0 type 0
[   17.057012] adt7475 0-002e: ADT7473 device, revision 0
[   17.100609] marvell-cesa f1030000.crypto: CESA device successfully registered
[   17.121755] sd 1:0:0:0: Attached scsi generic sg1 type 0

Re: Kernel 5.1.0 on ix-dl no sensors, Need recompile ?
June 02, 2019 09:06PM
olderzeus,

Which DTB are you using to boot this box?

And have you tried to modprobe it manually?

modprobe adt7475

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 06/02/2019 09:14PM by bodhi.
Re: Kernel 5.1.0 on ix-dl no sensors, Need recompile ?
June 03, 2019 01:52AM
https://forum.doozan.com/read.php?3,19216

I used the DTB from this thread.
Re: Kernel 5.1.0 on ix-dl no sensors, Need recompile ?
June 03, 2019 02:06AM
Sorry for my own carelessness.

I had test & more times to run dpkg -i linux-image-5.1.0-kirkwood-tld-1_1.0_armel.deb
but not check the module files.

I checked & not found /lib/modules/5.1.0-kirkwood-tld-1, So I'm retried dpkg -i linux-image-5.1.0-kirkwood-tld-1_1.0_armel.deb and checked module files.

It's correct now.

<root@IX2-DL>~/:uname -a
Linux IX2-DL 5.1.0-kirkwood-tld-1 #1 PREEMPT Tue May 7 00:16:02 PDT 2019 armv5tel GNU/Linux
<root@IX2-DL>~/:sensors
adt7473-i2c-0-2e
Adapter: mv64xxx_i2c adapter
in1:          +1.10 V  (min =  +0.00 V, max =  +2.99 V)
+3.3V:        +3.35 V  (min =  +2.96 V, max =  +3.61 V)
fan1:         812 RPM  (min =    0 RPM)
fan2:           0 RPM  (min =    0 RPM)
fan3:           0 RPM  (min =    0 RPM)
fan4:           0 RPM  (min =    0 RPM)
temp1:        +54.5°C  (low  = -63.0°C, high = +191.0°C)
                       (crit = +100.0°C, hyst = +96.0°C)
Board Temp:   +52.2°C  (low  = -63.0°C, high = +191.0°C)
                       (crit = +100.0°C, hyst = +96.0°C)
temp3:        +49.2°C  (low  = -63.0°C, high = +191.0°C)
                       (crit = +100.0°C, hyst = +96.0°C)
Re: Kernel 5.1.0 on ix-dl no sensors, Need recompile ?
June 03, 2019 02:33AM
olderzeus,

Glad that you've figured out the problem!

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: