Welcome! Log In Create A New Profile

Advanced

[SOLVED] NSA325v2 no network (eth0 missing)

Posted by rufik 
[SOLVED] NSA325v2 no network (eth0 missing)
August 18, 2019 02:43AM
I've sucessfully managed to boot kernel 5.1.11 with Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi, thanks Bodhi!
Uboot is U-Boot 2017.07-tld-1, I'm using USB drive with ext4 filesystem. Uboot is simple for me:
setenv bootargs_linux 'console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) earlyprintk=serial'
setenv bootcmd_linux 'setenv bootargs $bootargs_linux; mw.l f1010100 0020c000; usb reset; ext4load usb 0:1 0x800000 /boot/uImage; ext4load usb 0:1 0x02100000 /boot/uInitrd; ext4load usb 0:1 0x1c00000 /boot/dts/kirkwood-dns325.dtb; bootm 0x800000 0x02100000 0x1c00000'


But there is some problem (maybe with DTB?) with ethernet, I can see kernel message:
[    8.450525] mdio_bus f1072004.mdio-bus-mii: MDIO device at address 8 is missing.
[    8.458797] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
[    8.466686] mv643xx_eth_port mv643xx_eth_port.0: DMA mask not set
And eth0 is completely missing...



Edited 1 time(s). Last edit at 08/18/2019 03:59PM by rufik.
Re: NSA325v2 no network (eth0 missing)
August 18, 2019 03:23AM
rufik,

> setenv bootargs_linux 'console=ttyS0,115200
> root=LABEL=rootfs rootdelay=10 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2)

Should be

setenv bootargs_linux 'console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 mtdparts=orion_nand:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2)

> $bootargs_linux; mw.l f1010100 0020c000; usb
> reset; ext4load usb 0:1 0x800000 /boot/uImage;
> ext4load usb 0:1 0x02100000 /boot/uInitrd;
> ext4load usb 0:1 0x1c00000
> /boot/dts/kirkwood-dns325.dtb; bootm 0x800000
> 0x02100000 0x1c00000'

No need to set it like that, U-Boot 2017.07-tld-1 envs are already set up to boot the NSA325 correctly.

> And eth0 is completely missing...

Please post the entire serial console log.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: NSA325v2 no network (eth0 missing)
August 18, 2019 06:58AM
Bodhi, I've changed mtdparts to orion_nand but no go :/


Full serial console boot log: https://pastebin.com/raw/G7vyRRzc
Uboot env: https://pastebin.com/raw/xjbLjpjx
Re: NSA325v2 no network (eth0 missing)
August 18, 2019 03:16PM
rufik,

dtb_file=/boot/dts/kirkwood-dns325.dtb

That was the wrong DTB. It should be:
dtb_file=/boot/dts/kirkwood-nsa325.dtb

I did not regconize it in your log above either :) they look almost identical !

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 08/18/2019 03:18PM by bodhi.
Re: NSA325v2 no network (eth0 missing)
August 18, 2019 03:59PM
Thanks a lot, it did the trick! :)
I don't really know why I put dns325 instead of nsa325, really...
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: