Welcome! Log In Create A New Profile

Advanced

OS upgrade failure on Pogo Mobile

Posted by unmesh 
OS upgrade failure on Pogo Mobile
November 30, 2019 04:59PM
Currently running 4.2.0 on latest uboot. When trying to upgrade to 5.3.2, I get the following error message

# dpkg -i linux-image-5.3.2-kirkwood-tld-1_1.0_armel.deb
dpkg-deb: error: archive 'linux-image-5.3.2-kirkwood-tld-1_1.0_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing linux-image-5.3.2-kirkwood-tld-1_1.0_armel.deb (--install):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 linux-image-5.3.2-kirkwood-tld-1_1.0_armel.deb

Any help in getting past this will be greatly appreciated
Re: OS upgrade failure on Pogo Mobile
November 30, 2019 06:05PM
unmesh,

> Currently running 4.2.0 on latest uboot. When
> trying to upgrade to 5.3.2,

There is a problem with old version of dpkg when running to unpack new deb package.

Is your rootfs Debian wheezy?
cat /etc/debian_version

Wheezy is end of life, so I would not expect this to be fixed in that repo. So you need to upgrade first to get the new dpkg.

And backup your rootfs first if you already have a lot of things installed. Upgrading to buster (or stretch) would result in a massive change so back up is a must, in case you are not successful.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 12:41AM
root@DebianPlugMobile:~# cat /etc/debian_version
7.9
By upgrade, you mean using
apt-get update
apt-get upgrade

Thanks
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 01:35AM
unmesh,

This is Debian wheezy.

> root@DebianPlugMobile:~# cat /etc/debian_version
> 7.9


To upgrade to later version of Debian, you would change /etc/apt/sources.list to jessie, stretch, or buster. And then,

apt-get update
apt-get dist-upgrade

Running only apt-get upgrade, without changing /etc/apt/sources.list, would keep you in wheezy, but upgrade all wheezy packages to the latest version. This is not enough to fix the problem you are seeing.

When you change to the latest Debian version like this:

cat /etc/apt/sources.list
deb http://ftp.us.debian.org/debian buster main contrib non-free
deb-src http://ftp.us.debian.org/debian buster main contrib non-free

deb http://security.debian.org/ buster/updates main contrib non-free
deb-src  http://security.debian.org/ buster/updates main contrib non-free

deb http://http.debian.net/debian buster-updates main contrib non-free
deb-src http://http.debian.net/debian buster-updates main contrib non-free

and then
apt-get update
apt-get dist-upgrade
It will upgrade your system to the latest Debian ditribution. And thererfore you wil have the latest dpkg. This is a really big change, upgrading from wheezy (7) to buster (10).

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 02:14AM
Related to this issue, I recently used the Jessie Debian rootfs for the Dell M300 on a new install. After the first boot, when I went to do a apt-get update, the system said my certificates were expired. 'apt-get clean' did not clear the error. Had to 'apt-get install ca-certificates' to be able to update, upgrade and install newer packages.
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 10:54AM
'apt update' gave the following messages
W: GPG error: http://ftp.us.debian.org buster Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY DCC9EFBF77E11517
W: GPG error: http://security.debian.org buster/updates Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AA8E81B4331F7F50 NO_PUBKEY 112695A0E562B32A
W: GPG error: http://http.debian.net buster-updates Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138
W: Failed to fetch http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/trusty/Release  Unable to find expected entry 'main/binary-armel/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

'apt-get dist-upgrade' warned about not being able to verify the packages and ended with
E: /var/cache/apt/archives/libsqlite3-0_3.27.2-3_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/libsqlite3-0_3.27.2-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libkeyutils1_1.6-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libssl1.1_1.1.1d-0+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libkrb5-3_1.17-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgssapi-krb5-2_1.17-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libk5crypto3_1.17-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libkrb5support0_1.17-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtirpc-common_1.1.4-0.4_all.deb
E: Prior errors apply to /var/cache/apt/archives/libc6_2.28-10_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libudev1_241-7~deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libblkid1_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/tar_1.30+dfsg-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblzma5_5.2.4-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpcre3_2%3a8.39-12_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libselinux1_2.8-1+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/lsb-base_10.2019051400_all.deb
E: Prior errors apply to /var/cache/apt/archives/dpkg_1.19.7_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libfdisk1_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libmount1_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtinfo6_6.1+20181013-2+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libncursesw6_6.1+20181013-2+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libsmartcols1_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libaudit-common_1%3a2.8.4-3_all.deb
E: Prior errors apply to /var/cache/apt/archives/libcap-ng0_0.7.9-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libaudit1_1%3a2.8.4-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdb5.3_5.3.28+dfsg1-0.5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpam0g_1.3.1-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpam-modules-bin_1.3.1-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpam-modules_1.3.1-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgcrypt20_1.8.4-5_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 10%E: /var/cache/apt/archives/libgpg-error0_1.35-1_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/libgpg-error0_1.35-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblz4-1_1.8.3-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libsystemd0_241-7~deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/mount_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/sysvinit-utils_2.93-8_armel.deb
E: Prior errors apply to /var/cache/apt/archives/util-linux_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/login_1%3a4.5-1.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/fdisk_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/perl_5.28.1-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/perl-base_5.28.1-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/debconf_1.5.71_all.deb
E: Prior errors apply to /var/cache/apt/archives/perl-modules-5.28_5.28.1-6_all.deb
E: Prior errors apply to /var/cache/apt/archives/libgdbm6_1.18.1-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgdbm-compat4_1.18.1-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libperl5.28_5.28.1-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/init-system-helpers_1.56+nmu1_all.deb
E: Prior errors apply to /var/cache/apt/archives/update-inetd_4.49_all.deb
E: Prior errors apply to /var/cache/apt/archives/libtext-charwidth-perl_0.04-7.1+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblocale-gettext-perl_1.07-3+b4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libuuid-perl_0.28-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtext-iconv-perl_1.7-5+b7_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libelf1_0.176-1.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libmnl0_1.0.4-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libxtables12_1.8.2-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libcap2-bin_1%3a2.25-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gcc-8-base_8.3.0-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libatomic1_8.3.0-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libisc-export1100_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdns-export1104_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/ntpdate_1%3a4.2.8p12+dfsg-4_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 21%E: /var/cache/apt/archives/libopts25_1%3a5.18.12-4_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/libopts25_1%3a5.18.12-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/ntp_1%3a4.2.8p12+dfsg-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/isc-dhcp-client_4.4.1-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/iproute2_4.20.0-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/netbase_5.6_all.deb
E: Prior errors apply to /var/cache/apt/archives/ifupdown_0.8.35_armel.deb
E: Prior errors apply to /var/cache/apt/archives/base-files_10.3+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/startpar_0.61-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/insserv_1.18.0-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/sysv-rc_2.93-8_all.deb
E: Prior errors apply to /var/cache/apt/archives/initscripts_2.93-8_armel.deb
E: Prior errors apply to /var/cache/apt/archives/linux-base_4.6_all.deb
E: Prior errors apply to /var/cache/apt/archives/udev_241-7~deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/dmsetup_2%3a1.02.155-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdevmapper1.02.1_2%3a1.02.155-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libevent-2.1-6_2.1.8-stable-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/keyutils_1.6-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/nfs-kernel-server_1%3a1.3.4-2.5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/nfs-common_1%3a1.3.4-2.5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtirpc3_1.1.4-0.4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libc-bin_2.28-10_armel.deb
E: Prior errors apply to /var/cache/apt/archives/rpcbind_1.2.5-0.3+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libcomerr2_1.44.5-1+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libcom-err2_1.44.5-1+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libuuid1_2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libattr1_1%3a2.4.48-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libacl1_2.2.53-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libkmod2_26-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libsepol1_2.8-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libsemanage-common_2.8-2_all.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 32%E: /var/cache/apt/archives/libsemanage1_2.8-2_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/libsemanage1_2.8-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/bzip2_1.0.6-9.2~deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libbz2-1.0_1.0.6-9.2~deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/passwd_1%3a4.5-1.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/adduser_3.118_all.deb
E: Prior errors apply to /var/cache/apt/archives/libcap2_1%3a2.25-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgmp10_2%3a6.1.2+dfsg-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libnettle6_3.4.1-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libhogweed4_3.4.1-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libunistring2_0.9.10-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libidn2-0_2.0.5-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgcc1_1%3a8.3.0-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libffi6_3.2.1-9_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libp11-kit0_0.23.15-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtasn1-6_4.13-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgnutls30_3.6.7-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libsasl2-modules-db_2.1.27+dfsg-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libsasl2-2_2.1.27+dfsg-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libldap-common_2.4.47+dfsg-3+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libldap-2.4-2_2.4.47+dfsg-3+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libnfsidmap2_0.25-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libwrap0_7.6.q-28_armel.deb
E: Prior errors apply to /var/cache/apt/archives/coreutils_8.30-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/sensible-utils_0.0.12_all.deb
E: Prior errors apply to /var/cache/apt/archives/ucf_3.0038+nmu1_all.deb
E: Prior errors apply to /var/cache/apt/archives/zlib1g_1%3a1.2.11.dfsg-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/debianutils_4.8.6.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/tzdata_2019c-0+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libbsd0_0.9.1-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libedit2_3.1-20181209-1_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 43%E: /var/cache/apt/archives/libstdc++6_8.3.0-6_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/libstdc++6_8.3.0-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libzstd1_1.3.8+dfsg-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libseccomp2_2.3.3-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libapt-inst2.0_1.8.2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/apt-utils_1.8.2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/debian-archive-keyring_2019.1_all.deb
E: Prior errors apply to /var/cache/apt/archives/apt_1.8.2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libapt-pkg5.0_1.8.2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpgv_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/bash_5.0-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/bsdmainutils_11.1.2+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/bsdutils_1%3a2.33.1-0.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/dash_0.5.10.2-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/diffutils_1%3a3.7-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/e2fslibs_1.44.5-1+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libext2fs2_1.44.5-1+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/e2fsprogs_1.44.5-1+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/findutils_4.6.0+git+20190209-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/grep_3.3-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gzip_1.9-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/hostname_3.21_armel.deb
E: Prior errors apply to /var/cache/apt/archives/ncurses-bin_6.1+20181013-2+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/sed_4.7-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdebconfclient0_0.249_armel.deb
E: Prior errors apply to /var/cache/apt/archives/base-passwd_3.5.46_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libslang2_2.3.2-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/dialog_1.3-20190211-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libncursesw5_6.1+20181013-2+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtinfo5_6.1+20181013-2+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libncurses5_6.1+20181013-2+deb10u2_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 54%E: /var/cache/apt/archives/ncurses-base_6.1+20181013-2+deb10u2_all.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/ncurses-base_6.1+20181013-2+deb10u2_all.deb
E: Prior errors apply to /var/cache/apt/archives/mawk_1.3.3-17+b3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libuchardet0_0.0.6-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/groff-base_1.22.4-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpipeline1_1.5.1-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/man-db_2.8.5-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpython2.7-minimal_2.7.16-2+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python2.7-minimal_2.7.16-2+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python2-minimal_2.7.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python-minimal_2.7.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/mime-support_3.62_all.deb
E: Prior errors apply to /var/cache/apt/archives/libexpat1_2.2.6-2+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/readline-common_7.0-5_all.deb
E: Prior errors apply to /var/cache/apt/archives/libreadline7_7.0-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpython2.7-stdlib_2.7.16-2+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python2.7_2.7.16-2+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpython2-stdlib_2.7.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpython-stdlib_2.7.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python2_2.7.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python_2.7.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpam-runtime_1.3.1-5_all.deb
E: Prior errors apply to /var/cache/apt/archives/libncurses6_6.1+20181013-2+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libprocps7_2%3a3.3.15-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/procps_2%3a3.3.15-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python-dnspython_1.16.0-1_all.deb
E: Prior errors apply to /var/cache/apt/archives/python-crypto_2.6.1-9+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtalloc2_2.1.14-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtdb1_1.3.16-2+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtevent0_0.9.37-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libwbclient0_2%3a4.9.5+dfsg-5+deb10u1_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 65%E: /var/cache/apt/archives/samba_2%3a4.9.5+dfsg-5+deb10u1_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/samba_2%3a4.9.5+dfsg-5+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libldb1_2%3a1.5.1+really1.4.6-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpython2.7_2.7.16-2+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python-ldb_2%3a1.5.1+really1.4.6-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python-tdb_1.3.16-2+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libavahi-common-data_0.7-4+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libavahi-common3_0.7-4+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libapparmor1_2.13.2-10_armel.deb
E: Prior errors apply to /var/cache/apt/archives/dbus_1.12.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdbus-1-3_1.12.16-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libavahi-client3_0.7-4+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libcups2_2.2.10-6+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libjansson4_2.12-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpopt0_1.16-12_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python-talloc_2.1.14-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/samba-libs_2%3a4.9.5+dfsg-5+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/python-samba_2%3a4.9.5+dfsg-5+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/samba-common_2%3a4.9.5+dfsg-5+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/samba-common-bin_2%3a4.9.5+dfsg-5+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/tdb-tools_1.3.16-2+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libntfs-3g883_1%3a2017.3.23AR.3-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/ntfs-3g_1%3a2017.3.23AR.3-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libassuan0_2.5.2-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libksba8_1.3.5-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libnpth0_1.6-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/dirmngr_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gnupg_2.2.12-1+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/gnupg-utils_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpgconf_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpg_2.2.12-1+deb10u1_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 76%E: /var/cache/apt/archives/pinentry-curses_1.1.0-2_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/pinentry-curses_1.1.0-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpg-agent_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpg-wks-client_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpg-wks-server_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gpgsm_2.2.12-1+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/gnupg-l10n_2.2.12-1+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libss2_1.44.5-1+deb10u2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libusb-0.1-4_2%3a0.1.12-32_armel.deb
E: Prior errors apply to /var/cache/apt/archives/multiarch-support_2.28-10_armel.deb
E: Prior errors apply to /var/cache/apt/archives/cpio_2.12+dfsg-9_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libtext-wrapi18n-perl_0.06-7.1_all.deb
E: Prior errors apply to /var/cache/apt/archives/debconf-i18n_1.5.71_all.deb
E: Prior errors apply to /var/cache/apt/archives/iputils-ping_3%3a20180629-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/isc-dhcp-common_4.4.1-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/kmod_26-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/nano_3.2-3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/vim-tiny_2%3a8.1.0875-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/vim-common_2%3a8.1.0875-5_all.deb
E: Prior errors apply to /var/cache/apt/archives/xxd_2%3a8.1.0875-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libfstrm0_0.4.0-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libgeoip1_1.6.12-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libjson-c3_0.12.1+ds-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblmdb0_0.9.22-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libprotobuf-c1_1.3.1-1+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libicu63_63.1-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libxml2_2.9.4+dfsg1-7+b3_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libisc1100_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdns1104_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libisccc161_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libisccfg163_1%3a9.11.5.P4+dfsg-5.1_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 87%E: /var/cache/apt/archives/libbind9-161_1%3a9.11.5.P4+dfsg-5.1_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/libbind9-161_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblwres161_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/bind9-host_1%3a9.11.5.P4+dfsg-5.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblockfile-bin_1.14-1.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/openssh-server_1%3a7.9p1-10+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/openssh-sftp-server_1%3a7.9p1-10+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/openssh-client_1%3a7.9p1-10+deb10u1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpcre2-8-0_10.32-5_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libpsl5_0.20.2-2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/wget_1.20.1-1.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/xz-utils_5.2.4-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libavahi-core7_0.7-4+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libdaemon0_0.14-7_armel.deb
E: Prior errors apply to /var/cache/apt/archives/avahi-daemon_0.7-4+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/busybox_1%3a1.30.1-4_armel.deb
E: Prior errors apply to /var/cache/apt/archives/busybox-syslogd_1%3a1.30.1-4_all.deb
E: Prior errors apply to /var/cache/apt/archives/devio_1.2-1.2+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/fuse_2.9.9-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libfuse2_2.9.9-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/htop_2.2.0-1+b1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/initramfs-tools_0.133+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/klibc-utils_2.0.6-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libklibc_2.0.6-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/initramfs-tools-core_0.133+deb10u1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libclass-isa-perl_0.36-6_all.deb
E: Prior errors apply to /var/cache/apt/archives/libfile-copy-recursive-perl_0.44-1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libgssglue1_0.4-2+b2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libidn11_1.33-2.2_armel.deb
E: Prior errors apply to /var/cache/apt/archives/liblockfile1_1.14-1.1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/libswitch-perl_2.17-2_all.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 98%E: /var/cache/apt/archives/lockfile-progs_0.1.18_armel.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/lockfile-progs_0.1.18_armel.deb
E: Prior errors apply to /var/cache/apt/archives/net-tools_1.60+git20180626.aebd88e-1_armel.deb
E: Prior errors apply to /var/cache/apt/archives/rsync_3.1.3-6_armel.deb
E: Prior errors apply to /var/cache/apt/archives/u-boot-tools_2019.01+dfsg-7_armel.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 100%
dpkg-deb: error: archive '/var/cache/apt/archives/libsqlite3-0_3.27.2-3_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libsqlite3-0_3.27.2-3_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/libkeyutils1_1.6-6_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libkeyutils1_1.6-6_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/libssl1.1_1.1.1d-0+deb10u2_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libssl1.1_1.1.1d-0+deb10u2_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/libkrb5-3_1.17-3_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libkrb5-3_1.17-3_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/libgssapi-krb5-2_1.17-3_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libgssapi-krb5-2_1.17-3_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/libk5crypto3_1.17-3_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libk5crypto3_1.17-3_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/libkrb5support0_1.17-3_armel.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/libkrb5support0_1.17-3_armel.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libsqlite3-0_3.27.2-3_armel.deb
 /var/cache/apt/archives/libkeyutils1_1.6-6_armel.deb
 /var/cache/apt/archives/libssl1.1_1.1.1d-0+deb10u2_armel.deb
 /var/cache/apt/archives/libkrb5-3_1.17-3_armel.deb
 /var/cache/apt/archives/libgssapi-krb5-2_1.17-3_armel.deb
 /var/cache/apt/archives/libk5crypto3_1.17-3_armel.deb
 /var/cache/apt/archives/libkrb5support0_1.17-3_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

'apt-get install ca-certificates' gave a bunch of errors ending with
W: You may want to run apt-get update to correct these problems
E: Sub-process /usr/bin/dpkg returned an error code (1)
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 09:23PM
unmesh,

Try this.

apt-get clean
apt-get install debian-keyring debian-archive-keyring
apt-get update
And keep executing
apt-get update
until there is no error.

And then,
apt-get dist-upgrade

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 10:30PM
'apt-get -y install debian-keyring debian-archive-keyring'
Get:1 http://ftp.us.debian.org/debian/ buster/main debian-archive-keyring all 2019.1 [75.1 kB]
Get:2 http://ftp.us.debian.org/debian/ buster/main debian-keyring all 2019.02.25 [32.4 MB]
Fetched 32.4 MB in 19s (1689 kB/s)
E: /var/cache/apt/archives/debian-archive-keyring_2019.1_all.deb not a valid DEB package.
E: Prior errors apply to /var/cache/apt/archives/debian-archive-keyring_2019.1_all.deb
E: Prior errors apply to /var/cache/apt/archives/debian-keyring_2019.02.25_all.deb
debconf: apt-extracttemplates failed: No such file or directory
dpkg-deb: error: archive '/var/cache/apt/archives/debian-archive-keyring_2019.1_all.deb' contains not understood data member control.tar.xz, giving up
dpkg: error processing /var/cache/apt/archives/debian-archive-keyring_2019.1_all.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/debian-archive-keyring_2019.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

'apt-get update' gives a bunch of output ending in
W: GPG error: http://ftp.us.debian.org buster Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY DCC9EFBF77E11517
W: GPG error: http://http.debian.net buster-updates Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138
W: GPG error: http://security.debian.org buster/updates Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AA8E81B4331F7F50 NO_PUBKEY 112695A0E562B32A
W: Failed to fetch http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/trusty/Release  Unable to find expected entry 'main/binary-armel/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried it 5 times
Re: OS upgrade failure on Pogo Mobile
December 01, 2019 10:59PM
unmesh,

I think it is the case that you jump versions too far. Unfortunately, dpkg has changed a bit since wheezy to buster. At the present time, no developer cares to rerofit old wheezy dpkg to work with new deb format, afaik.

Try upgrade to jessie using the same steps to see if you will be successul.

If you have installed a bunch of packages and use this rootfs heavily, I think upgrading version-by-version would be more feasible. If you don't care what is in your current rootfs then I would create a new Debian buster rootfs from scratch.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: OS upgrade failure on Pogo Mobile
December 02, 2019 12:05AM
I tried a new buster rootfs install on a SDHC card and it didn't boot, even after the modifying the fstab file to use /dev/sda1 instead of the rootfs label

The LED is a steady orange instead of green with Wheezy
Re: OS upgrade failure on Pogo Mobile
December 02, 2019 10:40PM
I decided to limit my ambition to an upgrade to only Jessie and was continuing to get errors including one for a java upgrade from a non-existent repository. I finally figured out where this was being requested and deleted it.

'/etc/apt/sources.list.d/webupd8team-java.list'

It started doing the install without errors and I left it doing so while I attended to other things for a couple of hours. Unfortunately, my Windows laptop with the SSH session went to sleep so I missed seeing the output till the very end. I SSHed in again and top did not show anything going so so I rebooted but now it won't respond to SSH.

A network scan shows it is listening only on the rpcbind port.

Almost there, I hope.



Edited 1 time(s). Last edit at 12/02/2019 10:48PM by unmesh.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: