Welcome! Log In Create A New Profile

Advanced

NSA 320 - is it bricked?

Posted by rookpl 
NSA 320 - is it bricked?
October 06, 2020 04:22AM
Hi, I've got problem with my zyxel nsa 320. I was using it few months ago with Debian, but disks broke down, and now i tried to back it to life, with new hdd.

I turn it on with serial connected, but there is no output. Minicom is blank. All leds are on, fan is working, cpu is hot.

I thought that maybe i broke something months ago, and forgot about it, so i tried kwboot first

su root
apt install u-boot-tools (to install kwboot)
cd /uboot.2017.07-tld-1.nsa320.bohdi
kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2017.07-tld-1.nsa320s.mtd0.kwb -p

waiting for reboot target, and stuck on it...

Is it bricked? What else can i try?



Edited 2 time(s). Last edit at 10/06/2020 04:37AM by rookpl.
Re: NSA 320 - is it bricked?
October 06, 2020 05:16AM
rookpl,

Make sure you use the correct u-boot image.

Quote

uboot.2017.07-tld-1.nsa320.bodhi.tar
md5
ed39fa5a2f79809f32a78b661faa7a2c
sha256
67eba01db75a020cdb71e20b636d5863042f51a996f9c80d342e7ccca64a31e2

Is it a typo here?
kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2017.07-tld-1.nsa320s.mtd0.kwb -p

You meant:

kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2017.07-tld-1.nsa320.mtd0.kwb -p

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: NSA 320 - is it bricked?
October 06, 2020 05:30AM
yes, its typo :) i wrote it correctly nsa320 in terminal (just checked in logs ;) but there is no response...
tried to switch RX / TX with no luck



Edited 1 time(s). Last edit at 10/06/2020 05:34AM by rookpl.
Re: NSA 320 - is it bricked?
October 06, 2020 06:02AM
rookpl,

All leds are on, fan is working, cpu is hot.

When there is no LED on and just fan on, it is bad. That behavior above is somewhat better.

Make sure you check the wire connections. And also remove the serial connection, just power up to see if the behavior is different.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: NSA 320 - is it bricked?
October 06, 2020 06:24AM
When i first turn it on, there was only 3 LEDs on (without hdd1 i hdd2), fan was down. Afters 2 or 3 power off, all LEDs and fan turned on.

There is no difference with or without serial connection.

I think that serial connection is ok. It worked few months ago, and cable was inside NAS, without possibility to broke or something, but i ordered another one to test. It should arrive tomorrow



Edited 1 time(s). Last edit at 10/07/2020 04:10AM by rookpl.
Re: NSA 320 - is it bricked?
October 07, 2020 09:25PM
rookpl,

> I think that serial connection is ok. It worked
> few months ago, and cable was inside NAS, without
> possibility to broke or something,

That's not enough to say it is OK. You should recheck the connections.

And test the serial converter module with a different box if possible, to make sure it is working (or do loop back TX-RX, at least).

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 10/07/2020 09:25PM by bodhi.
Re: NSA 320 - is it bricked?
October 08, 2020 02:28AM
I have got another USB Serial module with leds that signals rx / tx connection - still nothing. Leds on USB stick shows nothing too. Tested on Ubuntu with Minicom and Windows Tera Term

When i unplug it from NSA320 and connect RX and TX cables together i see some marks in terminal, so it works.

There is no output from NSA320.

With kwboot... command - TX led is blinking - only that one, and nothing happens, waiting for reboot

I tested LAN once again and this time its blinking when cable is connected, but i cant see it in my router...



Edited 4 time(s). Last edit at 10/08/2020 07:37AM by rookpl.
Re: NSA 320 - is it bricked?
October 09, 2020 02:33AM
> With kwboot... command - TX led is blinking - only
> that one, and nothing happens, waiting for reboot

The box LEDs are all on, meaning it started but could not load u-boot. Running kwboot sometime is tricky to get a handshake.

Have you tried to power on the box, and then run kwboot within a second or so? (instead of the usual sequence of running kwboot first).

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: