Welcome! Log In Create A New Profile

Advanced

Issues with pogoplug E02 boot since Uboot update

Posted by phileblunt86 
Issues with pogoplug E02 boot since Uboot update
May 16, 2017 09:59PM
Thank you in advance to this forum, you're some of the most informative folks I've ever seen!

I updated my E02 pogoplug's uboot a few months ago, because I wanted GPT support. However, after this, the Arch installation I used booted once, and now since then, I can't connect to the PP at all, I've used a few different rootfs, and its not showing up on my dhcp list with any of them, so I'm a bit stumped as to what I should try next, as the led on the front turns green, and appears working. I don't have any logs from the uboot update, but I do recall following the instructions here : http://forum.doozan.com/read.php?3,12381

Any help you could offer would be appreciated, thank you!



Edited 1 time(s). Last edit at 05/16/2017 10:01PM by phileblunt86.
Re: Issues with pogoplug E02 boot since Uboot update
May 17, 2017 03:51AM
phileblunt86,

Since you have installed Arch u-boot, try booting Debian rootfs following this instruction:
http://forum.doozan.com/read.php?3,23727

And then you can decide whether keeping Debian or go back to Arch.

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner
Re: Issues with pogoplug E02 boot since Uboot update
May 17, 2017 12:07PM
Thank you so much bodhi!

Okay, my PP booted with the Debian rootfs in the thread you referenced, and im able to ssh in. I'm happy to know my plug isn't borked! However I still can't get the standard Arch Kirkwood build to load. Could this have to do with my U-boot? And how would I go about fixing this? Are there different Uboots that must be used with individual distros? Thank you so much already!
Re: Issues with pogoplug E02 boot since Uboot update
May 17, 2017 11:44PM
phileblunt86,

>
> Okay, my PP booted with the Debian rootfs in the t
> hread you referenced, and im able to ssh in. I'm h
> appy to know my plug isn't borked!

Cool!

> However I still
> can't get the standard Arch Kirkwood build to load
> . Could this have to do with my U-boot?

No, not your uboot.

> And how wo
> uld I go about fixing this? Are there different Ub
> oots that must be used with individual distros?

Arch built U-boot and my U-boot build are very similar. That's why you only need to adjust a few envs to boot Debian. Your Arch rootfs is probably of a wrong flavor. Probably you have a non-FDT Kirkwood rootfs.

1. Boot back into Debian and log in, get the envs listing (just in case we need to look at it):

fw_printenv


2. Mount your Arch rootfs, and assuming it is mounted as /media/sdb1. Get the listing of the kernel files:

ls -lart /media/boot
ls -lart /media/boot/dt*/

I think you need a new Arch rootfs that support FDT kernel. The above output will hopefully tell whether if it is true. And you can also go to Arch site and find out where that rootfs tarball is.

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: