Welcome! Log In Create A New Profile

Advanced

kwboot not working

Posted by balanga 
kwboot not working
November 03, 2017 11:03AM
I've used kwboot in the past but recently it won't access my serial port. cu works but kwboot doesn't.

Is there any alternative to kwboot that I can try?

Could the problem be due to my usb serial connector breaking in some way?
Re: kwboot not working
November 03, 2017 11:11AM
balanga Wrote:
-------------------------------------------------------
> I've used kwboot in the past but recently it won't
> access my serial port. cu works but kwboot
> doesn't.
>
> Is there any alternative to kwboot that I can try?
>
>
> Could the problem be due to my usb serial
> connector breaking in some way?

Didn't you have this problem before trying to use on a bsd system? Are did you find a bsd equivalent?
Re: kwboot not working
November 04, 2017 11:03AM
I did try building it on FreeBSD but never got it to work. My current problem is on Linux (Ubuntu) although I've also tried Arch Linux. I have had it working in the past but it doesn't work now. I'll try it on a different laptop in case there is something wrong with the USB port this time using Debian although I'm having problems trying access the serial device as /dev/ttyUSB0...
Re: kwboot not working
November 04, 2017 12:44PM
sudo apt install u-boot-tools

the number can change try 0-3 to see after unpluging and reinserting.

"sudo dmesg" should show you the usb is connected and which tty

i.e.

usb 2-1.2: new full-speed USB device number 21 using ehci-pci
usb 2-1.2: New USB device found, idVendor=067b, idProduct=2303
usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0

usb 2-1.2: Product: USB-Serial Controller
usb 2-1.2: Manufacturer: Prolific Technology Inc.
pl2303 2-1.2:1.0: pl2303 converter detected
usb 2-1.2: pl2303 converter now attached to ttyUSB0


while in the same directory otherwise include the path to the .kwb file.

kwboot -b u-boot.kwb -p -t -B 115200 /dev/ttyUSB0



Edited 1 time(s). Last edit at 11/04/2017 12:50PM by feas.
Re: kwboot not working
November 04, 2017 04:45PM
Many thanks for the "dmesg | greb usb". It shows my pl2303 converter is attached to ttyUSB0.

Unfortunately cu -l /dev/ttyUSB0 -s 115200 shows Connected but that's all.and kwboot doesn't connect either.

The GoFlexHome dock boots up and I can ssh into it but nothing is output via the serial connector so I guess the connector has broken or I've damaged the GoFlexHome dock. I've ordered a new connector so I'll see if that sorts things out.
Re: kwboot not working
November 05, 2017 04:22AM
cable tx is connected to board rx
and
cable rx is connected to board tx?
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: