Welcome! Log In Create A New Profile

Advanced

U-Boot w/ MMC/SD-card booting for Pogoplug Series 4

Posted by davygravy 
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 05, 2014 10:44PM
@dhead,

Did you try to put this in the custom_params parameter at the end of bootcmd?

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 06, 2014 09:50AM
@bodhi

Thanks,
I've set my bootarg correctly but I had the wrong assumption that blparam works with this uBoot.
It looks like that blparam is writing to the wrong addresses (although it does read the uBoot params and shows the updated params).
Setting the param from uBoot by serial fixed it.
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 07, 2014 03:35AM
@dhead,

blparam (in Arch/stock uBoot) use different location from fw_setenv for uBoot envs (for this uBoot), and writes a differrent checksum too. So mixing usage will corrupt the envs.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 08, 2014 05:59AM
Bodhi,

The previous output I listed was exactly the same whether I was in netconsole or UART. At this point I'm starting to convince myself it is a USB/SD/Flash compatibility related issue.

I have been looking at a third independent pogoplug V4 - non mobile where I have successfully installed on one USB stick the Arch-Linux distribution. On several other 4GBy USB sticks - same manufacturer I get more or less the same hang ( as well as others from different manufacturers) . The one successful USB stick run's consistently good. This is very close to what I see with the SD card as well.

I tried the SD utility described above as well as several other techniques for formatting and mke'ing an ext3 filesystem
The one difference is the computer where I am formatting/making is running Ubuntu 13.10. It would be hard to believe that there is a difference between that and debian wheezy.

This is for information only at this point.

Geo
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 08, 2014 08:39AM
Geo,

You'd need to stop netconsole to see full UART booting process. When both are activated at the same time, you stopped UART output at that point. I believe that it should show more output in UART booting. Were both activated when you see these output?

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 01/08/2014 08:42AM by bodhi.
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 09, 2014 05:29AM
Bodhi,
I have used just the UART and got the same response.
My UART is just barely hanging in place - I'll re-solder the connector today and go back to UART console.
Geo -
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
January 09, 2014 06:45AM
Geo,

Please post the entire UART output, from the uBoot version banner to where it got stuck booting kernel.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: U-Boot w/ MMC/SD-card booting for Pogoplug Series 4
February 07, 2014 08:47PM
Download links are dead. I have both nand and uart flashes for mobile, but I need the normal uboot.

edit: oh there it is https://www.dropbox.com/sh/nwt2kbvetvgvroo/sm-hZ0B4jU/Kirkwood/uboot/Pogoplug4Series



Edited 1 time(s). Last edit at 02/07/2014 08:49PM by hyperlogos.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: