Welcome! Log In Create A New Profile

Advanced

(solved) NSA325 - kernel panic, Cannot open root device "(null)" (powerloss while initial install)

Posted by elisdg 
Hello,
I tried to do the initial install of the NSA325 with linux-4.12.1-kirkwood-tld and rootfs.
I head a powerloss before the reboot.

Status:
Since there is a lot of awesome information in this forum (thank you guys, thank you bodhi) I got it nearly working.
Booted with kwboot, restored Environment with uboot.2016.05-tld-1.environment.src and adjusted it to my environment.
USB Stick is an ext3 Corsair Survivor 16GB (USB3) labeled as rootfs (I tried also with a noname usb2.0 8GB stick).

Problem:
While booting debian it gives a kernel panic and is not finding root ?!
I think the relevant output is:
...
[    5.978414] ata2: SATA link down (SStatus 0 SControl F300)
[    5.994171] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    6.001726] Please append a correct "root=" boot option; here are the available partitions:
[    6.010185] 1f00            1024 mtdblock0
[    6.010189]  (driver?)
[    6.016749] 1f01             512 mtdblock1
[    6.016751]  (driver?)
[    6.023404] 1f02             512 mtdblock2
[    6.023408]  (driver?)
[    6.029991] 1f03             512 mtdblock3
[    6.029994]  (driver?)
[    6.036560] 1f04           10240 mtdblock4
[    6.036563]  (driver?)
[    6.043146] 1f05           10240 mtdblock5
[    6.043149]  (driver?)
[    6.049724] 1f06           48896 mtdblock6
[    6.049727]  (driver?)
[    6.056294] 1f07           10240 mtdblock7
[    6.056296]  (driver?)
[    6.062870] 1f08           48896 mtdblock8
[    6.062873]  (driver?)
[    6.069450] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    6.077746] CPU: 0 PID: 1 Comm: swapper Not tainted 4.12.1-kirkwood-tld-1 #1
[    6.084824] Hardware name: Marvell Kirkwood (Flattened Device Tree)
[    6.091137] [<c010ea54>] (unwind_backtrace) from [<c010ab48>] (show_stack+0x10/0x14)
[    6.098919] [<c010ab48>] (show_stack) from [<c01dba9c>] (panic+0xb0/0x250)
[    6.105831] [<c01dba9c>] (panic) from [<c0c01274>] (mount_block_root+0x204/0x27c)
[    6.113343] [<c0c01274>] (mount_block_root) from [<c0c013d8>] (mount_root+0xec/0x118)
[    6.121209] [<c0c013d8>] (mount_root) from [<c0c01528>] (prepare_namespace+0x124/0x184)
[    6.129249] [<c0c01528>] (prepare_namespace) from [<c0c00e90>] (kernel_init_freeable+0x210/0x260)
[    6.138166] [<c0c00e90>] (kernel_init_freeable) from [<c0833200>] (kernel_init+0x8/0x10c)
[    6.146385] [<c0833200>] (kernel_init) from [<c01070f0>] (ret_from_fork+0x14/0x24)
[    6.153992] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    6.163114] usb 1-1: new high-speed USB device number 2 using orion-ehci
[    6.369633] usb 1-1: New USB device found, idVendor=05e3, idProduct=0608
[    6.376371] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    6.398109] usb 1-1: Product: USB2.0 Hub
[    6.408637] hub 1-1:1.0: USB hub found
[    6.418117] hub 1-1:1.0: 4 ports detected
[    6.748113] usb 1-1.2: new high-speed USB device number 3 using orion-ehci
[    6.919382] usb 1-1.2: New USB device found, idVendor=1b1c, idProduct=1a04
[    6.926299] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    6.948109] usb 1-1.2: Product: Survivor 3.0
[    6.952403] usb 1-1.2: Manufacturer: Corsair
[    6.956685] usb 1-1.2: SerialNumber: 09020000001181700000001705
[    6.978782] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[    6.998286] scsi host2: usb-storage 1-1.2:1.0
[    8.018707] scsi 2:0:0:0: Direct-Access     Corsair  Survivor 3.0     1.00 PQ: 0 ANSI: 5
[    8.039543] sd 2:0:0:0: [sda] 31375360 512-byte logical blocks: (16.1 GB/15.0 GiB)
[    8.058137] sd 2:0:0:0: [sda] Write Protect is off
[    8.062971] sd 2:0:0:0: [sda] Mode Sense: 23 00 02 00
[    8.078132] sd 2:0:0:0: [sda] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[    8.101240]  sda: sda1
[    8.105779] sd 2:0:0:0: [sda] Attached SCSI removable disk
... waiting some time...
[ 113.768638] random: crng init done
... nothing happens anymore ...

Printenv:

printenv
arcNumber=2097
baudrate=115200
bootargs_stock=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) root=/dev/nfs rw init=/init
bootcmd=run bootcmd_uenv; run scan_disk; run set_bootargs; run bootcmd_exec
bootcmd_exec=run load_uimage; if run load_initrd; then if run load_dtb; then bootm $load_uimage_addr $load_initrd_addr $load_dtb_addr; else bootm $load_uimage_addr $load_initrd_addr; fi; else if run load_dtb; then bootm $load_uimage_addr - $load_dtb_addr; else bootm $load_uimage_addr; fi; fi
bootcmd_linux=setenv bootargs $(bootargs_linux); mw.l f1010100 0020c000; usb reset; ext2load usb 0:1 $(loadaddr) /boot/uImage; ext2load usb 0:1 0x01100000 /boot/uInitrd; bootm $(loadaddr) 0x01100000
bootcmd_uenv=run uenv_load; if test $uenv_loaded -eq 1; then run uenv_import; fi
bootdelay=10
bootdev=usb
console=console=ttyS0,115200
device=0:1
devices=usb ide
disks=0 1 2 3
dtb_file=/boot/dts/kirkwood-nsa325.dtb
ethact=egiga0
ethaddr=52:3b:20:9c:11:51
fileaddr=800000
filesize=ca0
if_netconsole=ping $serverip
ipaddr=192.168.0.231
led_error=orange blinking
led_exit=green off
led_init=green blinking
load_dtb=echo loading DTB $dtb_file ...; load $bootdev $device $load_dtb_addr $dtb_file
load_dtb_addr=0x1c00000
load_initrd=echo loading uInitrd ...; load $bootdev $device $load_initrd_addr /boot/uInitrd
load_initrd_addr=0x1100000
load_uimage=echo loading uImage ...; load $bootdev $device $load_uimage_addr /boot/uImage
load_uimage_addr=0x800000
machid=0x831
mainlineLinux=yes
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:1M(u-boot),4M(uImage),32M(rootfs),-(data)
partition=nand0,2
preboot_nc=run if_netconsole start_netconsole
scan_disk=echo running scan_disk ...; scan_done=0; setenv scan_usb "usb start";  setenv scan_ide "ide reset";  setenv scan_mmc "mmc rescan"; for dev in $devices; do if test $scan_done -eq 0; then echo Scan device $dev; run scan_$dev; for disknum in $disks; do if test $scan_done -eq 0; then echo device $dev $disknum:1; if load $dev $disknum:1 $load_uimage_addr /boot/uImage 1; then scan_done=1; echo Found bootable drive on $dev $disknum; setenv device $disknum:1; setenv bootdev $dev; fi; fi; done; fi; done
serverip=192.168.0.220
set_bootargs=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts $custom_params
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version;
stderr=serial
stdin=serial
stdout=serial
to_linux=setenv mainlineLinux yes; setenv bootcmd \\'run bootcmd_linux\\'; saveenv; reset
uenv_addr=0x810000
uenv_import=echo importing envs ...; env import -t $uenv_addr $filesize
uenv_init_devices=setenv init_usb "usb start";  setenv init_ide "ide reset";  setenv init_mmc "mmc rescan"; for devtype in $devices; do run init_$devtype; done;
uenv_load=run uenv_init_devices; setenv uenv_loaded 0; for devtype in $devices;  do for disknum in 0; do run uenv_read_disk; done; done;
uenv_read=echo loading envs from $devtype $disknum ...; if load $devtype $disknum:1 $uenv_addr /boot/uEnv.txt; then setenv uenv_loaded 1; fi
uenv_read_disk=if test $devtype -eq mmc; then if $devtype part; then run uenv_read;  fi; else if $devtype part $disknum; then run uenv_read; fi;  fi
usb_ready_retry=15

Previous to the powerloss I mad a backup of /fw_env.config and proc_mtd:
# cat /backup/etc-fw_env.config 
# MTD device name       Device offset   Env. size       Flash sector size       Number of sectors
# NAND example
/dev/mtd1               0x0000          0x20000         0x20000                 4

# cat /vb_backup/proc_mtd 
dev:    size   erasesize  name
mtd0: 00100000 00020000 "uboot"
mtd1: 00080000 00020000 "uboot_env"
mtd2: 00080000 00020000 "key_store"
mtd3: 00080000 00020000 "info"
mtd4: 00a00000 00020000 "etc"
mtd5: 00a00000 00020000 "kernel_1"
mtd6: 02fc0000 00020000 "rootfs1"
mtd7: 00a00000 00020000 "kernel_2"
mtd8: 02fc0000 00020000 "rootfs2"


now I see, that I didn't change the arc number after restoring the environment. Could that be the problem?
I tried many different thing. I don't know, why it cant find "root"


Thank you for every hint that leads me in the right direction



Edited 3 time(s). Last edit at 01/01/2019 01:23PM by elisdg.
Re: NSA325 - kernel panic, Cannot open root device "(null)" (powerloss while initial install)
January 01, 2019 05:04AM
elisdg,

Your envs look fine. Only some minor adjustment needed (which should not effect booting). But the power loss has apparently corrupted the rootfs.

Unplug the rootfs and mount it on another Linux box and fix the errors. Assuming the USB drive is assigned /dev/sdb1 and mount at /media/sdb1.

Fix file system error

umount  /media/sdb1
e2fsck /dev/sdb1
sync

Mount it and check the relevant files

mount /dev/sdb1 /media/sdb1
ls -lart /media/sdb1/boot

And then if all checked out OK.

sync

And unmount the drive and remove it, bring it back to the NS325. Power up. Capture the entire serial console log , if you have serial console, and post here.

-bodhi
===========================
Forum Wiki
bodhi's corner
Thank you!! I don't know why, but now it works, after running:
e2fsck -f /dev/sdb1
... as you advised and Step 4 again (Generate the uImage with DTB embedded inside...).
Beforehand I created the USB Stick multiple times, following the guide.

I wonder, because e2fsck didn't really say, that it had to repair something.

But as a sidenode:
At first e2fsck said:
fsck e2fsck: Cannot continue, aborting
... although I proved, that the drive was NOT mounted or anything. I found a thread where someone states, that there could be a problem with udev and mdadm.

I didn't found mdadm on my machine, but I just disabled "udev" for a try (service stop udev) and after that:
- e2fsck was executed successfully
- the NSA325 was able to boot into debian

(I'm just writing that, for future reference)

Thank you, again!



Edited 2 time(s). Last edit at 01/01/2019 11:19AM by elisdg.
oh no, the problem still exists, its strange...

when I do:
cat dts/kirkwood-nsa325.dtb  >> zImage.fdt
... while preparing the boot-directory I get the error I described above

But when I do:
cat dts/kirkwood-goflexnet.dtb  >> zImage.fdt
... the NSA325 is starting and I can login BUT network is not working.


current printenv is:
baudrate=115200
bootargs_linux=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(u-boot),0x400000(uImage),0x2000000(rootfs),0xDB00000(data), root=LABEL=rootfs loglevel=8
bootargs_stock=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) root=/dev/nfs rw init=/init
bootcmd=run bootcmd_uenv; run scan_disk; run set_bootargs; run bootcmd_exec
bootcmd_exec=run load_uimage; if run load_initrd; then if run load_dtb; then bootm $load_uimage_addr $load_initrd_addr $load_dtb_addr; else bootm $load_uimage_addr $load_initrd_addr; fi; else if run load_dtb; then bootm $load_uimage_addr - $load_dtb_addr; else bootm $load_uimage_addr; fi; fi
bootcmd_linux=setenv bootargs $(bootargs_linux); mw.l f1010100 0020c000; usb reset; ext2load usb 0:1 $(loadaddr) /boot/uImage; ext2load usb 0:1 0x01100000 /boot/uInitrd; bootm $(loadaddr) 0x01100000
bootcmd_uenv=run uenv_load; if test $uenv_loaded -eq 1; then run uenv_import; fi
bootdelay=10
bootdev=usb
console=console=ttyS0,115200
device=0:1
devices=usb ide
disks=0 1 2 3
dtb_file=/boot/dts/kirkwood-nsa325.dtb
ethact=egiga0
fileaddr=800000
filesize=ca0
if_netconsole=ping $serverip
ipaddr=192.168.0.231
led_error=orange blinking
led_exit=green off
led_init=green blinking
load_dtb=echo loading DTB $dtb_file ...; load $bootdev $device $load_dtb_addr $dtb_file
load_dtb_addr=0x1c00000
load_initrd=echo loading uInitrd ...; load $bootdev $device $load_initrd_addr /boot/uInitrd
load_initrd_addr=0x1100000
load_uimage=echo loading uImage ...; load $bootdev $device $load_uimage_addr /boot/uImage
load_uimage_addr=0x800000
mainlineLinux=yes
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:1M(u-boot),4M(uImage),32M(rootfs),-(data)
partition=nand0,2
preboot_nc=run if_netconsole start_netconsole
scan_disk=echo running scan_disk ...; scan_done=0; setenv scan_usb "usb start";  setenv scan_ide "ide reset";  setenv scan_mmc "mmc rescan"; for dev in $devices; do if test $scan_done -eq 0; then echo Scan device $dev; run scan_$dev; for disknum in $disks; do if test $scan_done -eq 0; then echo device $dev $disknum:1; if load $dev $disknum:1 $load_uimage_addr /boot/uImage 1; then scan_done=1; echo Found bootable drive on $dev $disknum; setenv device $disknum:1; setenv bootdev $dev; fi; fi; done; fi; done
serverip=192.168.0.220
set_bootargs=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts $custom_params
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version;
stderr=serial
stdin=serial
stdout=serial
to_linux=setenv mainlineLinux yes; setenv bootcmd \\'run bootcmd_linux\\'; saveenv; reset
uenv_addr=0x810000
uenv_import=echo importing envs ...; env import -t $uenv_addr $filesize
uenv_init_devices=setenv init_usb "usb start";  setenv init_ide "ide reset";  setenv init_mmc "mmc rescan"; for devtype in $devices; do run init_$devtype; done;
uenv_load=run uenv_init_devices; setenv uenv_loaded 0; for devtype in $devices;  do for disknum in 0; do run uenv_read_disk; done; done;
uenv_read=echo loading envs from $devtype $disknum ...; if load $devtype $disknum:1 $uenv_addr /boot/uEnv.txt; then setenv uenv_loaded 1; fi
uenv_read_disk=if test $devtype -eq mmc; then if $devtype part; then run uenv_read;  fi; else if $devtype part $disknum; then run uenv_read; fi;  fi
usb_ready_retry=15
arcNumber=4495
ethaddr=00:50:43:00:02:02

Full Output is:


U-Boot 2017.07-tld-1 (Sep 05 2017 - 00:42:03 -0700)
ZyXEL NSA325 2-Bay Power Media Server

SoC:   Kirkwood 88F6282_A1
DRAM:  512 MiB
WARNING: Caches not enabled
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
MV88E1318 PHY initialized on egiga0
Hit any key to stop autoboot: 10  9  8  7  6  5  4  3  2  1  0 
starting USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 
Use USB retry period from the environment: 15 second(s)
1 Storage Device(s) found

Reset IDE: ide_preinit failed

Partition Map for USB device 0  --   Partition Type: DOS

Part	Start Sector	Num Sectors	UUID		Type
  1	2048      	31373312  	9de96e73-01	83

## Unknown partition table type 0

## Unknown partition table type 0

## Unknown partition table type 0

## Unknown partition table type 0

## Unknown partition table type 0

## Unknown partition table type 0
loading envs from usb 0 ...
2874 bytes read in 830 ms (2.9 KiB/s)

no IDE devices available
importing envs ...

Warning: egiga0 MAC addresses don't match:
Address in SROM is         52:3b:20:9c:11:51
Address in environment is  00:50:43:00:02:02
running scan_disk ...
Scan device usb
device usb 0:1
1 bytes read in 692 ms (0 Bytes/s)
Found bootable drive on usb 0
loading uImage ...
3836140 bytes read in 904 ms (4 MiB/s)
loading uInitrd ...
7245696 bytes read in 908 ms (7.6 MiB/s)
loading DTB /boot/dts/kirkwood-nsa325.dtb ...
14548 bytes read in 1538 ms (8.8 KiB/s)
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Linux-4.12.1-kirkwood-tld-1
   Created:      2019-01-01  19:00:08 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3836076 Bytes = 3.7 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01100000 ...
   Image Name:   initramfs-4.12.1-kirkwood-tld-1
   Created:      2017-07-24   0:18:23 UTC
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    7245632 Bytes = 6.9 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 01c00000
   Booting using the fdt blob at 0x1c00000
   Loading Kernel Image ... OK
   Loading Ramdisk to 1f424000, end 1fb0cf40 ... OK
   Loading Device Tree to 1f41d000, end 1f4238d3 ... OK
Using machid 0x831 from environment

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.12.1-kirkwood-tld-1 (root@tldDebian) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 PREEMPT Sat Jul 15 21:40:50 PDT 2017
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=0005397f
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] OF: fdt: Machine model: ZyXEL NSA325
[    0.000000] Memory policy: Data cache writeback
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130048
[    0.000000] Kernel command line: console=ttyS0,115200
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 506336K/524288K available (8192K kernel code, 716K rwdata, 1972K rodata, 1024K init, 288K bss, 17952K reserved, 0K cma-reserved)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
[    0.000000]     vmalloc : 0xe0800000 - 0xff800000   ( 496 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xe0000000   ( 512 MB)
[    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
[    0.000000]       .text : 0xc0008000 - 0xc0900000   (9184 kB)
[    0.000000]       .init : 0xc0c00000 - 0xc0d00000   (1024 kB)
[    0.000000]       .data : 0xc0d00000 - 0xc0db3274   ( 717 kB)
[    0.000000]        .bss : 0xc0db9b9c - 0xc0e01e60   ( 289 kB)
[    0.000000] Preemptible hierarchical RCU implementation.
[    0.000000] NR_IRQS:16 nr_irqs:16 16
[    0.000000] clocksource: orion_clocksource: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 9556302233 ns
[    0.000006] sched_clock: 32 bits at 200MHz, resolution 5ns, wraps every 10737418237ns
[    0.000036] Switching to timer-based delay loop, resolution 5ns
[    0.000419] Console: colour dummy device 80x30
[    0.000448] Calibrating delay loop (skipped), value calculated using timer frequency.. 400.00 BogoMIPS (lpj=2000000)
[    0.000467] pid_max: default: 32768 minimum: 301
[    0.000631] Security Framework initialized
[    0.000728] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000744] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.001510] CPU: Testing write buffer coherency: ok
[    0.002381] Setting up static identity map for 0x100000 - 0x100058
[    0.002615] mvebu-soc-id: MVEBU SoC ID=0x6282, Rev=0x1
[    0.005183] devtmpfs: initialized
[    0.009193] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.009216] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.009539] prandom: seed boundary self test passed
[    0.012397] prandom: 100 self tests passed
[    0.012412] pinctrl core: initialized pinctrl subsystem
[    0.013388] NET: Registered protocol family 16
[    0.013671] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.015033] cpuidle: using governor ladder
[    0.015094] cpuidle: using governor menu
[    0.015390] Feroceon L2: Enabling L2
[    0.015427] Feroceon L2: Cache support initialised.
[    0.015727] [Firmware Info]: /ocp@f1000000/ethernet-controller@72000/ethernet0-port@0: local-mac-address is not set
[    0.019895] No ATAGs?
[    0.027112] vgaarb: loaded
[    0.027366] SCSI subsystem initialized
[    0.027748] usbcore: registered new interface driver usbfs
[    0.027801] usbcore: registered new interface driver hub
[    0.027842] usbcore: registered new device driver usb
[    0.028571] clocksource: Switched to clocksource orion_clocksource
[    0.097646] VFS: Disk quotas dquot_6.6.0
[    0.097719] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.105876] NET: Registered protocol family 2
[    0.106481] TCP established hash table entries: 4096 (order: 2, 16384 bytes)
[    0.106538] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[    0.106590] TCP: Hash tables configured (established 4096 bind 4096)
[    0.106659] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.106680] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.106826] NET: Registered protocol family 1
[    0.107165] RPC: Registered named UNIX socket transport module.
[    0.107175] RPC: Registered udp transport module.
[    0.107180] RPC: Registered tcp transport module.
[    0.107186] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.107431] NetWinder Floating Point Emulator V0.97 (double precision)
[    0.108077] audit: initializing netlink subsys (disabled)
[    0.108408] Initialise system trusted keyrings
[    0.108449] Key type blacklist registered
[    0.108524] audit: type=2000 audit(0.099:1): state=initialized audit_enabled=0 res=1
[    0.108658] workingset: timestamp_bits=30 max_order=17 bucket_order=0
[    0.108726] zbud: loaded
[    0.109498] NFS: Registering the id_resolver key type
[    0.109525] Key type id_resolver registered
[    0.109531] Key type id_legacy registered
[    0.109550] nfs4filelayout_init: NFSv4 File Layout Driver Registering...
[    0.109558] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[    0.109719] jffs2: version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
[    0.109869] fuse init (API version 7.26)
[    0.110138] orangefs_debugfs_init: called with debug mask: :none: :0:
[    0.110302] orangefs_init: module version upstream loaded
[    0.110311] SGI XFS with ACLs, security attributes, realtime, no debug enabled
[    2.558576] random: fast init done
[    4.461539] Key type asymmetric registered
[    4.461554] Asymmetric key parser 'x509' registered
[    4.461608] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 249)
[    4.461617] io scheduler noop registered
[    4.461623] io scheduler deadline registered
[    4.461697] io scheduler cfq registered (default)
[    4.462673] kirkwood-pinctrl f1010000.pin-controller: registered pinctrl driver
[    4.464157] mvebu-pcie mbus@f1000000:pcie-controller@82000000: PCI host bridge to bus 0000:00
[    4.464175] pci_bus 0000:00: root bus resource [io  0x1000-0xfffff]
[    4.464185] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xefffffff]
[    4.464196] pci_bus 0000:00: root bus resource [bus 00-ff]
[    4.464452] PCI: bus0: Fast back to back transfers disabled
[    4.464471] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    4.488712] PCI: bus1: Fast back to back transfers disabled
[    4.488882] pci 0000:00:01.0: BAR 14: assigned [mem 0xe0000000-0xe00fffff]
[    4.488898] pci 0000:01:00.0: BAR 0: assigned [mem 0xe0000000-0xe0001fff 64bit]
[    4.488918] pci 0000:00:01.0: PCI bridge to [bus 01]
[    4.488932] pci 0000:00:01.0:   bridge window [mem 0xe0000000-0xe00fffff]
[    4.489008] pcieport 0000:00:01.0: enabling device (0140 -> 0142)
[    4.489086] pci 0000:01:00.0: enabling device (0140 -> 0142)
[    4.489515] mv_xor f1060800.xor: Marvell shared XOR driver
[    4.549150] mv_xor f1060800.xor: Marvell XOR (Registers Mode): ( xor cpy sg intr )
[    4.549344] mv_xor f1060900.xor: Marvell shared XOR driver
[    4.609131] mv_xor f1060900.xor: Marvell XOR (Registers Mode): ( xor cpy sg intr )
[    4.609515] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    4.610607] console [ttyS0] disabled
[    4.610665] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 26, base_baud = 12500000) is a 16550A
[    5.278628] console [ttyS0] enabled
[    5.288653] loop: module loaded
[    5.292296] sata_mv f1080000.sata: slots 32 ports 2
[    5.299372] scsi host0: sata_mv
[    5.302895] scsi host1: sata_mv
[    5.306244] ata1: SATA max UDMA/133 irq 32
[    5.310400] ata2: SATA max UDMA/133 irq 32
[    5.315142] nand: device found, Manufacturer ID: 0xec, Chip ID: 0xf1
[    5.321611] nand: Samsung NAND 128MiB 3,3V 8-bit
[    5.326245] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    5.333872] Scanning device for bad blocks
[    5.435781] 9 ofpart partitions found on MTD device orion_nand
[    5.441652] Creating 9 MTD partitions on "orion_nand":
[    5.446818] 0x000000000000-0x000000100000 : "uboot"
[    5.452776] 0x000000100000-0x000000180000 : "uboot_env"
[    5.459115] 0x000000180000-0x000000200000 : "key_store"
[    5.465292] 0x000000200000-0x000000280000 : "info"
[    5.471023] 0x000000280000-0x000000c80000 : "etc"
[    5.476655] 0x000000c80000-0x000001680000 : "kernel_1"
[    5.482815] 0x000001680000-0x000004640000 : "rootfs1"
[    5.489093] 0x000004640000-0x000005040000 : "kernel_2"
[    5.495269] 0x000005040000-0x000008000000 : "rootfs2"
[    5.502510] libphy: Fixed MDIO Bus: probed
[    5.507211] libphy: orion_mdio_bus: probed
[    5.512135] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
[    5.619051] mv643xx_eth: Set the PHY to fix link down
[    5.619669] mv643xx_eth_port mv643xx_eth_port.0 eth0: port 0 with MAC address 00:50:43:00:02:02
[    5.633620] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    5.640225] ehci-pci: EHCI PCI platform driver
[    5.644737] ehci-orion: EHCI orion driver
[    5.648802] ata1: SATA link down (SStatus 0 SControl F300)
[    5.654620] orion-ehci f1050000.ehci: EHCI Host Controller
[    5.660182] orion-ehci f1050000.ehci: new USB bus registered, assigned bus number 1
[    5.667996] orion-ehci f1050000.ehci: irq 30, io mem 0xf1050000
[    5.698597] orion-ehci f1050000.ehci: USB 2.0 started, EHCI 1.00
[    5.704827] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    5.711668] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.718940] usb usb1: Product: EHCI Host Controller
[    5.723842] usb usb1: Manufacturer: Linux 4.12.1-kirkwood-tld-1 ehci_hcd
[    5.730588] usb usb1: SerialNumber: f1050000.ehci
[    5.735817] hub 1-0:1.0: USB hub found
[    5.739656] hub 1-0:1.0: 1 port detected
[    5.744059] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    5.749372] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 2
[    5.757118] xhci_hcd 0000:01:00.0: hcc params 0x014042cb hci version 0x96 quirks 0x00000004
[    5.765740] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[    5.772584] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.779849] usb usb2: Product: xHCI Host Controller
[    5.784743] usb usb2: Manufacturer: Linux 4.12.1-kirkwood-tld-1 xhci-hcd
[    5.791490] usb usb2: SerialNumber: 0000:01:00.0
[    5.796642] hub 2-0:1.0: USB hub found
[    5.800488] hub 2-0:1.0: 2 ports detected
[    5.804912] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    5.810217] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 3
[    5.817724] usb usb3: We don't know the algorithms for LPM for this host, disabling LPM.
[    5.825986] usb usb3: New USB device found, idVendor=1d6b, idProduct=0003
[    5.832819] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.840086] usb usb3: Product: xHCI Host Controller
[    5.844980] usb usb3: Manufacturer: Linux 4.12.1-kirkwood-tld-1 xhci-hcd
[    5.851802] usb usb3: SerialNumber: 0000:01:00.0
[    5.856943] hub 3-0:1.0: USB hub found
[    5.860791] hub 3-0:1.0: 2 ports detected
[    5.865414] usbcore: registered new interface driver usb-storage
[    5.871765] mousedev: PS/2 mouse device common for all mice
[    5.877644] i2c /dev entries driver
[    5.883827] rtc-pcf8563 0-0051: low voltage detected, date/time is not reliable.
[    5.891468] rtc-pcf8563 0-0051: rtc core: registered rtc-pcf8563 as rtc0
[    5.901018] hidraw: raw HID events driver (C) Jiri Kosina
[    5.906807] drop_monitor: Initializing network drop monitor service
[    5.913464] NET: Registered protocol family 17
[    5.917995] Key type dns_resolver registered
[    5.922879] registered taskstats version 1
[    5.926991] Loading compiled-in X.509 certificates
[    5.931903] zswap: loaded using pool lzo/zbud
[    5.938155] Key type big_key registered
[    5.943495] Key type encrypted registered
[    5.949909] rtc-pcf8563 0-0051: low voltage detected, date/time is not reliable.
[    5.957365] rtc-pcf8563 0-0051: hctosys: unable to read the hardware clock
[    5.979534] ata2: SATA link down (SStatus 0 SControl F300)
[    5.995302] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    6.002862] Please append a correct "root=" boot option; here are the available partitions:
[    6.011297] 1f00            1024 mtdblock0 
[    6.011301]  (driver?)
[    6.017864] 1f01             512 mtdblock1 
[    6.017867]  (driver?)
[    6.024502] 1f02             512 mtdblock2 
[    6.024506]  (driver?)
[    6.031155] 1f03             512 mtdblock3 
[    6.031158]  (driver?)
[    6.037719] 1f04           10240 mtdblock4 
[    6.037722]  (driver?)
[    6.044313] 1f05           10240 mtdblock5 
[    6.044317]  (driver?)
[    6.050895] 1f06           48896 mtdblock6 
[    6.050898]  (driver?)
[    6.057462] 1f07           10240 mtdblock7 
[    6.057465]  (driver?)
[    6.064047] 1f08           48896 mtdblock8 
[    6.064050]  (driver?)
[    6.070627] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    6.078931] CPU: 0 PID: 1 Comm: swapper Not tainted 4.12.1-kirkwood-tld-1 #1
[    6.086007] Hardware name: Marvell Kirkwood (Flattened Device Tree)
[    6.092323] [<c010ea54>] (unwind_backtrace) from [<c010ab48>] (show_stack+0x10/0x14)
[    6.100113] [<c010ab48>] (show_stack) from [<c01dba9c>] (panic+0xb0/0x250)
[    6.107025] [<c01dba9c>] (panic) from [<c0c01274>] (mount_block_root+0x204/0x27c)
[    6.114546] [<c0c01274>] (mount_block_root) from [<c0c013d8>] (mount_root+0xec/0x118)
[    6.122411] [<c0c013d8>] (mount_root) from [<c0c01528>] (prepare_namespace+0x124/0x184)
[    6.130451] [<c0c01528>] (prepare_namespace) from [<c0c00e90>] (kernel_init_freeable+0x210/0x260)
[    6.139367] [<c0c00e90>] (kernel_init_freeable) from [<c0833200>] (kernel_init+0x8/0x10c)
[    6.147588] [<c0833200>] (kernel_init) from [<c01070f0>] (ret_from_fork+0x14/0x24)
[    6.155194] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    6.164322] usb 1-1: new high-speed USB device number 2 using orion-ehci
[    6.370125] usb 1-1: New USB device found, idVendor=05e3, idProduct=0608
[    6.376869] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    6.398583] usb 1-1: Product: USB2.0 Hub
[    6.409133] hub 1-1:1.0: USB hub found
[    6.418591] hub 1-1:1.0: 4 ports detected
[    6.748587] usb 1-1.2: new high-speed USB device number 3 using orion-ehci
[    6.919748] usb 1-1.2: New USB device found, idVendor=1b1c, idProduct=1a04
[    6.926663] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    6.948583] usb 1-1.2: Product: Survivor 3.0
[    6.952881] usb 1-1.2: Manufacturer: Corsair
[    6.957173] usb 1-1.2: SerialNumber: 09020000001181700000001705
[    6.979282] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[    6.998776] scsi host2: usb-storage 1-1.2:1.0
[    8.019202] scsi 2:0:0:0: Direct-Access     Corsair  Survivor 3.0     1.00 PQ: 0 ANSI: 5
[    8.040040] sd 2:0:0:0: [sda] 31375360 512-byte logical blocks: (16.1 GB/15.0 GiB)
[    8.058613] sd 2:0:0:0: [sda] Write Protect is off
[    8.063448] sd 2:0:0:0: [sda] Mode Sense: 23 00 02 00
[    8.078608] sd 2:0:0:0: [sda] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[    8.101737]  sda: sda1
[    8.106397] sd 2:0:0:0: [sda] Attached SCSI removable disk

Can you see something?

What is ment by/how do I get rid of:
Warning: egiga0 MAC addresses don't match:
Address in SROM is         52:3b:20:9c:11:51
Address in environment is  00:50:43:00:02:02



Edited 4 time(s). Last edit at 01/01/2019 01:04PM by elisdg.
SOLVED

ok, now it works.

oh man ... X)

I missed the "skip"-part in "4. Create uImage with embedded DTB for booting with older u-boots (2012 or earlier). Skip this step if you have installed the latest U-Boot for Kirkwood (or are installing this u-boot at the same time)"

I forgot, that while troubleshooting the powerloss with kwboot, I installed the latest bootloader X)

So, now I freshly copied the files from the boot-directory of the tar archive into the the boot-stick and all seems fine at the moment


thanks again, and awesome new year!



Edited 1 time(s). Last edit at 01/01/2019 01:28PM by elisdg.
Re: NSA325 - kernel panic, Cannot open root device "(null)" (powerloss while initial install)
January 01, 2019 10:44PM
elisdg,

> SOLVED

Cool :)

> I missed the "skip"-part in "4. Create uImage with
> embedded DTB for booting with older u-boots (2012
> or earlier). Skip this step if you have
> installed the latest U-Boot for Kirkwood
(or
> are installing this u-boot at the same time)"

It's a common mis-step coming from stock u-boot to new u-boot!

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: