Welcome! Log In Create A New Profile


Do I need a serial cable?

Posted by radsfaninlv 
Do I need a serial cable?
February 03, 2014 01:12PM
I have messed up my pogoplug E02 so badly that it won't boot in to the rescue system or from a usb stick. To fix this am I going to need a serial cable? If so, do I just reinstall the rescue system?

Re: Do I need a serial cable?
February 03, 2014 03:48PM

You do need a serial cable, if netconsole was not set up. Boot with serial console and look at uBoot envs, you might have typos in one of those uBoot envs, if you have been changing them. If you can't spot the error, post the output of uBoot command printenv.

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: Do I need a serial cable?
February 07, 2014 06:55PM
The serial cable arrived and this is the output during bootup from putty:

U-Boot 2011.12 (Feb 20 2012 - 21:21:59)
Pogoplug E02

SoC: Kirkwood 88F6281_A0
DRAM: 256 MiB
WARNING: Caches not enabled
NAND: 128 MiB
In: serial
Out: serial
Err: serial
Net: egiga0
88E1116 Initialized on egiga0
Hit any key to stop autoboot: 0
(Re)start USB...
USB: Register 10011 NbrPorts 1
scanning bus for devices... 2 USB Device(s) found
scanning bus for storage devices... 0 Storage Device(s) found
** Block device usb 0 not supported

** Invalid boot device **
Creating 1 MTD partitions on "nand0":
0x000002500000-0x000008000000 : "mtd=3"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size: 131072 bytes (128 KiB)
UBI: logical eraseblock size: 129024 bytes
UBI: smallest flash I/O unit: 2048
UBI: sub-page size: 512
UBI: VID header offset: 512 (aligned 512)
UBI: data offset: 2048
UBI: attached mtd1 to ubi0
UBI: MTD device name: "mtd=3"
UBI: MTD device size: 91 MiB
UBI: number of good PEBs: 728
UBI: number of bad PEBs: 0
UBI: max. allowed volumes: 128
UBI: wear-leveling threshold: 4096
UBI: number of internal volumes: 1
UBI: number of user volumes: 0
UBI: available PEBs: 717
UBI: total number of reserved PEBs: 11
UBI: number of PEBs reserved for bad PEB handling: 7
UBI: max/mean erase counter: 1/1
UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi:rootfs", error -19
Error reading superblock on volume 'ubi:rootfs'!
** Block device usb 0 not supported
** Block device usb 1 not supported
** Block device usb 2 not supported
** Block device usb 3 not supported
** Block device usb 0 not supported
** Block device usb 0 not supported
Wrong Image Format for bootm command
ERROR: can't get kernel image!
stopping USB..

NAND read: device 0 offset 0x100000, size 0x400000
4194304 bytes read: OK
## Booting kernel from Legacy Image at 00800000 ...
Image Name: Linux-
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 3236180 Bytes = 3.1 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
Loading Kernel Image ... OK
Using machid 0xdd6 from environment

Starting kernel ...

Uncompressing Linux............................................................................................................................................................................................................. done, booting the kernel.

Error: unrecognized/unsupported machine ID (r1 = 0x00000dd6).

Available machine support:

ID (hex) NAME
00000690 Marvell DB-88F6281-BP Development Board
00000691 Marvell RD-88F6192-NAS Development Board
00000692 Marvell RD-88F6281 Reference Board
0000078c Marvell 88F6281 GTW GE Board
00000831 Marvell SheevaPlug Reference Board
00000bb6 Seagate FreeAgent DockStar
00000c11 Seagate Goflex Net
0000085b QNAP TS-119/TS-219
00000915 Marvell OpenRD Base Board

Please check your kernel config and/or bootloader.

It looks like I have the wrong machine ID but I am not sure how to send a command via putty to fix it. I have tried googling it but no joy yet. When I plug it in to a router I don't get a IP address. Thanks for your help bohdi.

Re: Do I need a serial cable?
February 07, 2014 07:10PM
I figured out how to get a command prompt. It helps to fully read the output.

I changed the machine id to 831 and the arcNumber to 2097 but it still doen't boot.

output of printenv:

bootcmd=usb start; run force_rescue_bootcmd; run ubifs_bootcmd; run usb_bootcmd; usb stop; run rescue_bootcmd; run pogo_bootcmd; reset
force_rescue_bootcmd=if test $force_rescue -eq 1 || ext2load usb 0:1 0x1700000 /rescueme 1 || fatload usb 0:1 0x1700000 /rescueme.txt 1; then run rescue_bootcmd; fi
led_error=orange blinking
led_exit=green off
led_init=green blinking
pogo_bootcmd=if fsload uboot-original-mtd0.kwb; then go 0x800200; fi
rescue_bootcmd=if test $rescue_installed -eq 1; then run rescue_set_bootargs; nand read.e 0x800000 0x100000 0x400000; bootm 0x800000; else run pogo_bootcmd; fi
rescue_set_bootargs=setenv bootargs console=$console ubi.mtd=2 root=ubi0:rootfs ro rootfstype=ubifs $mtdparts $rescue_custom_params
ubifs_bootcmd=run ubifs_set_bootargs; if ubi part data && ubifsmount rootfs && ubifsload 0x800000 /boot/uImage && ubifsload 0x1100000 /boot/uInitrd; then bootm 0x800000 0x1100000; fi
ubifs_set_bootargs=setenv bootargs console=$console ubi.mtd=$ubifs_mtd root=ubi0:rootfs rootfstype=ubifs $mtdparts $ubifs_custom_params
usb_boot=mw 0x800000 0 1; ext2load usb $usb_device 0x800000 /boot/uImage; if ext2load usb $usb_device 0x1100000 /boot/uInitrd; then bootm 0x800000 0x1100000; else bootm 0x800000; fi
usb_bootcmd=run usb_init; run usb_set_bootargs; run usb_boot
usb_init=run usb_scan
usb_scan=usb_scan_done=0;for scan in $usb_scan_list; do run usb_scan_$scan; if test $usb_scan_done -eq 0 && ext2load usb $usb 0x800000 /boot/uImage 1; then usb_scan_done=1; echo "Found bootable drive on usb $usb"; setenv usb_device $usb; setenv usb_root /dev/$dev; fi; done
usb_scan_1=usb=0:1 dev=sda1
usb_scan_2=usb=1:1 dev=sdb1
usb_scan_3=usb=2:1 dev=sdc1
usb_scan_4=usb=3:1 dev=sdd1
usb_scan_list=1 2 3 4
usb_set_bootargs=setenv bootargs console=$console root=$usb_root rootdelay=$usb_rootdelay rootfstype=$usb_rootfstype $mtdparts $usb_custom_params

Environment size: 2355/131068 bytes

I look forward to your suggestions.

Re: Do I need a serial cable?
February 07, 2014 09:44PM

A couple things to try:

1. Your uBoot envs look good, except that the machid is still set to dd6, while arcNumber is 2097. Without USB attached, try setting it again to 831 in serial console:
> setenv machid 831
> boot
see if it will boot into rescue system.

2. Download the latest rootfs (link in my signature) and put it on a USB thumb drive. In serial console, set arcNumber to 3542, and machid to dd6 and boot:
> setenv arcNumber 3542
> setenv machid dd6
> boot
see if it boots into Debian

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: Do I need a serial cable?
February 07, 2014 10:00PM
The first method worked. THANK YOU VERY MUCH!!

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.