Welcome! Log In Create A New Profile


Rescue V2.8.2 : many enhancements + full kernel support for GoFlexNet/Home, Zyxel NSA3x0 and many others

Posted by davygravy 
Excellent update. Just finished updating a couple of GFH devices with no issue. Was by far the easiest way to partition a 3TB drive for Arch. I tried several times attaching to Ubuntu. Booted to the rescue system and work first time. Rescue uses an older version of GPT fdisk. Could this be the reason I had no issues?
Would this work with PogopLug Pro? Can anyone please point me to where I can update/upgrade uboot and kernel for pogoplug Pro and to where I can install debian wheezy? I'm new and I have been lurking for a couple of days before I registered and I couldn't find about the kernel/uboot upgrade or how to get wheezy.
No this rescue system won't work for Pogo Pro. For Debian on Pogo Pro, see this thread:

Forum Wiki
bodhi's corner
Noob question:

Device: Pogoplug E02 arcNumber 3542

I first installed this:


2. Install Arch Linux or some other Linux derivative, boot from that, login and:
Install Rescue system (this replaces the Pogoplug partition with a powerful rescue system.

cd /tmp
wget http://jeff.doozan.com/debian/rescue/install_rescue.sh
chmod +x install_rescue.sh

Without any usb attached it boots into rescue, uname -a shows kernel "linux debian 3.3.2".
Later i found it is actually "Rescue System v2" from here: http://forum.doozan.com/read.php?4,3896 .
Previous os it was something debian (or pogo stock fw) on nand and with this operation i managed to erase it.

After that i installed "Rescue V2.8.2" http://forum.doozan.com/read.php?4,7915,page=1

What is the my problem/question ?

c/p from "Rescue V2.8.2" page:

0. Booting into the Rescue System: from within netconsole or serial, execute the following:
run bootcmd_rescue

I don't have serial cable, netconsole only works one way (ie from pogo to my pc; my interaction where it says "press any key to stop booting... with 10s counter" produced zero success), and if doesn't boot into "Rescue V2.8.2" it must be "rescue v2" ? So now i have 2 rescue systems installed and it automatically boots into "Rescue System v2" ?

I tested netconsole response on win and linux os.

But if i look script for v2 and instructions for v2.8.2 i see both mtd1,2 are flashed & formated, thus having both rescue systems is a contradiction (assuming i have done "instructions" for v2.8.2 somehow wrong).



$UBIFORMAT /dev/mtd2 -s 512 -f $ROOTFS_MTD2 -y



flash_eraseall /dev/mtd1
nandwrite /dev/mtd1 uImage-mtd1.img

flash_eraseall /dev/mtd2
ubiformat /dev/mtd2 -s 512 -f rootfs-mtd2.img -y

3rd possibility is that i don't understand usage notes for rescue v2.8.2 correctly.

Edited 4 time(s). Last edit at 01/23/2014 02:44PM by jst818.
I just installed 2.8.2 on my Pogoplug E02. I was able to successfuly boot into rescue via netconsole.
I was able to get Rescue system 2.8.2 working on a Pogoplug V4, here are the steps that I followed for those interested. :)

I modified the mtdparts so that the original mtd1 and mtd2 were merged as a single 6M mtd1. The rescue system's kernel was 3.5 MB and was not fitting in the original mtd1. Other than the below changes everything worked out of the box. Even Pogo V4s arcNumber and machtype were accepted by the rescue system. :)

I am using @bodhi's uBoot for Pogo V4

fw_setenv mtdparts 'mtdparts=orion_nand:2M(u-boot),6M(uImage),8M(failsafe),112M(root)'
fw_setenv set_bootargs_rescue 'setenv bootargs console=$console ubi.mtd=3 root=ubi0:rootfs ro rootfstype=ubifs $mtdparts'
fw_setenv bootcmd_rescue 'run set_bootargs_rescue; nand read.e 0x800000 0x200000 0x400000; bootm 0x800000'
fw_setenv bootcmd 'run bootcmd_usb; run bootcmd_mmc; run bootcmd_sata; run bootcmd_rescue; reset'

flash_eraseall /dev/mtd1
nandwrite /dev/mtd1 uImage-mtd1.img

flash_eraseall /dev/mtd3
ubiformat /dev/mtd3 -s 512 -f rootfs-mtd2.img -y

Edited 1 time(s). Last edit at 08/21/2014 02:08AM by varkey.
Has this been tested on V4 yet? My v4 doesn't seem to want to boot its internal flash any more anyway, so I guess I'm ready to test.
hyperlogos Wrote:
> Has this been tested on V4 yet? My v4 doesn't seem
> to want to boot its internal flash any more
> anyway, so I guess I'm ready to test.

Yes, works fine on my V4.
can this be used to restore the original pogoplug firmware on an e02?
the mtdblock partitions were wiped and no backup exists.
n64 Wrote:
> can this be used to restore the original pogoplug
> firmware on an e02?
> the mtdblock partitions were wiped and no backup
> exists.

No. It is an rescue system to be installed in the same NAND space as the orginial OS was.

Forum Wiki
bodhi's corner
is there a newer version than 2.8.2? or is this pretty much it?
Does the Rescue system work on NSA325V2?
So I downloaded and ran the process for:

(or for V2.8.2 use this link : https://dl.dropbox.com/u/1015928/Kirkwood/rescue/RescueV2.8.2-10292012.tar.gz == but change commands for flashing accordingly !)

now I am getting ready to build using:

mkdir rescuebuilddir
cd rescuebuilddir
wget http://buildroot.uclibc.org/downloads/buildroot-2010.08.tar.gz
tar zxf buildroot-2010.08.tar.gz
wget http://dl.dropbox.com/u/1015928/Kirkwood/rescue/rescue-V2.8-applyto-buildroot2010.08.patch
cd buildroot-2010.08
patch -p1 < ../rescue-V2.8-applyto-buildroot2010.08.patch
wget http://dl.dropbox.com/u/1015928/Kirkwood/rescue/custom-RescueV2.8.1.tar.gz
tar zxf custom-RescueV2.8.1.tar.gz
cp custom/buildroot-config .config

Is there a custom-RescueV2.8.2.tar.gz to go with V2.8.2 or do I still use custom-RescueV2.8.1.tar.gz as linked?


davygravy has not updated or responded to question about this rescue system for a long time. This thread basically dead, so you're on your own here. I don't use this rescue system (or any other rescue system except Jeffs V2) so can't be of help.

Forum Wiki
bodhi's corner
thanks, it compiled with some errors so I will see about the other.
dropbox.com links for rescue 2.8.X from 1st link are dead.
Anyone has a copy ?

Installed it 2-3 years ago on my pogo e02 as described , in betweeen upgraded uboot to latest 2017 (done all steps), now i cannot it make working, if i unplug usb hdd i only got orange blinking led on pogo e02.
Meanwhile i didn't touch mtd1/mtd2 where rescue "resides".


bootcmd=run bootcmd_uenv; run scan_disk; run set_bootargs; run bootcmd_exec
bootcmd_uenv=run uenv_load; if test $uenv_loaded -eq 1; then run uenv_import; fi
devices=usb ide mmc
disks=0 1 2 3
if_netconsole=ping $serverip
led_error=orange blinking
led_exit=green off
led_init=green blinking
load_dtb=echo loading DTB $dtb_file ...; load $bootdev $device $load_dtb_addr $dtb_file
load_initrd=echo loading uInitrd ...; load $bootdev $device $load_initrd_addr /boot/uInitrd
load_uimage=echo loading uImage ...; load $bootdev $device $load_uimage_addr /boot/uImage
scan_disk=echo running scan_disk ...; scan_done=0; setenv scan_usb "usb start"; setenv scan_ide "ide reset"; setenv scan_mmc "mmc rescan"; for dev in $devices; do if test $scan_done -eq 0; then echo Scan device $dev; run scan_$dev; for disknum in $disks; do if test $scan_done -eq 0; then echo device $dev $disknum:1; if load $dev $disknum:1 $load_uimage_addr /boot/uImage 1; then scan_done=1; echo Found bootable drive on $dev $disknum; setenv device $disknum:1; setenv bootdev $dev; fi; fi; done; fi; done
set_bootargs=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts $custom_params
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version;
uenv_import=echo importing envs ...; env import -t $uenv_addr $filesize
uenv_init_devices=setenv init_usb "usb start"; setenv init_ide "ide reset"; setenv init_mmc "mmc rescan"; for devtype in $devices; do run init_$devtype; done;
uenv_load=run uenv_init_devices; setenv uenv_loaded 0; for devtype in $devices; do for disknum in 0; do run uenv_read_disk; done; done;
uenv_read_disk=if test $devtype -eq mmc; then if $devtype part; then run uenv_read; fi; else if $devtype part $disknum; then run uenv_read; fi; fi
uenv_read=echo loading envs from $devtype $disknum ...; if load $devtype $disknum:1 $uenv_addr /boot/uEnv.txt; then setenv uenv_loaded 1; fi
ethaddr= XXXXX //edited
preboot_nc=setenv nc_ready 0; for pingstat in 1 2 3 4 5; do; sleep 1; if run if_netconsole; then setenv nc_ready 1; fi; done; if test $nc_ready -eq 1; then run start_netconsole; fi
preboot=run preboot_nc
ipaddr=XXXXX //edited
serverip=XXXXX //edited

edit: solved, got it working !
added this from 2015 uboot envs :D

fw_setenv bootcmd 'run bootcmd_uenv; run scan_disk; run set_bootargs; run bootcmd_exec; run bootcmd_rescue'
fw_setenv bootcmd_rescue 'run set_bootargs_rescue; nand read.e 0x800000 0x100000 0x400000; bootm 0x800000'
fw_setenv bootcmd_pogo 'run bootcmd_rescue'
fw_setenv rescue_installed 1s
fw_setenv set_bootargs_rescue 'setenv bootargs console=$console ubi.mtd=2 root=ubi0:rootfs ro rootfstype=ubifs $mtdparts'

Edited 8 time(s). Last edit at 11/17/2017 04:31PM by jst818.

I finally found the Rescue System V2.8.2 images.
I have shared them on Jumpshare, because they claim to have an unlimited storage time:
Rescue System V2.8.2 davygravy

I also uploaded the buildroot, in case the original link dies:

I could not find rescue-V2.8-applyto-buildroot2010.08.patch or custom-RescueV2.8.1.tar.gz, though.
Would be nice if someone could provide those archives!

Edited 1 time(s). Last edit at 05/28/2018 09:12AM by ElMariachi.
Would this rescue system/instructions work on the t5325?
R92001r Wrote:
> Would this rescue system/instructions work on the
> t5325?

No, it will not work on the T5325.

Forum Wiki
bodhi's corner

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.