Welcome! Log In Create A New Profile

Advanced

Reliability of booting from SD

Posted by cobalt 
Reliability of booting from SD
April 17, 2013 05:31PM
Hi,

booting my tablet from SD is highly erratic. To describe the effect, from e.g. 17 boot attempts only 7 succeed. This does not mean, that half of the attempt work, but instead, long series of failures can occur, although i initialized device before each attempt.

I wonder, whether this reflects the known state of the spl/u-boot implementation or any known issue.

I'm using a recent u-boot from linux-sunxi and a sunxi-3.4 kernel.

Thanks, cobalt

--
My tablet is a PROTAB2-IPS9 (V1.0)
Re: Reliability of booting from SD
October 09, 2013 05:51AM
Hi Cobalt,
We are also facing the same problem. We are developing tablet PC by our own. While testing we are getting error some times but some times its booting fine.We are also booting from SD card. I think we are on the same page.

So if find any solution please let us know. We can get solution together for this problem.

Thanks in advance.

Thanks & Advance
Sathish Kumar.K
Re: Reliability of booting from SD
October 09, 2013 09:26AM
Hi Ayssathi,

If I find out something, i'll let you know.

Kind Regards, Cobalt

--
My tablet is a PROTAB2-IPS9 (V1.0)
Re: Reliability of booting from SD
October 09, 2013 11:12PM
Thank you for your kind reply.

May i know your country ?

Thanks & Regards
Sathish K
Re: Reliability of booting from SD
October 10, 2013 02:04AM
Hi Ayssathi,

as you ask, i'm located in Germany.

For the problem, i believe you're in much better position than i am in respect of diagnostic opportunities. I for one haven't yet managed to open the device (no screws, perhaps i should try using a vacuum cup to lift the display off the housing). Therefore, i've virtually no access to any diagnostic connections right now and i'm thus being limited to very coarse go/nogo tests which means the whole boot pipeline (spi,u-boot,linux,image) must work properly until i can decide 'go'.

Meanwhile i got me a cubie-board for differential diagnostics. I was thinking to apply a micro SD breakout (see http://linux-sunxi.org/MicroSD_Breakout) and a protocol analyzer, as the SD slot wires are the only connections available outside the device to access activity in the early boot stages, but that would be a project in itself. My main suspicions is software, meaning spi in particular, perhaps a wrong device-specific adjustment in e.g. [board/allwinner/.../dram.c].

In your case, i think, you are in a far more fortunate situation, as the hardware was made by yourself and you have access to the TX/RX to see the u-boot diagnostics and you have easy access to various other wires, allowing to more precisely locate the circumstances of the problem.

As for your case, is u-boot is really entered or is your issue located in spi?

Regards, Cobalt.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: