Welcome! Log In Create A New Profile

Advanced

Zyxel310 - no network with new kernell

Posted by Lobo 
Zyxel310 - no network with new kernell
May 13, 2020 05:05AM
Hi, after update to new kernel (5.6.5 Kirkwood) I am without a networkcard

When I try modprobe r8168 everything look good

Is the right solution remove the r8168.conf from a /etc/modprobe.d directory and add r8168 to /etc/modules?

With this method everything work, only echo “r8168”>> /etc/modules was not enought

L



Edited 1 time(s). Last edit at 05/13/2020 05:05AM by Lobo.
Re: Zyxel310 - no network with new kernell
May 13, 2020 05:01PM
Lobo,

> Is the right solution remove the r8168.conf from a
> /etc/modprobe.d directory and add r8168 to
> /etc/modules?

They are equivalent. Either one is fine.

> With this method everything work, only

> echo “r8168”>> /etc/modules was not enought

Remember after updating /etc/modules file, you have to do:

update-initramfs -u

and then

cd /boot
mkimage -A arm -O linux -T ramdisk -C gzip -a 0x00000000 -e 0x00000000 -n initramfs-5.6.5-kirkwood-tld-1 -d initrd.img-5.6.5-kirkwood-tld-1 uInitrd

That will ensure the next boot will load the module.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: