Welcome! Log In Create A New Profile


solved - NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).

Posted by merlin2k11 
solved - NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).
August 23, 2020 03:43PM
Hello, please excuse my bad english.

I have try to use Debin on a NSA320 like https://forum.doozan.com/read.php?2,12096

I have Installed the uboot

U-Boot 2016.05-tld-1 (Jun 12 2016 - 13:52:06 -0700)
ZyXEL NSA320 2-Bay Power Media Server
gcc (Debian 4.9.2-10) 4.9.2
GNU ld (GNU Binutils for Debian) 2.25"]

For USB Stick i have used Debian-5.2.9-kirkwood-tld-1-rootfs-bodhi.tar.bz2
in another Try Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2

at every start i get the following error message and the system freezes

starting USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found

Partition Map for USB device 0  --   Partition Type: DOS

Part    Start Sector    Num Sectors     UUID            Type
  1     2048            31297536        1592d73c-01     83
loading envs from usb 0 ...
** File not found /boot/uEnv.txt **
3821592 bytes read in 488 ms (7.5 MiB/s)
7245696 bytes read in 652 ms (10.6 MiB/s)
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Linux-4.12.1-kirkwood-tld-1
   Created:      2017-07-20   8:11:24 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3821528 Bytes = 3.6 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01100000 ...
   Image Name:   initramfs-4.12.1-kirkwood-tld-1
   Created:      2017-07-24   0:18:23 UTC
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    7245632 Bytes = 6.9 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).

Available machine support:

ID (hex)        NAME
ffffffff        Generic DT based system
ffffffff        Marvell Kirkwood (Flattened Device Tree)

Please check your kernel config and/or bootloader.

can it be that the kernel is not for the nsa320?

greetings armin

Edited 2 time(s). Last edit at 08/23/2020 05:41PM by merlin2k11.
Re: NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).
August 23, 2020 04:21PM

> can it be that the kernel is not for the nsa320?

That's the correct kernel. Old version, but it should boot OK.

It seems your u-boot envs are messed up. You've must have made a mistake somewhere during installation.

Power up, interreupt serial console and

And post the entire serial console log here (don't excerpt it, just post the whole log).

Forum Wiki
bodhi's corner
Re: NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).
August 23, 2020 04:26PM
U-Boot 2016.05-tld-1 (Jun 12 2016 - 13:52:06 -0700)
ZyXEL NSA320 2-Bay Power Media Server

SoC:   Kirkwood 88F6281_A1
DRAM:  512 MiB
WARNING: Caches not enabled
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
MV88E1318 PHY initialized on egiga0
Hit any key to stop autoboot:  0
NSA320> printenv
bootcmd=run bootcmd_uenv; run bootcmd_usb; usb stop; run bootcmd_sata; reset
bootcmd_sata=run sata_init; run set_bootargs_sata; run sata_boot
bootcmd_uenv=run uenv_load; if test $uenv_loaded -eq 1; then run uenv_import; fi; sleep 3
bootcmd_usb=run usb_init; run set_bootargs_usb; run usb_boot
led_error=orange blinking
led_exit=green off
led_init=green blinking
sata_boot=mw 0x800000 0 1; run sata_load_uimage; if run sata_load_uinitrd; then bootm 0x800000 0x1100000; else bootm 0x800000; fi
sata_init=ide reset
sata_load_uimage=ext2load ide $device 0x800000 /boot/uImage
sata_load_uinitrd=ext2load ide $device 0x1100000 /boot/uInitrd
set_bootargs_sata=setenv bootargs console=$console root=$sata_root rootdelay=$rootdelay rootfstype=$rootfstype $mtdparts
set_bootargs_usb=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts earlyprintk=serial
uenv_import=echo importing envs ...; env import -t 0x810000
uenv_load=usb start; setenv uenv_loaded 0; for devtype in usb; do for disknum in 0; do run uenv_read_disk; done; done
uenv_read=echo loading envs from $devtype $disknum ...; if load $devtype $disknum:1 0x810000 /boot/uEnv.txt; then setenv uenv_loaded 1; fi
uenv_read_disk=if $devtype part $disknum; then run uenv_read; fi
usb_boot=mw 0x800000 0 1; run usb_load_uimage; if run usb_load_uinitrd; then bootm 0x800000 0x1100000; else bootm 0x800000; fi
usb_init=usb start
usb_load_uimage=ext2load usb $device 0x800000 /boot/uImage
usb_load_uinitrd=ext2load usb $device 0x1100000 /boot/uInitrd

Environment size: 2076/131068 bytes

Re: NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).
August 23, 2020 04:56PM

Yes, the envs were old. Not the default envs provided in the installation for this version of u-boot.



B. Flashing default u-boot envs image

This default envs image supports booting with multiple disk drives (and hubs) attached. The disk drives could be any type (usb, sata, sd card). The scanning logic and default envs were set to automatically boot the box with the following required configuration:

For whatever reason, if you can't set up your configuration to satisfy the following 4 requirements, then don't flash this defaut envs image. It might not boot properly. In this case, section C below can be used to tailor the envs to your specific configuration.

r1. There must be only one partition among all partitions from all drives that contains the kernel files. The 2 kernel files are /boot/uImage and /boot/uInitrd.
r2. The partition that contains the 2 kernel files must be partition 1 in a disk drive
r3. The partition that contains the rootfs must be labeled rootfs
r4. The rootfs partition is recommended to be type Ext3 (this is not a hard requirement, ext4 should boot OK, but Ext3 will ensure no problem).

So the bottom line is if you have only one rootfs in a single Ext3 partition, which is labeled as rootfs, then you're all set.

a. Download the default u-boot envs at Dropbox:


This tarball includes 3 files:

uboot.2016.05-tld-1.environment.img (the default envs image to be flashed)
uboot.2016.05-tld-1.environment (the content of the default envs in text format)
uboot.2016.05-tld-1.environment.64K.img (small envs image to be flashed on HP T5325 only).

So, there are a few different ways to make it right. However, best that you make it consistent by loading the default envs from a script, like what I described here (the script is attached to the post):


And you would just use regular serial console like you have now to load the script. And the command to load dtb_file is

setenv dtb_file '/boot/dts/kirkwood-nsa320.dtb'

Please post the serial console log here, and I will double check for you to make sure everything is OK.

Forum Wiki
bodhi's corner
Re: NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).
August 23, 2020 05:41PM
it works - many thanks
Re: NSA320 | Error: unrecognized/unsupported machine ID (r1 = 0x00000f74).
August 23, 2020 06:22PM

Forum Wiki
bodhi's corner

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.