Welcome! Log In Create A New Profile


[solved] NSA320 LEDs no longer work

Posted by mantequilla 
[solved] NSA320 LEDs no longer work
September 23, 2020 10:03AM
Hello! I have just recently recently gone through the process to update uboot and set up Debian on a flash drive on my NSA320. It's working great and OMV is just what I needed for my old but perfectly functional NAS.

However, now the only LED that works is the power LED. It turns on when the device boots, flashes while it's booting, and goes solid once it's up and running. The other LEDs (most importantly disk activity) no longer do anything. I've searched every way I can think of on the web and this forum but haven't find anything. Can anyone point me in the right direction to get them working again?

Thanks so much everyone for the great help here. I'll be doing my NAS326 next.

Edited 1 time(s). Last edit at 09/23/2020 02:48PM by mantequilla.
Re: NSA320 LEDs no longer work
September 23, 2020 12:34PM
I was having same issue on my Netgear RN102.Please check /etc/rc.local maybe it is same for you:

> All leds are constantly on.Maybe some scripts or
> drivers required.

This should be controlled in /etc/rc.local. See the examples I have in this file.

Re: NSA320 LEDs no longer work
September 23, 2020 02:40PM

Add this to your /etc/rc.local

if [ -d /sys/class/leds/nsa320:green:hdd1 ]; then
   echo ide-disk1  > /sys/class/leds/nsa320:green:hdd1/trigger 

if [ -d /sys/class/leds/nsa320:green:hdd2 ]; then
   echo ide-disk2  > /sys/class/leds/nsa320:green:hdd2/trigger 

Forum Wiki
bodhi's corner
Re: NSA320 LEDs no longer work
September 23, 2020 02:47PM
Hello whitepawn and bodhi:

You both are awesome, this is perfect. Thanks so much for your help!


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.