Welcome! Log In Create A New Profile

Advanced

uEnv.txt parameters are ignored (maybe)

Posted by cdlenfert 
uEnv.txt parameters are ignored (maybe)
October 01, 2021 11:38AM
I've put the latest rootfs onto a USB and am booting a Pogoplug Mobile v4.
In the boot/uEnv.txt file I have the following:
custom_params=zswap.enabled=1 init=/bin/systemd initramfs.runsize=23M

Initially I noticed that the Pogo wasn't booting with systemd enabled. I used a workaround for this presented here: https://forum.doozan.com/read.php?2,60589,64714#msg-64714

When I run `dmesg` I see the following when looking for zSwap status (but maybe zSwap is enabled by default? because this is present without /boot/uEnv.txt in place):
zswap: loaded using pool lzo/zbud

Finally I want the tempfs to be larger so I can reload service daemons during package installations/upgrades. uEnv.txt is also not being utilized for setting this 23M value.
tmpfs          tmpfs      11M  380K   11M   4% /run

Bodhi's comment here from May 2018 mentions a typo and uEnv.txt not loading and offers a solution. I'm not sure if the same command will work if I'm already booting into systmd, or if that matters. I simply want uEnv.txt to be read from.
https://forum.doozan.com/read.php?2,60589,60709#msg-60709

Thanks for any insights
Re: uEnv.txt parameters are ignored (maybe)
October 01, 2021 03:37PM
cdlenfert,

> When I run `dmesg` I see the following when
> looking for zSwap status (but maybe zSwap is
> enabled by default? because this is present
> without /boot/uEnv.txt in place):
>
> zswap: loaded using pool lzo/zbud
>

Yes, it always show the zswap is loaded.

in Debian,

fw_printenv

See if custom_params is shown in the env set_bootargs like this:
set_bootargs=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts $custom_params

And sounds like you don't have serial console, so you should set up netconsole and watch uEnv.txt being loaded during boot.

Also Interrupt netconsole and list the envs in u-boot

printenv

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: uEnv.txt parameters are ignored (maybe)
October 01, 2021 05:37PM
I'll work on the netconsole setup. I've done that once before on this box, so probably just need to review how to connect.

In the meantime here's what I see for set_bootargs (no mention of the custom_params)
set_bootargs=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts

Will work on the other pieces shortly. Thank you for the input!
Author:

Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: