Welcome! Log In Create A New Profile

Advanced

WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV

Posted by gisab 
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 04, 2022 04:14PM
> And then if you decide to flash that u-boot
> without serial console, you must get vzhilov or
> CyperPK or others to dump the envs image. And then
> flash both u-boot image and the envs image in the
> same session.

Or if they can dump their mtd0 (which include the envs), then you can also flash the whole mtd0 file at once.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 04, 2022 05:18PM
Hey,

Many thanks for your advice. Honestly I think the best options is ask for a dump, because I don’t know what I can check to figure out why the console is not working.

Perhaps I need to go to the orignal WD firmware?

I will try to contact CyperPK or vzhilov and let’s see if they can dump their u-boot.

Thanks again for all your time and advices with my issue.

Best
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 04, 2022 05:33PM
i5Js,

> Perhaps I need to go to the orignal WD firmware?

No, because the envs will not work.

>
> I will try to contact CyperPK or vzhilov and
> let’s see if they can dump their u-boot.
>

Yes. Come back and I'll help you flashing it. It is best to have the dump for the entire mtd0 (5MB).

> Thanks again for all your time and advices with my
> issue.

My pleasure, too bad serial console does not work, or we could have solved it many days ago!

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 04, 2022 05:46PM
I was meaning to get the WD firm back to get the console enable.. because it’s very strange that it doesn’t work at all. I was thinking it was because of the firmware and the chance it had not enable by default
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 04, 2022 05:51PM
> I was thinking it was
> because of the firmware and the chance it had not
> enable by default

Yes, it does not hurt to do that. But the chance is quite slim that was the reason. When the BootROM starts, u-boot is not running yet. The first few lines on console are from BootROM.

Quote

BootROM - 1.73
Booting from NAND flash

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 11/04/2022 05:52PM by bodhi.
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 05, 2022 11:11AM
As expected, flashing the latest stock firmware didn’t fix or enable the uart :)



Edited 1 time(s). Last edit at 11/05/2022 12:21PM by i5Js.
Re: WD My Cloud Ex2: Kernel v5.10 with Debian Bullseye and OMV
November 05, 2022 07:08PM
> As expected, flashing the latest stock firmware
> didn’t fix or enable the uart :)

PM the users on that working thread for mtd0 dump. They might not read new posts.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: