Welcome! Log In Create A New Profile


Squeeze to Wheezy Update Woes

Posted by BubbleSort 
Squeeze to Wheezy Update Woes
August 06, 2013 07:11PM
-- Pogoplug E02 (I realized after typing this that I forgot to mention the model)
Last night I switched from Arch to Debian due to packages breaking. After fighting through a bunch of issues, I managed to get Debian Squeeze running. I then got greedy and wanted newer package updates. I ran:
apt-get update
apt-get upgrade
(point sources to wheezy)
apt-get update
apt-get upgrade
apt-get dist-upgrade

After rebooting, netcat showed me that everything was working fine at least up until "Starting Kernel". After that I can't ping or ssh into my box. I then tried to follow the directions in this Squeeze to Wheezy forum post.

From my netbook, I cd'd to the usb directory and ran:
sudo mkimage -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -n Linux-2.6.32-5-kirkwood -d boot/vmlinuz-2.6.32-5-kirkwood boot/uImage

sudo mkimage -A arm -O linux -T ramdisk -C gzip -a 0x00000000 -e 0x00000000 -n Initrd-2.6.32-5-kirkwood -d boot/initrd.img-2.6.32-5-kirkwood boot/uInitrd

No go. So now I'm stuck. I'd prefer not to reinstall since I already have my applications configured and running, but I'm not sure what else to check to see what's wrong.

Here is my nc:
U-Boot 2011.12 (Feb 12 2012 - 21:33:07)
Seagate FreeAgent DockStar
arm-none-linux-gnueabi-gcc (Sourcery G++ Lite 2009q3-67) 4.4.1
GNU ld (Sourcery G++ Lite 2009q3-67)
Hit any key to stop autoboot:  0 
(Re)start USB...
USB:   Register 10011 NbrPorts 1
scanning bus for devices... 3 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Loading file "/rescueme" from usb device 0:1 (usbda1)
** File not found /rescueme
reading /rescueme.txt

** Unable to read "/rescueme.txt" from usb 0:1 **
Creating 1 MTD partitions on "nand0":
0x000002500000-0x000008000000 : "mtd=3"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    129024 bytes
UBI: smallest flash I/O unit:    2048
UBI: sub-page size:              512
UBI: VID header offset:          512 (aligned 512)
UBI: data offset:                2048
UBI: attached mtd1 to ubi0
UBI: MTD device name:            "mtd=3"
UBI: MTD device size:            91 MiB
UBI: number of good PEBs:        727
UBI: number of bad PEBs:         1
UBI: max. allowed volumes:       128
UBI: wear-leveling threshold:    4096
UBI: number of internal volumes: 1
UBI: number of user volumes:     0
UBI: available PEBs:             716
UBI: total number of reserved PEBs: 11
UBI: number of PEBs reserved for bad PEB handling: 7
UBI: max/mean erase counter: 1/1
UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi:rootfs", error -19
Error reading superblock on volume 'ubi:rootfs'!
Loading file "/boot/uImage" from usb device 0:1 (usbda1)
1 bytes read
Found bootable drive on usb 0:1
Loading file "/boot/uImage" from usb device 0:1 (usbda1)
1437272 bytes read
Loading file "/boot/uInitrd" from usb device 0:1 (usbda1)
4548307 bytes read
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Linux-2.6.32-5-kirkwood
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1437208 Bytes = 1.4 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01100000 ...
   Image Name:   Initrd-2.6.32-5-kirkwood
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    4548243 Bytes = 4.3 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

After this I am lost.
Re: Squeeze to Wheezy Update Woes
August 06, 2013 11:44PM
Just a few observations:

1. It appears you are running a Dockstar uBoot in your E02. Mine shows "Pogoplug E02". Not sure what effect this would have on things. (My guess is that it would likely work if you aren't concerned about areas where the two devices are architecturally different.)

2. Wheezy is designed for a 3.2 kernel. Not sure what effect running a 2.6 kernel would have on it. (Can you even run a mkimage from another machine of a different architecture? I have no idea.)

Is there anything in /var/log/dmesg? (You may have to take the disk / thumb drive to another machine to mount the /var partition and look at it.)

Good luck!

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.