Fabio
Goflexnet ethernet auto negotiation
July 18, 2022 05:22AM
With the latest releases of the 5.15.x series kernel compiled by me for the goflexnet thank to the patches provided by bodhi, the auto-negotiation of the ethernet interface does not seem to work. If I send the command "ifdown eth0 & ifup eth0" the network is not reconfigured and I lose the connection with ssh. If in "/etc/network /interace" I put the line "pre-up ethtool -s eth0 autoneg off duplex full speed 1000" everything works. Any suggestions for making the auto-negotiation of the ethernet interface work?
Re: Goflexnet ethernet auto negotiation
July 18, 2022 03:13PM
Fabio,

On my GoFlex Net, it does work for me to do "ifdown eth0 & ifup eth0" and did not lose the connection with SSH.

Here is ethtool output looks like.

~# ethtool eth0

Settings for eth0:
	Supported ports: [ TP	 MII ]
	Supported link modes:   10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full
	                                     100baseT/Half 100baseT/Full
	                                     1000baseT/Full
	Link partner advertised pause frame use: Symmetric
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Auto-negotiation: on
	master-slave cfg: preferred slave
	master-slave status: slave
	Port: Twisted Pair
	PHYAD: 0
	Transceiver: external
	MDI-X: Unknown
	Supports Wake-on: d
	Wake-on: d
	Link detected: yes

Do down/up.

~# ifdown eth0 & ifup eth0
[1] 18258
ifup: waiting for lock on /run/network/ifstate.eth0
[1]+  Done                    ifdown eth0
~#

~# myinfo 

Seagate GoFlex Net
Linux version 5.18.6-kirkwood-tld-1 (root@tldDebian) (gcc (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1.0 PREEMPT Fri Jun 24 15:26:02 PDT 2022
Debian 11.1

-bodhi
===========================
Forum Wiki
bodhi's corner
Fabio
Re: Goflexnet ethernet auto negotiation
July 18, 2022 04:11PM
Thank for your reponse bodhi.I'm running kernel 5.15.55 compiled by me with your patches applied and the situation is that described in my previous post i.e. if I not disable auto negotiation of the ethernet port with ethtool the network goes down after the command "ifdown eth0 && ifup eth0". My ethtool info seems the same.
~# ethtool eth0
Settings for eth0:
	Supported ports: [ TP	 MII ]
	Supported link modes:   10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Advertised pause frame use: No
	Advertised auto-negotiation: No
	Advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Auto-negotiation: off
	master-slave cfg: preferred slave
	master-slave status: slave
	Port: Twisted Pair
	PHYAD: 0
	Transceiver: external
	MDI-X: Unknown
	Supports Wake-on: d
	Wake-on: d
	Link detected: yes
Fabio
Re: Goflexnet ethernet auto negotiation
July 18, 2022 04:18PM
My info
Seagate Goflex Net
Linux version 5.15.55-kirkwood-tld-1 (fabio@VBoxUbuntuMacBookFabio) (arm-linux-gnueabi-gcc (Ubuntu 11.2.0-17ubuntu1) 11.2.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #1 PREEMPT Sun Jul 17 10:56:23 CEST 2022
Debian 11.1
Fabio
Re: Goflexnet ethernet auto negotiation
July 18, 2022 04:21PM
Sorry, Debian release is 11.4
Re: Goflexnet ethernet auto negotiation
July 18, 2022 07:11PM
Fabio,

I assumed that you used my config file and patches from the tarball, without changing anything?

Is this box connected to a switch, that the SSH session box is connected to? You should try to plug in both to the same switch/router, and do down/up to see if it behaves differently.

Kernel 5.15.x should not be a factor.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 07/18/2022 07:13PM by bodhi.
Re: Goflexnet ethernet auto negotiation
July 18, 2022 08:45PM
Hard to compare if you turned of auto-negotiation, turn it on and see if it is actually the same as mine.

Auto-negotiation: on
Advertised auto-negotiation: Yes

-bodhi
===========================
Forum Wiki
bodhi's corner
Fabio
Re: Goflexnet ethernet auto negotiation
July 19, 2022 03:33AM
Bodhi,
I connected via ssh to the golfex network from another golfex network connected to the same switch. The result is the same: the connection is not reestablished after the "ifdown eth0 && ifup eth0" command. Automatic negotiation was active on the machine to which the connection was made..
....
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
....
I think that the problem is kernel related as starting the machine with an old kernel installed on it (5.2.9) the problem go away.
Fabio
Re: Goflexnet ethernet auto negotiation
July 19, 2022 03:38AM
And ... Yes, for compiling the kernel on Ubuntu 22.0.4 running on VirtualBox on a MacBook pro, I used your config file and patches from the tarball, without changing anything.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: