Welcome! Log In Create A New Profile


Build your own Pro NAS – Seagate Goflex Net with Debian Linux, RAID1 and OpenMediaVault

Posted by DonCharisma 
Since all the posts here are quite old, I have tried to install OMV using the description found here


/etc/apt/sources.list.d/openmediavault.list looks like that

deb http://packages.openmediavault.org/public arrakis main
# deb http://downloads.sourceforge.net/project/openmediavault/packages arrakis main
## Uncomment the following line to add software from the proposed repository.
deb http://packages.openmediavault.org/public arrakis-proposed main
# deb http://downloads.sourceforge.net/project/openmediavault/packages arrakis-proposed main
## This software is not part of OpenMediaVault, but is offered by third-party
## developers as a service to OpenMediaVault users.
deb http://packages.openmediavault.org/public arrakis partner
# deb http://downloads.sourceforge.net/project/openmediavault/packages arrakis partner

afterwards invoked

export LANG=C
export DEBIAN_FRONTEND=noninteractive
apt-get update
apt-get --allow-unauthenticated install openmediavault-keyring
apt-get update

... then

apt-get --yes --auto-remove --show-upgraded \
    --allow-downgrades --allow-change-held-packages \
    --no-install-recommends \
    --option Dpkg::Options::="--force-confdef" \
    --option DPkg::Options::="--force-confold" \
    install postfix openmediavault

At that step the download-and-install-magic should take place, but there are two points with problems, the last one freezes the installation

First one does not freeze the installation process

[....] Not starting S.M.A.R.T. daemon smartd, disabled via /etc/default/smartmontoo[warn. (warning).
Setting up mdadm (3.4-4+b1) ...
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

But this here does

Warning: The home dir /run/proftpd you specified can't be accessed: No such file or directory
Adding system user `proftpd' (UID 111) ...
Adding new user `proftpd' (UID 111) with group `nogroup' ...update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Not creating home directory `/run/proftpd'.
Adding system user `ftp' (UID 112) ...
Adding new user `ftp' (UID 112) with group `nogroup' ...
Creating home directory `/srv/ftp' ...
'/usr/share/proftpd/templates/welcome.msg' -> '/srv/ftp/welcome.msg.proftpd-new'
[ ok ] Starting ftp server: proftpd.
At that point the installation freezes

A check done by opening a second ssh console shows that /run/proftpd is existing ...

After "shutdown -h now" and cycling power, the system is not longer accessible by ssh, serial console reports...

root@debian:~# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 20  bytes 1320 (1.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 20  bytes 1320 (1.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

no more network connections ...

Edited 3 time(s). Last edit at 11/02/2018 03:09AM by Martin aus Dortmund.
Did you read this Install Procedure?:

erasmus is for debian 8 and arrakis for debian 9.

I didnt try arrakis for the moment, but i got running erasmus on debian 8 (Jessie) on the GFN some month ago.
I think it was Jessie:
Debian-4.4.0-kirkwood-tld-1-rootfs-bodhi.tar.bz2 with kernel 4.11.3

Edited 2 time(s). Last edit at 11/02/2018 04:30AM by joerg_999.
Except two lines where I have removed the comment prefix "#" it seems to be identically...

EDIT: Second try with a cleaned up USB Stick and newly installed Debian 4.18-4 (I have made some backups of several stages of created USB sticks according to https://forum.doozan.com/read.php?2,12096,24034#msg-24034, that makes this an easy and fast job...)

Now I tried it without any changes.... no success.

Perhaps the "xmlstartlet" problem is not fixed, and the procedure mentioned here is necessary ....


Get xmlstarlet 1.5.0-1 and install it:

wget http://ftp.us.debian.org/debian/pool/main/x/xmlstarlet/xmlstarlet_1.5.0-1_armel.deb
dpkg -i xmlstarlet_1.5.0-1_armel.deb

EDIT 2 Now I used serial console to shutdown dockstar

shutdown -h now
on serial console, the setup on ssh console resumed

[ ok ] Starting ftp server: proftpd.
here the setup was freezed, and continues after shutdown command ...
Setting up php-xml (1:7.0+49) ...
Setting up xmlstarlet (1.6.1-2) ...
Setting up libpython-stdlib:armel (2.7.13-2) ...
Setting up libtevent0:armel (0.9.31-1) ...
Setting up collectd-core (5.7.1-1.1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/collectd.service -> /lib/systemd/system/collectd.service.

XMLStartlet seems to be quite ok ... concerning the version number ...

That seems to be a similar problem.
I dont think, that it is the correct solution to use elder versions.
I think I will drop my plan to use OMV on Dockstar, perhaps it is really too memory demanding ...


Edited 5 time(s). Last edit at 11/02/2018 10:33AM by Martin aus Dortmund.
Martin aus Dortmund,

If you would like to install OMV on armv5 the easiest way is via softy script https://github.com/armbian/config. The script is optimised for armv7, however, some of the software installations work on armv5 out of the box, others do after some changes in the script.

I have tested OMV. It did install and was running fine, but most of the extra plugins would not work on armv5. Most of the management and tasks on the NAS I do via ssh anyway, so I have removed OMV as it was interfering with the apt install as well for some reason.

I have used the softy script to install TV headend, Syncthing, Transmission and MiniDLNA. Currently, all running nicely. The other software in the script I did not try. Docker and newer nodejs do not work on armv5. Back up your system before you use the script, uninstalling the software is not as straightforward.


Since I only wanted to have a simple SMB share and some family calendars. I fell back to quite simple solution

- Samba for making attached USB HDD accessible from our home net
- Radicale for the family calendars https://radicale.org/
- smartmontools for periodic hdd health checks

Up to now rights management is nearly not existing (everyone in our home net can access hdd, and calendars ...) That's one point I want to take care of.
Thats something I expected advantages using OMV ...

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.