Welcome! Log In Create A New Profile


Arch Linux Seagate Goflex Home (SG-GFH) was fully operational but now not getting IP address after plugging in USB Western Digital My Book Essentials (USB-WD-MBE) and restarting

Posted by MaxMcByte 
Hello Archers!

Arch Linux Seagate Goflex Home (SG-GFH) was fully operational but now not getting IP address after plugging in USB Western Digital My Book Essentials (USB-WD-MBE) and restarting.

1 NetGear WND3700 v2 router.
1 Laptop computer (LT-A) running Ubuntu Linux 12.04 .
1 Seagate GoFlex Home (SG-GFH) with Arch Linux) connected directly to router.
1 USB Western Digital My Book Esstentials (USB-WD-MBE)

Recently installed Arch Linux on SG-GFH.
Setup 3 partitions - 1st partition for system, 2nd for swap and 3rd for data.
Create mount point for 3rd partition.
Setup NFS.
Installed some additional packages, Webmin, etc.
Everything seemed to be working fine.

Connected USB-WD-MBE to LT-A.
Used Filezilla to successfully copy 150 GBs of data from LT-A/USB-WD-MBE to the SG-GFH. Transfer rate was very slow.

To see if I could get better transfer speed I plugged in the USB-WD-MBE into the USB port on the SG-GFH.
I verified that the SG-GFH was seeing the USB-WD-MBE (/dev/sdc). I did not setup any mount points or modify fstab, etc.

I restarted the SG-GFH with the USB-WD-MBE plugged in and now not getting IP address.

So, I shutdown everything and powered up again, still no ip.
Then, I disconnected the USB-WD-MBE and powered up, still no ip.

I shutdown everything again and pulled the disk from the SG-GFH.
Upon restart, I could see that the router assigned to the device named "ALARM".

I can ping successfully *** BUT *** I cannot ssh into it "Connection refused".

$ ssh -v root@
OpenSSH_5.9p1 Debian-5ubuntu1.1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host port 22: Connection refused

Ran port scan (Network Tools) nothing returned.

So what can I do. Is it possible to get it back?
I am not sure if the USB-WD-MBE had anything to do with this.
I cannot ssh in and not even sure if I can do a complete re-install.

Any assistance much appreciated!


It probably quicker to get help if you ask at Arch forum. In any case, for the "connection refused" problem, did you wait long enough? I would wait about 5 minutes or longer to see if you can ssh in.

Forum Wiki
bodhi's corner (buy bodhi a beer)
Hi bodhi ,

Yes, I realized after I posted that this forum was not for Arch Linux, sorry about that.

I do appreciate your response. Yes, I did wait longer than 5 minutes and still no IP.

Will post over at Arch Linux.

BTW - I did read some of your other posts as I was setting up the SG-GFH and they helped me out with other aspects. thanks much.



Plugging in the Western Digital My Book Essentials HDD should not cause problem like that! if you can't get it solved at Arch site, come back here and we'll help.

Forum Wiki
bodhi's corner (buy bodhi a beer)
If I remember correctly, some of the WD drives have a USB to SATA controller that also implements an extra (virtual) drive. That very virtual drive could probably get in the way and hinder the normal boot process. ;-) Worth checking out, I think.
Hi Ingmar,

Thanks for that info. Not sure if it applies to my situation. I have a Western Digital My Book Essential 3TB unit.

Power off;
I removed the Western Digital My Book Essentials (USB-WD-MBE) placed a boot-able USB with Arch Linux on it into the USB port on the SeaGate GoFlex 2TB (SG-GFH) .

Power on;
The SG-GFH is recognized by the router and is assigned an IP address "".
I cannot ssh into the SG-GFH. "Connection Refused".

Am wondering if one can ssh into a session started by a boot-able USB with Arch Linux on it if I did not setup ssh. It was a week ago I setup the boot-able USB and I do not recall doing anything special to it. I have to review.

Question: Does one need to do anything special to be able to ssh into a session that was initiated by a boot-able USB Arch Linux?

It would be nice if I could just recover what I already had. However, at this point I would be happy to just do a complete re-install. But, I would need to be able to ssh into the SG-GFH to start the process and do not know how to proceed at this point.

I honestly do not care if I am using Arch Linux or Debian on the SG-GFH. However, please note I have been a very happy camper using Debian variations Mint and Ubuntu. I only choose Arch Linux as there was existing docs on how to convert a SeaGate GoFlex using Arch Linux as I was disgusted with the out of the box unit provided by SeaGate.

Since I can boot the SG-GFH with the USB (SanDisk Cruiser - Arch Linux on it) and get an IP address but no ssh, is there anything I can do to reinstall either Debian or Arch Linux onto the SG-GFH?



Edited 9 time(s). Last edit at 11/10/2013 11:28PM by MaxMcByte.

Easiest way to boot Debian on GoFlex Home is to use this rootfs (latest is version 3.12.0).

Forum Wiki
bodhi's corner (buy bodhi a beer)
Hi bodhi/Ingmar;

I went over to the Arch Linux site (as suggested in the earlier posts) and presented the same question. It has been 5 days and no response. On this site, I have received multiple responses and have a potential solution! Not sure if it will work but now I have a direction and hope!

To be sucessful with a new unfamilar technology, the community that works with it and shares that experience is worth far more than a technologist blogging about how they suceeded in doing a particular operation.

This community has responded to direct queries and provided insights. It is in this way that I have to say this community rocks!

Thank you.

I went ahead and created a bootable USB (San Disk Cruiser) with Debian on it using the info "Linux Kernel 3.12.0 Kirkwood package and rootfs (Non Flattened Device Tree)" at http://forum.doozan.com/read.php?2,12096.

I was able to boot-up the SG-GFH but could not get an IP. (I did remove the SATA drive prior to boot up.)

Frustrated but determined, I decided to try one more time with Arch Linux. I went ahead and *** re-created *** another bootable USB with Arch Linux on it and this time the SG-GFH booted up with IP and I can ssh into it! Something must have happened to my other USB with Arch Linux on it. With the original bootable USB/Arch Linux that I created I could get an IP address but *** could not ssh (connection refused) ***, weird!!!

After booting up with the new bootable USB/Arch Linux, I placed the SATA drive in the craddle and mounted the partitions on sdb and they all (sdb1 - system, sdb2 - swap, sdb3 - large partition for data) appear normal.

I was ready to go down the Debain path but since my stuff on the drive is intact I want to be able to boot like before.

I want to boot using Arch Linux with the SATA drive in the craddle. I do not want to boot with the USB/Flash/Arch Linux.

How can I accomplish this?

Currently, the boot flag is set on the existing sdb1 partiton. But, if I remove the bootable USB/Arch Linux and starting with the SATA drive in the craddle (SATA now becomes sda1) is the same as it was before, have a green light but no IP.

If I use the bootable USB/Arch Linux I get IP, can ssh and see the existing partitons on the SATA drive.

Any tips greatly appreciated!


Edited 11 time(s). Last edit at 11/14/2013 02:16AM by MaxMcByte.

To make sure that udev does not reassign eth0/eth1 every boot, see this post:
Those 2 files mentioned in there are important. Mount the disk on another Linux box, or Live CD and check and correct those files. Your problem might have been as simple as that.

To boot with SATA, you will need to change uBoot envs.

Below are 4 necessary SATA boot commands. Set them with fw_setenv in Linux.
For example
fw_setenv boot_debian 'bootm 0x800000 0x1100000'
fw_setenv boot_arch 'bootm 0x800000'

boot_debian=bootm 0x800000 0x1100000
sata_bootcmd=run usb_set_bootargs; run sata_boot
sata_boot=ide reset; mw 0x800000 0 1; ext2load ide 0:1 0x800000 /boot/uImage; if ext2load ide 0:1 0x1100000 /boot/uInitrd; then run boot_debian; else bootm 0x800000; fi
bootcmd=usb start; run force_rescue_bootcmd; run ubifs_bootcmd; run usb_bootcmd; usb stop; run sata_bootcmd; run rescue_bootcmd; run pogo_bootcmd; reset

Before you try to set the envs in Debian or Arch, you can post them here for sanitycheck! Also please post your output of fw_printenv. But the very important thing to do is to setup netconsole first (before changing uBoot envs) if you don't have serial console:

Forum Wiki
bodhi's corner (buy bodhi a beer)

Edited 2 time(s). Last edit at 11/14/2013 02:43AM by bodhi.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.