Welcome! Log In Create A New Profile


Dockstar won't boot, no lights, no netconsole

Posted by JohnXX 
Dockstar won't boot, no lights, no netconsole
March 29, 2014 10:04PM
I've been running a Debian Wheezy install based on bodhi's 3.10.4 kernel/rootfs since September or so and everything's been working great. Of course that meant I just had to go and fiddle with things. I upgraded to the newest (3.13.1) kernel, followed the directions to the letter, went to reboot and ... nothing. The Dockstar's light doesn't turn on at all and the light on the USB drive holding the rootfs flashes on once then stays off. I tried to see what it was doing via netconsole (which I have setup according to the guide and has worked previously), but got nothing. I thought I might have misremembered the IP address it was supposed to send to, so I plugged it into my laptop with a crossover cable, and see no activity from it as it boots up. I also tried it with a different power brick just to make sure that wasn't the issue.

The only thing that I can think of is that there might be something wrong with the onboard flash. It stopped being able to boot into the Seagate distro on mtd over a year ago and I almost wrote it off for dead at that point, but it was apparently still able to boot from USB.

So my questions are:
  1. When does the LED first come on in the boot process?
  2. Is there anything worth trying without a serial or JTAG cable that I haven't thought of?
  3. Is it worth putting together a serial cable and trying to revive it, or is it probably dead?
Re: Dockstar won't boot, no lights, no netconsole
March 30, 2014 03:37PM

If you have not changed any of U-Boot envs (you have only played with rootfs), then it does not hurt to try these first:

- On a different Linux box, fsck your rootfs to see if there is any error. Cold boot after the check. If this did not boot then,
- Make a basic fresh rootfs on a different USB stick, and try to boot with that.

The LED should be green after the U-Boot has loaded the kernel and ramdisk. Hopefully your rootfs USB just really bad that U-Boot can't read them. But usually it flashes before that.

It is definitely worthwhile to get serial console install to try to revive it. If you can get it to boot U-Boot and interrupt serial console, then the chance to make it work is very high, even some of the NAND is bad.

Forum Wiki
bodhi's corner (buy bodhi a beer)

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.