Welcome! Log In Create A New Profile

Advanced

(SOLVED) How to enable smb2 / smb3

Posted by Almaz 
(SOLVED) How to enable smb2 / smb3
June 07, 2015 08:52PM
I'd like to try SMB2 / SMB3 between pogoplug and windows 8.1 but so far I can't get it to work. Windows 8.1 reports connection as SMB1. Here is my smb.conf. Should I add security to enable SMB3?


[global]
        client min protocol = SMB2
        client max protocol = SMB3
	log level = 0
	log file = /tmp/%m.log
	guest account = root
	load printers = no
	socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE
	wins server = 192.168.1.1
	map to guest = Bad User
	netbios name = POGOPLUG
	write cache size = 2097152
	server string = POGOPLUG
	printing = bsd
	workgroup = WORKGROUP
	os level = 20
	use sendfile = yes
	printcap name = /dev/null
	security = user
	disable spoolss = yes

 #unprotected/public share without login
 
[root]
  path = /
  read only = no
  public = yes
  writable = yes

[usb]
  path = /mnt/usb
  read only = no
  public = yes
  writable = yes



Edited 1 time(s). Last edit at 06/07/2015 09:53PM by Almaz.
Re: How to enable smb2 / smb3
June 07, 2015 09:52PM
Problem solved by adding security
Winter
Re: (SOLVED) How to enable smb2 / smb3
May 23, 2016 03:35AM
Hello , help please. The problem SMB2 Windows 7. How to configure smb.conf
Re: (SOLVED) How to enable smb2 / smb3
May 27, 2016 10:53AM
@Winter
post up your smb.conf and we will have a look

a good starter smb.conf is the following one - amend your folders to suit

#======================= Global Settings =======================
[global]
   workgroup = WORKGROUP
   server string = %h server
   dns proxy = no
#### Networking ####
#### Debugging/Accounting ####
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
####### Authentication #######
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
########## Domains ###########
########## Printing ##########
############ Misc ############
   socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE SO_RCVBUF=131072 SO_SNDBUF=131072
   use sendfile = yes
   write cache size = 2097152
   usershare allow guests = yes
#======================= Share Definitions =======================
[homes]
   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0755
   directory mask = 0755
   valid users = %S

[Shared1]
path = /media/external/Downloads
available = yes
read only = no
browseable = yes
public = yes
writable = yes
create mask = 0777
directory mask = 0777

[Shared2]
path = /media/external/Incomplete
available = yes
read only = no
browseable = yes
public = yes
writable = yes
create mask = 0777
directory mask = 0777



Edited 1 time(s). Last edit at 05/27/2016 11:05AM by Gravelrash.
Winter
Re: (SOLVED) How to enable smb2 / smb3
June 01, 2016 06:14AM
Thank you. I have fixed the problem .
Re: (SOLVED) How to enable smb2 / smb3
June 09, 2016 12:13PM
Hi,

I can see the share on Thunar, click on it and it asked for user name and password: root/root does not work.

After using those credentials, I get: "Failed to mount Windows share: No such file or directory."

I know there's such a directory because it shows up as a share, I only can't access it.

I have done nothing else to the config as used here, than specify my share.

I reckoned I'd make a note first and not mess about with the config.
Sanjay
Re: (SOLVED) How to enable smb2 / smb3
May 23, 2017 03:33AM
Hi

How did you fix this?
Re: (SOLVED) How to enable smb2 / smb3
June 02, 2017 09:20AM
post up your samba configs and ill see if i can help you out. there is a tutorial on the subject in Bodhi's wiki. which should give you a clear start
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: