Dockstar won't mount a nfs drive
November 26, 2010 02:10PM
Hi, I have installed the doozan stuff on my dockstar and it boots nicely from a usb stick. Thanks.

While playing, I enabled a nfs server on my Ubuntu Lucid laptop.

I have tried several /etc/export combos on my server but it always fails - from /etc/exports:


But when I try to connect from the dockstar I get:

root@debian:/tmp# mount /tmp/mnt
mount: wrong fs type, bad option, bad superblock on,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)
In some cases useful info is found in syslog - try
dmesg | tail or so

root@debian:/tmp# smbclient
-bash: smbclient: command not found
root@debian:/tmp# dmesg | tail
[ 1968.963325] eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[ 1968.970143] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1979.825614] eth0: no IPv6 routers present
[ 8281.691407] RPC: Registered udp transport module.
[ 8281.696172] RPC: Registered tcp transport module.
[ 8281.700897] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 8281.775503] Slow work thread pool: Starting up
[ 8281.780153] Slow work thread pool: Ready
[ 8281.785040] FS-Cache: Loaded
[ 8281.916908] FS-Cache: Netfs 'nfs' registered for caching

Has anyone else successfully mounted a nfs drive? Is the problem likely to be my server or client? I only have the one system here, but the ubuntu successfully mounts its own nfs drive locally, so I think the server is ok.

Thanks, Steve
Re: Dockstar won't mount a nfs drive
November 26, 2010 02:24PM
I'm doing the opposite -- using the Dockstar to serve up NFS files. But, the NFS package isn't loaded by default. Try:

# apt-get install nfs-kernel-server nfs-common portmap

Edited 1 time(s). Last edit at 11/26/2010 02:26PM by restamp.
Re: Dockstar won't mount a nfs drive
November 27, 2010 09:58AM
Hi, thanks for the reply.

You were not clear. Are you talking about installing that on Ubuntu? I already have nfs client and server working there. Does apt-get work on the dockstar? If it does I'll have to get it set up with an internet connection to get components....

What I want to do is allow the dockstar to attach via nfs so I can test some test apps, without moving the usb drive. I have not yet tried to boot the kernel using a nfs file system. I don't have a working file system image, so I guess I can use the doozan fs and try it.

It is always nice to keep the unknowns minimized when trying new things like booting from nfs.

Thanks, Steve
Re: Dockstar won't mount a nfs drive
November 27, 2010 11:04AM
SteevO, I believe you want to attach an exported Ubuntu directory to your Dockstar. I needed to do the opposite, namely to export a directory on my Dockstar to other machines. I'm not sure what is the minimal subset of packages you need to install do do what you want to do, but I know after doing the above apt-get on the Dockstar, I am able to both use the Dockstar as an NFS server and NFS client. Presumably, the NFS server code is already on your Ubuntu desktop box if you are able to successfully export it to other machines on your local LAN, so nothing more needs to be done there, except possibly adding the Dockstar's IP to the list of potential clients.

Good luck with it.
Re: Dockstar won't mount a nfs drive
November 27, 2010 01:38PM
Hi Thanks for the info.

I did not know that apt-get was in the doozan distribution.

Ok, so now I have to somehow get it onto the internet. Back to googling how to bridge from the ethernet x/o cable to my laptop through the wireless connection I have here at my home. I learn stuff everyday, even if I don't particularly want to know it.

Using the doozan u-boot I can download files via nfs, so I know the server is ok. By the way, there is a weird issue where u-boot says it cannot umount. It requires putting a line in /etc/hosts so the disconnect works too. Strange that it allows a mount but not a umount:

cat /etc/hosts localhost Gracie Dockstar

And for my nfs /etc/exports:
cat /etc/exports
# /etc/exports: the access control list for filesystems which may be exported
Re: Dockstar won't mount a nfs drive
November 29, 2010 12:25PM
SteveO Wrote:
> I did not know that apt-get was in the doozan
> distribution.

It may be worth mentioning that Jeff has not created a distro but has given us an easy way to install a standard (albeit minimal) Debian distro. Consequently, anything that normally comes with Debian is either already there or available from the repos. All Debian based distros include apt-get (it's fundamentally important).

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.