Welcome! Log In Create A New Profile


Drive upgrade failed...Any ideas why?

Posted by glalonde 
Drive upgrade failed...Any ideas why?
December 06, 2010 09:33PM
I'm currently running of a 8GB USB stick. I mounted the USB stick and a 40GB USB(SATA) drive on my main computer after rooting into ubuntu. Then I created 2 partitions(ext2 and swap) on the 40GB, did a dd to move the first partitions data from the USB stick to the 40GB drive's first partition.

I tried to boot of the 40GB USB drive, but no luck. I did see the lights flash for drive access a few times but the system never booted. I did not see any attributes on the partition(bootable or whatever) when I looked at it once mounted on my machine machine. Any ideas what I did wrong?

Re: Drive upgrade failed...Any ideas why?
December 07, 2010 04:37PM
Check /etc/fstab and make sure that your static file system info is correct. You may (or may not) have UUID strings in there that are pointing to the old flash drive instead of the new hard drive. I'd check to see if the mount points are correct as well.
Re: Drive upgrade failed...Any ideas why?
December 07, 2010 06:07PM
Hi Rat,
This sounds similar to my prob with not being able to mount my hard drive.
My fstab file ...

proc /proc proc defaults 0 0
devpts /dev/pts devpts gid=4,mode=620 0 0

This does not look like anything about the old flash drive does it?
Re: Drive upgrade failed...Any ideas why?
December 07, 2010 08:39PM
Got it resolved. This is what I did.

1. tried to boot again, seemed to fail.
2. mounted drive on main pc along with old USB stick.
3. USB stick did not have first partition set to 'bootable' but I just thought I would try that on the new drives' first partition.
4. Tried booting new drive, seemed to try once, then again, but on second boot it worked. Since then it seems ok.
5. noticed cfdisk showed correct sizes, 30GB data and 10GB swap, but df showed old sizes.
6. remounted on main pc, ran resize2fs to change the filesystem sizes.

Everthing looks ok now. Not sure if that all was logical but it did seem to get it working.

Took a quick look at fstab, but did not see anything of interest.

This is my /etc/fstab:
# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/root / ext2 noatime,errors=remount-ro 0 1
/dev/sda2 none swap sw 0 0
tmpfs /tmp tmpfs defaults 0 0

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.