Welcome! Log In Create A New Profile

Advanced

Netgear Stora booting problem in Kernel 4.11.3 Kirkwood

Posted by t00 
Hello.
I installed 4.11.3 on netgear stora and it doesn't boot anymore.
root@stora:~# systemctl status home.mount
● home.mount - /home
Loaded: loaded (/etc/fstab)
Active: failed (Result: exit-code) since Sun 2017-06-04 21:02:45 MSK; 1min 8s ago
Where: /home
What: /dev/sda1
Docs: man:fstab(5)
man:systemd-fstab-generator(8)
Process: 286 ExecMount=/bin/mount -n /dev/sda1 /home -t xfs (code=exited, status=32)

root@stora:~# insmod /lib/modules/4.11.3-kirkwood-tld-1/kernel/fs/xfs/xfs.ko
[ 169.001091] xfs: Unknown symbol crc32c (err 0)
insmod: ERROR: could not insert module /lib/modules/4.11.3-kirkwood-tld-1/kernel/fs/xfs/xfs.ko: Unknown symbol in module

Something worn with modules? I'll try to rebuild kernel by myself with your patch and config.



Edited 1 time(s). Last edit at 06/04/2017 12:24PM by bodhi.
Re: Netgear Stora booting problem in Kernel 4.11.3 Kirkwood
June 04, 2017 12:26PM
t00 Wrote:
-------------------------------------------------------
> Hello.
> I installed 4.11.3 on netgear stora and it doesn't
> boot anymore.
> root@stora:~# systemctl status home.mount
> ● home.mount - /home
> Loaded: loaded (/etc/fstab)
> Active: failed (Result: exit-code) since Sun 20
> 17-06-04 21:02:45 MSK; 1min 8s ago
> Where: /home
> What: /dev/sda1
> Docs: man:fstab(5)
> man:systemd-fstab-generator(8)
> Process: 286 ExecMount=/bin/mount -n /dev/sda1 /
> home -t xfs (code=exited, status=32)
>
> root@stora:~# insmod /lib/modules/4.11.3-kirkwood-
> tld-1/kernel/fs/xfs/xfs.ko
> [ 169.001091] xfs: Unknown symbol crc32c (err 0)
> insmod: ERROR: could not insert module /lib/module
> s/4.11.3-kirkwood-tld-1/kernel/fs/xfs/xfs.ko: Unkn
> own symbol in module
>
> Something worn with modules? I'll try to rebuild k
> ernel by myself with your patch and config.

It seems there are changes in modules loading behavior in kernel 4.11. I'm not using xfs so not sure what is wrong here.

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner
Re: Netgear Stora booting problem in Kernel 4.11.3 Kirkwood
June 04, 2017 01:04PM
Can you boot back to the 4.10.9 kernel and force the xfs module loading in

/etc/initramfs-tools/modules

And then regenerate initramfs and uInitrd.

Reboot and switch to kernel 4.11.3. Regenerate initramfs again.

-----

In hind sight, It might better if I had recompiled the kernel to include all file systems in the kernel (instead of configuring as modules).

-bodhi
===========================
Wiki
latest Kirkwood kernel builds and rootfs
latest u-boot-kirkwood builds
latest Oxnas kernel builds and rootfs
latest u-boot-oxnas builds
latest MVEBU Armada kernel builds and rootfs
U-Boot & Kernel Booting process
bodhi's u-boot GitHub
bodhi's corner
I have recompiled kernel and enabled xfs as build-in module. Also I enabled as build-in usb storage and SCSI and was able to successfully boot system.

I upgraded from 4.8.3 kernel, I didn't install 4.10 on device.

Anyway - problem is solved, thank you for your work and assistance.

Maybe it's good choise to include all well-known filesystems by default.
Re: Netgear Stora booting problem in Kernel 4.11.3 Kirkwood
June 04, 2017 02:16PM
Re: Netgear Stora booting problem in Kernel 4.11.3 Kirkwood
June 08, 2017 04:17PM
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: