Welcome! Log In Create A New Profile

Advanced

Need help with Lenovo ix2-ng

Posted by AlDaniel 
Need help with Lenovo ix2-ng
July 17, 2019 04:02PM
Hello, I have recently received a Lenovo ix2-ng NAS in order to make from it a DLNA server for Tv Shows and Movies. Using the stock firmware that has a version of Twonky it is unable to load the subtitle file.
Thus through my research of alternatives to the stock firmware I have reached to your forum.
Currently I am having issues with booting Debian from a usb stick due to a uboot read error.

Commands done to create the usb stick on an Ubuntu environment:
0. sudo su => All commands were run under root@AlDaniel
1. Used gparted to format the usb stick with ext2 and the name rootfs
2. mount /dev/sdg1 /media/sdb1/
3. cd /media/sdb1/
4. tar -xjf Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2
5. cd etc/
6. vi fstab
7. Modified fstab by changing ext3 to ext2
8. cd ..
9. cd boot/
10. cp -a zImage-4.12.1-kirkwood-tld-1  zImage.fdt
11. cat dts/kirkwood-lenovo-ix2-ng.dtb  >> zImage.fdt
12. mv uImage uImage.orig
13. mkimage -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -n Linux-4.12.1-kirkwood-tld-1 -d zImage.fdt  uImage
14. sync
15. cd /home/
16. umount /media/sdb1/

Commands done to Marvell Uboot via GtkTerm:
setenv load_initrd 'ext2load usb 0:1 0x2100000 /boot/uInitrd'
setenv load_uimage 'ext2load usb 0:1 0x800000 /boot/uImage'
setenv bootargs 'console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 mtdparts=orion_nand:0x80000@0(uboot),0x20000@0xa0000 (env),0x20000@0xc0000(env2),0x300000@0x100000(uImage),0x400000@0x400000(initrd),0x3f800000@0x800000 (boot),1024m@0x0(flash) earlyprintk=serial'
setenv usb_boot 'usb start; run load_uimage; run load_initrd; bootm 0x800000 0x2100000'
setenv bootcmd 'run usb_boot'
setenv usb_root 'LABEL=rootfs'
setenv rootdelay 10
boot

GtkTerm output after boot:
(Re)start USB...
USB:   scanning bus for devices... 2 USB Device(s) found
Waiting for storage device(s) to settle before scanning...
1 Storage Device(s) found
T T T T T T T T T T T T T T T T T T T T T T T T T T T T T T Device NOT ready
   Request Sense returned 00 00 00
T T T T T T T T T T T T T T T T T T T T T T Device NOT ready
   Request Sense returned 00 00 00
 ** ext2fs_devread() read error **

** Unable to read "/boot/uImage" from usb 0:1 **
T T T T T T T T T T T T T T T T T T T T T T Device NOT ready
   Request Sense returned 00 00 00
** Can't read partition table on 0:0 **
** Bad partition 1 **
## Booting image at 00800000 ...
Bad Magic Number

Marvell Uboot printenv after powercycle:

         __  __                      _ _
        |  \/  | __ _ _ ____   _____| | |
        | |\/| |/ _` | '__\ \ / / _ \ | |
        | |  | | (_| | |   \ V /  __/ | |
        |_|  |_|\__,_|_|    \_/ \___|_|_|
 _   _     ____              _
| | | |   | __ )  ___   ___ | |_ 
| | | |___|  _ \ / _ \ / _ \| __| 
| |_| |___| |_) | (_) | (_) | |_ 
 \___/    |____/ \___/ \___/ \__|  ** ix2-spi ** ** uboot_ver:0.0.8 **

 ** MARVELL BOARD: DB-88F6282A-BP LE 

U-Boot 1.1.4 (Oct 28 2011 - 15:18:22) Marvell version: 3.6.1 - EMC

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 006CD5A0

Soc: 88F6282 A1 CPU running @ 1600Mhz L2 running @ 800Mhz
SysClock = 533Mhz , TClock = 200Mhz 

DRAM (DDR3) CAS Latency = 7 tRP = 7 tRAS = 20 tRCD=7
DRAM CS[0] base 0x00000000   size 256MB 
DRAM Total size 256MB  16bit width
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done
Found ADT7473, program PWM1 ... OK
[1024kB@f8000000] Flash:  1 MB

Marvell Serial ATA Adapter
Integrated Sata device found
[0 0 0]: Enable DMA mode (6)
  Device 0 @ 0 0:
Model: WDC WD800JD-75MSA3                       Firm: 10.01E04 Ser#:      WD-WMAM9AM21410
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 76293.9 MB = 74.5 GB (156250000 x 512)
[0 1 0]: Enable DMA mode (6)
  Device 1 @ 0 1:
Model: WDC WD800JD-75MSA3                       Firm: 10.01E04 Ser#:      WD-WMAM9SV29648
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 76292.9 MB = 74.5 GB (156247887 x 512)


CPU : Marvell Feroceon (Rev 1)

Streaming disabled 
Write allocate disabled


USB 0: host mode
PEX 0: interface detected no Link.
PEX 1: interface detected no Link.
Net:   egiga0 [PRIME]
Hit any key to stop autoboot:  0 
Marvell>> printenv
baudrate=115200
loads_echo=0
rootpath=/srv/ubuntu
netmask=255.255.255.0
run_diag=yes
MALLOC_len=1
ethprime=egiga0
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
lcd0_enable=0
lcd0_params=640x480-16@60
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev[0]:fxs,dev[1]:fxo
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
image_multi=yes
ethact=egiga0
console=console=ttyS0,115200
bootargs_root=root=/dev/ram0
bootargs_mtd=mtdparts=spi_flash:0x7e000@0(u-boot),0x1000@0x7f000(env),0x1000@0x7e000(env2)
kernelimage=zImage
initrdimage=mfginitrd
ipaddr=192.168.1.2
mfgmodel=ix2
preroot_ver=0.0.2
fw_ver=0.0.2
uboot_ver=0.0.8
serial_number=5563Y01001G216000A7J0A1
ethaddr=00:D0:B8:1D:BA:D2
serialNo=EUAC1800AV
modelname=31997200
serialno=0,01nrdpRPKLbEh/6nvg5IwLGlVkRu2Q85Gft0N3lR2L2oy1d5RAQiGOzlMCx+zlwdFt,EUAC1800AV,
runintime=10800
ftpserver=192.168.43.4
testfile=100M
mfgtest_state=system_tested_ok
pre_path=IX2/1.0.3/download_runin.sh
pre_path_conf=IX2/1.0.3/download_runin.conf
pre_serverip=192.168.32.4
pre_user=ixxrunin
pre_passwd=123
pre_dirzi=IX2/1.0.3
serverip=192.168.32.4
bootcmd2=ide dev 1;ide read 0x40000 0x800 0x1800; ide read 0x900000 0x2000 0x2000; bootm 0x40000 0x900000;
bootcmd=setenv bootargs console=ttyS0,115200n8 root=/dev/sda1; usb start; ext2load usb 0:1 0x00800000 /uImage; bootm 0x00800000
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=no
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes
pcieTune=no
pcieTune1=no

Environment size: 1909/4091 bytes
Re: Need help with Lenovo ix2-ng
July 17, 2019 10:28PM
Try a different usb stick.
Re: Need help with Lenovo ix2-ng
July 17, 2019 11:43PM
AlDaniel,

Quote

(Re)start USB...
USB: scanning bus for devices... 2 USB Device(s) found
Waiting for storage device(s) to settle before scanning...
1 Storage Device(s) found
T T T T T T T T T T T T T T T T T T T T T T T T T T T T T T Device NOT ready
Request Sense returned 00 00 00
T T T T T T T T T T T T T T T T T T T T T T Device NOT ready
Request Sense returned 00 00 00

This is a hardware problem. If there are more than 1 USB port on this box, try the other USB port. If not, try using a diffrent USB thumb drive. I'd prefer Sandisk brand (most reliable for booting).

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Need help with Lenovo ix2-ng
July 18, 2019 11:06AM
Changed the usb thumb drive and it works perfectly now. Thanks a lot guys.
Re: Need help with Lenovo ix2-ng
July 18, 2019 05:12PM
No worries, enjoy!
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: