Fail to install Debian
August 14, 2010 10:14PM
I am new to Linux. I got my dockstar a while ago and installed openpogo on it. A week ago I find Jeff's instruction on how to install Debian. I decided to give it a try. However, I forgot to remove the openpogo before I run Jeff's installation script. After reboot, I sshed in my dockstar and I saw "pogoplug:~$" instead of "-bash-3.2#". Since the password I used to log in was the old one, I was sure the debian didn't boot correctly. I tried to reboot many times but still got the same result.

Now I stuck here, don't know what to do. Could somebody give me a hand? What can I do to restore my device or boot into debian?

Re: Fail to install Debian
August 15, 2010 11:48AM
I"m having the same problem. Debian installed on the USB drive, but on reboot it is not mounting and not booting into debian. i'm gettin the same pogoplug:~$ prompt too with the old stxadmin password.

any ideas would be appreciated.
Re: Fail to install Debian
August 15, 2010 01:28PM
I've found the following sequence of steps works all the time :

- Unplug your USB drive
- Boot into pogoplug and ssh in to check
- Plug in USB drive. Wait 10 secs for it to initialize. Can check by doing "dmesg". It shld list your USB drive as /dev/sda
- /sbin/reboot OR pressing the reset button on the side also works

If its booting right, you shld hear/see your USB drive blinking a few secs after the Dockstar's LED stops blinking green. If not then its definitely not booting and try the sequence again.

Only other problem I can see is maybe your install failed in one of the steps. I'd try to reinstall it if all else fails and look for the error msgs.
Re: Fail to install Debian
August 15, 2010 05:22PM
After many reboots, hard shutdowns, reset button pushes, I was able to get debian to boot up.

It worked perfectly well. Until i issued a shutdown -r now command... now I cannot get debian to boot back up - nor can I get pogoplug to boot.

I'm now just getting a flashing green light....
Re: Fail to install Debian
August 15, 2010 06:43PM
I've spent many hours with it. There seems to be no logic to when it will boot into debian and when it will not.
Re: Fail to install Debian
August 16, 2010 07:37AM
Two Issues I saw on my Box:

1. insufficent user rights: try #su - (sometimes twice) at pogoplug login, dunno why.
2. System is mixing up drives in /etc/dev, if more than one usb storage is connected...


Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.