Welcome! Log In Create A New Profile

Advanced

Problem updating Debian version on Dell M300

Posted by mikeh49 
Problem updating Debian version on Dell M300
February 13, 2020 05:17PM
Tried to update the Debian 10 (Buster) file system on my Dell M300. Did apt-get update followed by apt-get upgrade and ran into this:
Processing triggers for initramfs-tools (0.133+deb10u1) ...
update-initramfs: Generating /boot/initrd.img-5.5.1-kirkwood-tld-1
W: missing /lib/modules/5.5.1-kirkwood-tld-1
W: Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/5.5.1-kirkwood-tld-1: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
cat: /var/tmp/mkinitramfs_vDDIAc/lib/modules/5.5.1-kirkwood-tld-1/modules.builtin: No such file or directory
find: '/var/tmp/mkinitramfs_vDDIAc/lib/modules/5.5.1-kirkwood-tld-1/kernel': No such file or directory
depmod: WARNING: could not open modules.order at /var/tmp/mkinitramfs_vDDIAc/lib/modules/5.5.1-kirkwood-tld-1: No such file or directory
depmod: WARNING: could not open modules.builtin at /var/tmp/mkinitramfs_vDDIAc/lib/modules/5.5.1-kirkwood-tld-1: No such file or directory

It looks like it created this image file:
-rw-r--r-- 1 root root 5007694 Feb 13 15:03 initrd.img-5.5.1-kirkwood-tld-1

It is about half the size of the 5.2.9 image files.

I did update-upgrade on a Pogo E02 last weekend and it worked fine including regenerating the uInitrd as directed after the updgrade completed.



Edited 1 time(s). Last edit at 02/13/2020 05:23PM by mikeh49.
Re: Problem updating Debian version on Dell M300
February 13, 2020 06:59PM
Mike,

Usually this problem occurs when you either:
- did not install kernel 5.5.1-kirkwood-tld-1 with dpkg, but only copy and use the uImage and uInitd to run the rootfs.
- or to you've accidentally removed the /lib/modules/5.5.1-kirkwood-tld-1.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Problem updating Debian version on Dell M300
February 13, 2020 07:31PM
I thought I followed your directions in the kernel thread. Can I rerun the dpkg of the .deb to get the modules? Or extract them from the .deb and put them in the right places?

The deb file is in the /boot folder. Is this OK, or should it be in /?

Looks like too many files to do manually -> dpkg -c > many, many files!



Edited 1 time(s). Last edit at 02/13/2020 07:51PM by mikeh49.
Re: Problem updating Debian version on Dell M300
February 14, 2020 12:45AM
Mike,

Run
dpkg -i linux-image-5.5.1-kirkwood-tld-1_1.0_armel.deb


If the kernel was installed, then it will say installing on top of existing kernel. It is OK to install the same kernel again.

The .deb file could anywhere, does not matter.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 02/14/2020 12:46AM by bodhi.
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: